summaryrefslogtreecommitdiffstats
path: root/development/psycopg2/psycopg2.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-01-17 09:33:04 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-20 07:01:19 +0700
commit22dd8479981b34fa1fc5262c875294292aa34c65 (patch)
tree39b16ee235a33219a95edb1c938bb95f3423771f /development/psycopg2/psycopg2.SlackBuild
parent903aa21b7eb609f6478d49a8c2f3f5a8bee45ec7 (diff)
downloadslackbuilds-22dd8479981b34fa1fc5262c875294292aa34c65.tar.gz
slackbuilds-22dd8479981b34fa1fc5262c875294292aa34c65.tar.xz
development/psycopg2: Updated for version 2.7.3.2 and new maintainer.
Diffstat (limited to 'development/psycopg2/psycopg2.SlackBuild')
-rw-r--r--development/psycopg2/psycopg2.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/development/psycopg2/psycopg2.SlackBuild b/development/psycopg2/psycopg2.SlackBuild
index 09666f73ec..9f50045cd3 100644
--- a/development/psycopg2/psycopg2.SlackBuild
+++ b/development/psycopg2/psycopg2.SlackBuild
@@ -4,6 +4,7 @@
# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
# Copyright (c) 2010-2011, 2013 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# Copyright (c) 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,13 +25,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psycopg2
-VERSION=${VERSION:-2.5.1}
+VERSION=${VERSION:-2.7.3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -54,16 +55,15 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep "shared object" | grep ELF | \
- cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE PKG-INFO README doc/*.txt \
- doc/html doc/HACKING doc/COPYING* \
+cp -a AUTHORS INSTALL LICENSE NEWS README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild