summaryrefslogtreecommitdiffstats
path: root/development/pudb
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2018-08-09 21:53:07 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-08-11 07:23:09 +0700
commitad3a81a2e1cce6ca9611d7ef2a16e301c27f0a14 (patch)
tree1a06fff6b0c84d06374ea3a99463fb3c2f99fc20 /development/pudb
parent22db108cd5ae8449ef0e65e657820addfac0d110 (diff)
downloadslackbuilds-ad3a81a2e1cce6ca9611d7ef2a16e301c27f0a14.tar.gz
slackbuilds-ad3a81a2e1cce6ca9611d7ef2a16e301c27f0a14.tar.xz
development/pudb: Changed options.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development/pudb')
-rw-r--r--development/pudb/README8
-rw-r--r--development/pudb/pudb.SlackBuild10
2 files changed, 9 insertions, 9 deletions
diff --git a/development/pudb/README b/development/pudb/README
index 253788f594..76e9ca02bd 100644
--- a/development/pudb/README
+++ b/development/pudb/README
@@ -17,11 +17,11 @@ OPTIONS
To *ONLY* build the python2 version, use:
-NO_PYTHON3=1 ./pudb.SlackBuild
+NO_PYTHON3=yes ./pudb.SlackBuild
To *ONLY* build the python3 version, use:
-NO_PYTHON2=1 ./pudb.SlackBuild
+NO_PYTHON2=yes ./pudb.SlackBuild
The python2 version requires a newer version of urwid than the stock Slackware
one, therefore this also builds a custom urwid named py2_urwid, which it can
@@ -29,8 +29,8 @@ use. This should not conflict with the stock Slackware version.
OPTIONAL DEPENDENCIES
-python3-urwid for the python3 version. Note that it will still build without
-this, so it can be installed later if needed.
+python3-urwid is a runtime for the python3 version. Note that it will still
+build without this, so it can be installed later if needed.
###############################################################################
diff --git a/development/pudb/pudb.SlackBuild b/development/pudb/pudb.SlackBuild
index cd38d8a15a..beb5756928 100644
--- a/development/pudb/pudb.SlackBuild
+++ b/development/pudb/pudb.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=pudb
VERSION=${VERSION:-2017.1.4}
URWIDVER=2.0.1
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,7 +55,7 @@ else
LIBDIRSUFFIX=""
fi
-if [ -n "$NO_PYTHON2" ] && [ -n "$NO_PYTHON3" ]; then
+if [ "$NO_PYTHON2" = "yes" ] && [ "$NO_PYTHON3" = "yes" ]; then
printf "%s\n" "You appear to not want to install anything."
exit 1
fi
@@ -70,7 +70,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
# install custom urwid package
-if [ -z "$NO_PYTHON2" ]; then
+if [ "$NO_PYTHON2" != "yes" ]; then
rm -rf urwid-$URWIDVER
tar xfv $CWD/urwid-$URWIDVER.tar.gz
cd urwid-$URWIDVER
@@ -107,12 +107,12 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# install the python3 version before we wreck the python2 build
-if [ -n "$PY3" ] && [ -z "$NO_PYTHON3" ]; then
+if [ -n "$PY3" ] && [ "$NO_PYTHON3" != "yes" ]; then
python3 setup.py install --root=$PKG
fi
# install the edited python2 version
-if [ -z "$NO_PYTHON2" ]; then
+if [ "$NO_PYTHON2" != "yes" ]; then
# change all references to urwid to our custom py2_urwid
for py in \
settings.py \