summaryrefslogtreecommitdiffstats
path: root/development/python3-cycler
diff options
context:
space:
mode:
author Serban Udrea <S.Udrea@gsi.de>2017-04-30 09:23:38 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-30 09:23:38 +0700
commit5abbe691456c05f67ce52139a34748d4016c2159 (patch)
treec5650217b3c02a946da09faf7337c997d79a7dcf /development/python3-cycler
parentf3397c4a9b4095f553cdb1cad8c1e23ddb6bd0c0 (diff)
downloadslackbuilds-5abbe691456c05f67ce52139a34748d4016c2159.tar.gz
slackbuilds-5abbe691456c05f67ce52139a34748d4016c2159.tar.xz
development/python3-cycler: Added (composable cycles for Python 3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/python3-cycler')
-rw-r--r--development/python3-cycler/README7
-rw-r--r--development/python3-cycler/python3-cycler.SlackBuild74
-rw-r--r--development/python3-cycler/python3-cycler.info10
-rw-r--r--development/python3-cycler/slack-desc21
4 files changed, 112 insertions, 0 deletions
diff --git a/development/python3-cycler/README b/development/python3-cycler/README
new file mode 100644
index 0000000000..ede83fde16
--- /dev/null
+++ b/development/python3-cycler/README
@@ -0,0 +1,7 @@
+The cycler python module provides a composable cycle class used for
+constructing style-cycles.
+
+This is the Python 3 version of cycler and will coexist with SBo's
+cycler package.
+
+NOTE: six needs to be built with Python 3 support
diff --git a/development/python3-cycler/python3-cycler.SlackBuild b/development/python3-cycler/python3-cycler.SlackBuild
new file mode 100644
index 0000000000..61ae3c4d8e
--- /dev/null
+++ b/development/python3-cycler/python3-cycler.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for cycler
+
+# Copyright 2016-2017 Serban Udrea <s.udrea@gsi.de>
+# Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-cycler
+SRCNAM=cycler
+VERSION=${VERSION:-0.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/python3-cycler/python3-cycler.info b/development/python3-cycler/python3-cycler.info
new file mode 100644
index 0000000000..9ec7411cec
--- /dev/null
+++ b/development/python3-cycler/python3-cycler.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-cycler"
+VERSION="0.10.0"
+HOMEPAGE="http://matplotlib.org/cycler"
+DOWNLOAD="https://pypi.python.org/packages/c2/4b/137dea450d6e1e3d474e1d873cd1d4f7d3beed7e0dc973b06e8e10d32488/cycler-0.10.0.tar.gz"
+MD5SUM="4cb42917ac5007d1cdff6cccfe2d016b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="six"
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/development/python3-cycler/slack-desc b/development/python3-cycler/slack-desc
new file mode 100644
index 0000000000..6f5787cf5f
--- /dev/null
+++ b/development/python3-cycler/slack-desc
@@ -0,0 +1,21 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-cycler: cycler (composable cycles for Python 3)
+python3-cycler:
+python3-cycler: The cycler python module provides a composable cycle class used for
+python3-cycler: constructing style-cycles.
+python3-cycler:
+python3-cycler: This will coexist with SBo's cycler package.
+python3-cycler:
+python3-cycler:
+python3-cycler:
+python3-cycler: Homepage: http://matplotlib.org/cycler
+python3-cycler:
+python3-cycler:
+python3-cycler: