summaryrefslogtreecommitdiffstats
path: root/development/schroot/program_options.patch
diff options
context:
space:
mode:
author Vincent Batts <vbatts@hashbangbash.com>2011-12-21 06:29:02 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-12-22 00:03:03 -0600
commita2ce6fc7c2d93d57d191b16bfd9e1ddf0b5e75a6 (patch)
tree1eb7ba6757e2d2461db744efcf9b6a6ce7d66045 /development/schroot/program_options.patch
parent7bb560d5ca6f6f280a0ac2a2099b9c78fd55a171 (diff)
downloadslackbuilds-a2ce6fc7c2d93d57d191b16bfd9e1ddf0b5e75a6.tar.gz
slackbuilds-a2ce6fc7c2d93d57d191b16bfd9e1ddf0b5e75a6.tar.xz
development/schroot: Added (secure chroot utility)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'development/schroot/program_options.patch')
-rw-r--r--development/schroot/program_options.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/development/schroot/program_options.patch b/development/schroot/program_options.patch
new file mode 100644
index 0000000000..901ed7383b
--- /dev/null
+++ b/development/schroot/program_options.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index cf09108..07fd32b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -529,7 +529,7 @@ AC_MSG_CHECKING([for boost::program_options::variables_map in -lboost_program_op
+ saved_LIBS="${LIBS}"
+ LIBS="${saved_LIBS} -lboost_program_options"
+ define([testprog], [AC_LANG_PROGRAM([#include <boost/program_options.hpp>],
+- [boost::program_options::variables_map::variables_map dummy()])])
++ [boost::program_options::variables_map dummy()])])
+ AC_LINK_IFELSE(testprog,
+ [AC_MSG_RESULT([yes])
+ BOOST_LIBS="${BOOST_LIBS} -lboost_program_options"],