summaryrefslogtreecommitdiffstats
path: root/development/stgit
diff options
context:
space:
mode:
author Carlos Corbacho <carlos@strangeworlds.co.uk>2010-05-11 20:00:31 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:31 +0200
commit62d792b77efe73d81dd81c58b35ff8dc15f7937a (patch)
treeebebfa8bc5f3d1325c8ba881bf0feb9ecfacd7fc /development/stgit
parent553525cd39835d39987dda08dd4c5e3785bfc27b (diff)
downloadslackbuilds-62d792b77efe73d81dd81c58b35ff8dc15f7937a.tar.gz
slackbuilds-62d792b77efe73d81dd81c58b35ff8dc15f7937a.tar.xz
development/stgit: Added to 12.0 repository
Diffstat (limited to 'development/stgit')
-rw-r--r--development/stgit/README8
-rw-r--r--development/stgit/slack-desc19
-rw-r--r--development/stgit/stgit.SlackBuild101
-rw-r--r--development/stgit/stgit.info8
4 files changed, 136 insertions, 0 deletions
diff --git a/development/stgit/README b/development/stgit/README
new file mode 100644
index 0000000000..0f2a404f92
--- /dev/null
+++ b/development/stgit/README
@@ -0,0 +1,8 @@
+StGIT is a Python application providing similar functionality to
+Quilt (i.e. pushing/popping patches to/from a stack) on top of GIT.
+These operations are performed using GIT commands and the patches are
+stored as GIT commit objects, allowing easy merging of the StGIT
+patches into other repositories using standard GIT functionality.
+
+If you are building this on Slamd64, execute the build script as follows:
+ DISTRO=slamd64 ./stgit.SlackBuild \ No newline at end of file
diff --git a/development/stgit/slack-desc b/development/stgit/slack-desc
new file mode 100644
index 0000000000..5a2411d1a1
--- /dev/null
+++ b/development/stgit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+stgit: stgit (Push/pop utility on top of Git)
+stgit:
+stgit: StGIT is a Python application providing similar functionality to
+stgit: Quilt (i.e. pushing/popping patches to/from a stack) on top of GIT.
+stgit: These operations are performed using GIT commands and the patches are
+stgit: stored as GIT commit objects, allowing easy merging of the StGIT
+stgit: patches into other repositories using standard GIT functionality.
+stgit:
+stgit: Home Page: http://procode.org/stgit/
+stgit:
+stgit: \ No newline at end of file
diff --git a/development/stgit/stgit.SlackBuild b/development/stgit/stgit.SlackBuild
new file mode 100644
index 0000000000..ce5ce000c7
--- /dev/null
+++ b/development/stgit/stgit.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# SlackBuild for StGIT (Stacked GIT)
+
+# Copyright 2007-2008 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PKGNAM=stgit
+VERSION=${VERSION:-0.14.1}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DISTRO=${DISTRO:-slackware}
+
+if [ $DISTRO = slackware ]; then
+ PKGARCH=$ARCH
+else
+ PKGARCH=${ARCH}_${DISTRO}
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PKGNAM-$VERSION
+tar xvf $CWD/$PKGNAM-$VERSION.tar.gz || exit 1
+cd $PKGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py \
+ install \
+ --prefix=/usr \
+ --root="$PKG"
+
+rm -rf $PKG/usr/share/doc
+
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PKGNAM-$VERSION
+chmod 0644 $PKG/usr/doc/$PKGNAM-$VERSION/*
+
+# Compress and link manpages, if any:
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.?
+ )
+ done
+ )
+fi
+
+# Compress info files, if any:
+if [ -d $PKG/usr/info ]; then
+ ( cd $PKG/usr/info
+ rm -f dir
+ gzip -9 *
+ )
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$PKGARCH-$BUILD$TAG.tgz
+
+# Clean up the extra stuff:
+if [ "$1" = "--cleanup" ]; then
+ rm -rf $TMP/$PKGNAM-$VERSION
+ rm -rf $PKG
+fi
diff --git a/development/stgit/stgit.info b/development/stgit/stgit.info
new file mode 100644
index 0000000000..e118d23ad0
--- /dev/null
+++ b/development/stgit/stgit.info
@@ -0,0 +1,8 @@
+PRGNAM="stgit"
+VERSION="0.14.1"
+HOMEPAGE="http://procode.org/stgit/"
+DOWNLOAD="http://homepage.ntlworld.com/cmarinas/stgit/stgit-0.14.1.tar.gz"
+MD5SUM="e95e5ccf5e8372a5e1c4e4d09b1171cf"
+MAINTAINER="Carlos Corbacho"
+EMAIL="carlos@strangeworlds.co.uk"
+APPROVED="rworkman"