summaryrefslogtreecommitdiffstats
path: root/development/trac
diff options
context:
space:
mode:
author Eugene Suter <easuter@gmail.com>2010-04-16 21:48:11 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-15 10:38:06 +0200
commit39e7e607e2d6a765ef0e696d8d79422fa8e93f0f (patch)
tree4c52096d401402556b03a2033aa9d4afda666665 /development/trac
parent40b66211def12ffdd5c31b80cd955ec6e0c27917 (diff)
downloadslackbuilds-39e7e607e2d6a765ef0e696d8d79422fa8e93f0f.tar.gz
slackbuilds-39e7e607e2d6a765ef0e696d8d79422fa8e93f0f.tar.xz
development/trac: Added (wiki and issue tracking system)
Diffstat (limited to 'development/trac')
-rw-r--r--development/trac/README13
-rw-r--r--development/trac/slack-desc20
-rw-r--r--development/trac/trac.SlackBuild60
-rw-r--r--development/trac/trac.info10
4 files changed, 103 insertions, 0 deletions
diff --git a/development/trac/README b/development/trac/README
new file mode 100644
index 0000000000..2bb9ca991a
--- /dev/null
+++ b/development/trac/README
@@ -0,0 +1,13 @@
+Trac is an enhanced wiki and issue tracking system for software development
+projects. Trac uses a minimalistic approach to web-based software project
+management. Our mission is to help developers write great software while
+staying out of the way. Trac should impose as little as possible on a
+team's established development process and policies.
+
+Trac relies on multiple other packages (available at SlackBuilds):
+pysetuptools, MySQL-python, genshi and pygments.
+
+pysetuptools must be installed before all the others and pygments is
+optional (provides syntax highlighting).
+
+
diff --git a/development/trac/slack-desc b/development/trac/slack-desc
new file mode 100644
index 0000000000..634fad4400
--- /dev/null
+++ b/development/trac/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+trac: trac (enhanced wiki and issue tracking system)
+trac:
+trac: Trac is an enhanced wiki and issue tracking system for software
+trac: development projects. Trac uses a minimalistic approach to
+trac: web-based software project management. Our mission is to help
+trac: developers write great software while staying out of the way.
+trac: Trac should impose as little as possible on a team's established
+trac: development process and policies.
+trac:
+trac: Website: http://trac.edgewall.org/
+trac:
+
diff --git a/development/trac/trac.SlackBuild b/development/trac/trac.SlackBuild
new file mode 100644
index 0000000000..09cd0229f6
--- /dev/null
+++ b/development/trac/trac.SlackBuild
@@ -0,0 +1,60 @@
+#!/bin/sh
+
+# Slackware build script for
+# Written by Eugene Suter <easuter at gmail.com>
+
+PRGNAM="trac"
+SRCNAM="Trac"
+VERSION=${VERSION:-0.11.6}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Quick and easy install
+python setup.py install --root=$PKG
+
+# Documentation
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/README AUTHORS COPYING ChangeLog \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Copy the slack-desc
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Make the package
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/development/trac/trac.info b/development/trac/trac.info
new file mode 100644
index 0000000000..e161b6d879
--- /dev/null
+++ b/development/trac/trac.info
@@ -0,0 +1,10 @@
+PRGNAM="trac"
+VERSION="0.11.6"
+HOMEPAGE="http://trac.edgewall.com/"
+DOWNLOAD="ftp://ftp.edgewall.com/pub/trac/Trac-0.11.6.tar.gz"
+MD5SUM="f5a9542d81d3d50c3d9e46d8e2344f38"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Eugene Suter"
+EMAIL="easuter@gmail.com"
+APPROVED="dsomero"