summaryrefslogtreecommitdiffstats
path: root/development/xxdiff
diff options
context:
space:
mode:
author Benno <fwxx@rocketmail.com>2012-12-19 21:09:07 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-19 21:09:30 +0100
commitf033095a877cdda55311e2fbf34bddc55066bc4a (patch)
treecdcb0f44097e9aa7586eb6ee0477983724a9faa8 /development/xxdiff
parentc70a74311f284f9cf03a63dc7365d1fd568cb8fd (diff)
downloadslackbuilds-f033095a877cdda55311e2fbf34bddc55066bc4a.tar.gz
slackbuilds-f033095a877cdda55311e2fbf34bddc55066bc4a.tar.xz
development/xxdiff: Added (graphical diff).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development/xxdiff')
-rw-r--r--development/xxdiff/README1
-rw-r--r--development/xxdiff/slack-desc19
-rw-r--r--development/xxdiff/xxdiff.SlackBuild83
-rw-r--r--development/xxdiff/xxdiff.info10
4 files changed, 113 insertions, 0 deletions
diff --git a/development/xxdiff/README b/development/xxdiff/README
new file mode 100644
index 0000000000..86f7294d4c
--- /dev/null
+++ b/development/xxdiff/README
@@ -0,0 +1 @@
+xxdiff is a graphical file and directories comparator and merge tool.
diff --git a/development/xxdiff/slack-desc b/development/xxdiff/slack-desc
new file mode 100644
index 0000000000..8644ab61f0
--- /dev/null
+++ b/development/xxdiff/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xxdiff: xxdiff (graphical file and directories comparator and merge tool)
+xxdiff:
+xxdiff: This program is an essential software development tool that can
+xxdiff: be used to:
+xxdiff: * visualize the differences between files or directories
+xxdiff: * merge files with differences, resolving conflicts and saving
+xxdiff: output to a new file or patch
+xxdiff: * assist file changes reviewing and comment production
+xxdiff: (e.g. approving source code changes before they get merged
+xxdiff: into a source tree).
+xxdiff: homepage: http://furius.ca/xxdiff/
diff --git a/development/xxdiff/xxdiff.SlackBuild b/development/xxdiff/xxdiff.SlackBuild
new file mode 100644
index 0000000000..1fa2301ff1
--- /dev/null
+++ b/development/xxdiff/xxdiff.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+
+# Slackware build script for xxdiff
+
+# Written by Benno Grolik <fwxx@rocketmail.com>
+
+PRGNAM=xxdiff
+VERSION=${VERSION:-401}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cd src
+QMAKE=`which qmake` make -f Makefile.bootstrap Makefile
+make
+cd ..
+install -m 755 -o root -g root -D bin/$PRGNAM $PKG/usr/bin/$PRGNAM
+install -m 644 -o root -g root -D src/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
+
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES COPYING README TODO tools/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc $PKG/usr/doc/$PRGNAM-$VERSION/html
+rm $PKG/usr/doc/$PRGNAM-$VERSION/html/Makefile
+mv $PKG/usr/doc/$PRGNAM-$VERSION/html/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/xxdiff/xxdiff.info b/development/xxdiff/xxdiff.info
new file mode 100644
index 0000000000..24ff0a803c
--- /dev/null
+++ b/development/xxdiff/xxdiff.info
@@ -0,0 +1,10 @@
+PRGNAM="xxdiff"
+VERSION="401"
+HOMEPAGE="http://furius.ca/xxdiff/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/xxdiff-401.tar.xz"
+MD5SUM="ba7e03d2ad403926e9a3f8e30f67725a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benno"
+EMAIL="fwxx@rocketmail.com"