summaryrefslogtreecommitdiffstats
path: root/development/xxdiff
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-26 16:27:16 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-27 01:09:58 +0700
commitf4dada8bdd6e4de0f5e21b01e472cba059422459 (patch)
tree464aa3626cbaace6a486e1038433f9e905e7d92b /development/xxdiff
parentebb7d4ef35af0a86e10c39fff1201adb6ea8b506 (diff)
downloadslackbuilds-f4dada8bdd6e4de0f5e21b01e472cba059422459.tar.gz
slackbuilds-f4dada8bdd6e4de0f5e21b01e472cba059422459.tar.xz
development/xxdiff: Updated for version 20220219_d4432be.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/xxdiff')
-rw-r--r--development/xxdiff/xxdiff-e3cdca0088916446b019dcbf8ea7164cc5f788ac.diff115
-rw-r--r--development/xxdiff/xxdiff.SlackBuild17
-rw-r--r--development/xxdiff/xxdiff.info6
3 files changed, 9 insertions, 129 deletions
diff --git a/development/xxdiff/xxdiff-e3cdca0088916446b019dcbf8ea7164cc5f788ac.diff b/development/xxdiff/xxdiff-e3cdca0088916446b019dcbf8ea7164cc5f788ac.diff
deleted file mode 100644
index fc39adbc7e..0000000000
--- a/development/xxdiff/xxdiff-e3cdca0088916446b019dcbf8ea7164cc5f788ac.diff
+++ /dev/null
@@ -1,115 +0,0 @@
-# HG changeset patch
-# User Martin Blais <blais@furius.ca>
-# Date 1407690283 14400
-# Node ID e3cdca0088916446b019dcbf8ea7164cc5f788ac
-# Parent 5ebaec3d8cb9bb8eaf0600acee495a1ffc28b67c
-Applied patch from <john dot schmerge at gmail dot com> for bison 3.0.2
-
-diff --git a/src/resParser.cpp b/src/resParser.cpp
---- a/src/resParser.cpp
-+++ b/src/resParser.cpp
-@@ -73,7 +73,7 @@
-
- //------------------------------------------------------------------------------
- //
--void resParsererror( const char* msg )
-+void resParsererror( XxResources *, const char* msg )
- {
- // Send errors to stdout so we can filter out the debug info shmeglu while
- // debugging parser.
-@@ -794,7 +794,7 @@
- QString os;
- QTextStream oss( &os );
- oss << "Unknown " << errmsg << ": " << name << flush;
-- resParsererror( os.toLatin1().constData() );
-+ resParsererror( NULL, os.toLatin1().constData() );
- }
- num = ERROR_TOKEN;
- return ERROR_TOKEN;
-diff --git a/src/resParser.l b/src/resParser.l
---- a/src/resParser.l
-+++ b/src/resParser.l
-@@ -76,7 +76,7 @@
- result = YY_NULL; \
- } \
- else { \
-- int ii = 0; \
-+ unsigned ii = 0; \
- for ( ; (ii < max_size) && (!input_stream_ptr->atEnd()); ++ii ) { \
- (*input_stream_ptr) >> buf[ii]; \
- } \
-diff --git a/src/resParser.y b/src/resParser.y
---- a/src/resParser.y
-+++ b/src/resParser.y
-@@ -20,11 +20,6 @@
- *
- ******************************************************************************/
-
--%union
--{
-- int num;
-- char* str;
--}
- %{
-
- // xxdiff imports
-@@ -39,12 +34,22 @@
-
- // The parser input is the resources object to fill in.
- #define RESOURCES ( static_cast<XxResources*>(resources) )
--#define YYPARSE_PARAM resources
-+%}
-
-+%define api.pure full
-+%parse-param {XxResources * resources}
-+
-+%union
-+{
-+ int num;
-+ char* str;
-+}
-+
-+%{
- // Declare lexer from other compilation unit.
- int resParserlex( YYSTYPE* yylval );
-
--void resParsererror( const char* msg );
-+void resParsererror( XxResources *, const char* msg );
-
- // Declare some parser functions and data defined in resParser.cpp
- namespace XxResParserNS {
-@@ -144,7 +149,6 @@
- %type <num> boolkwd
-
- %start xxdiffrc
--%pure_parser
-
- %%
- xxdiffrc : stmts
-@@ -188,7 +192,7 @@
- RESOURCES->setPreferredGeometry( geometry );
- }
- else {
-- yyerror( "Bad geometry specification." );
-+ yyerror( NULL, "Bad geometry specification." );
- // Should never happen, the lexer regexp should be tough
- // enough.
- }
-@@ -212,7 +216,7 @@
- QString err = QString( "Requested style key does not exist." );
- err += QString( "\nValid styles are: " );
- err += styles.join( ", " );
-- yyerror( err.toLatin1().constData() );
-+ yyerror( NULL, err.toLatin1().constData() );
- }
- }
- ;
-@@ -224,7 +228,7 @@
- char buf[2048];
- ::snprintf( buf, 2048,
- "Unrecognized accelerator: %s\n", $5 );
-- yyerror( buf );
-+ yyerror( NULL, buf );
- }
- }
- ;
diff --git a/development/xxdiff/xxdiff.SlackBuild b/development/xxdiff/xxdiff.SlackBuild
index 409c7e614a..933f50f8cc 100644
--- a/development/xxdiff/xxdiff.SlackBuild
+++ b/development/xxdiff/xxdiff.SlackBuild
@@ -7,14 +7,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xxdiff
-VERSION=${VERSION:-401}
+VERSION=${VERSION:-20220219_d4432be}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -32,8 +32,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,18 +61,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix for bison-3
-# https://bitbucket.org/blais/xxdiff/commits/e3cdca0088916446b019dcbf8ea7164cc5f788ac/raw/
-patch -p1 < $CWD/xxdiff-e3cdca0088916446b019dcbf8ea7164cc5f788ac.diff
-
cd src
-QMAKE=`which qmake` make -f Makefile.bootstrap Makefile
+make -f Makefile.bootstrap
make
cd ..
install -m 755 -o root -g root -D bin/$PRGNAM $PKG/usr/bin/$PRGNAM
install -m 644 -o root -g root -D src/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -81,7 +76,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGES COPYING README TODO tools/ \
+ CHANGES COPYING README* TODO tools/ \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc $PKG/usr/doc/$PRGNAM-$VERSION/html
rm $PKG/usr/doc/$PRGNAM-$VERSION/html/Makefile
diff --git a/development/xxdiff/xxdiff.info b/development/xxdiff/xxdiff.info
index 24ff0a803c..888b1624c7 100644
--- a/development/xxdiff/xxdiff.info
+++ b/development/xxdiff/xxdiff.info
@@ -1,8 +1,8 @@
PRGNAM="xxdiff"
-VERSION="401"
+VERSION="20220219_d4432be"
HOMEPAGE="http://furius.ca/xxdiff/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/xxdiff-401.tar.xz"
-MD5SUM="ba7e03d2ad403926e9a3f8e30f67725a"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/xxdiff-20220219_d4432be.tar.xz"
+MD5SUM="1b74afc251e16e8e55e9cb210f89acf3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""