summaryrefslogtreecommitdiffstats
path: root/development/zope.interface
diff options
context:
space:
mode:
author Mikko Varri <vmj@linuxbox.fi>2010-05-12 23:29:00 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:29:00 +0200
commit36d3f5606d00f94d5839ee8d6dd2f5df1e52a962 (patch)
tree3843e33d7c327aacbd258dc331cb118539dc6cab /development/zope.interface
parent08c14438ada25899c6c302c76272ce9ad44e6fe4 (diff)
downloadslackbuilds-36d3f5606d00f94d5839ee8d6dd2f5df1e52a962.tar.gz
slackbuilds-36d3f5606d00f94d5839ee8d6dd2f5df1e52a962.tar.xz
development/zope.interface: Added to 12.2 repository
Diffstat (limited to 'development/zope.interface')
-rw-r--r--development/zope.interface/README10
-rw-r--r--development/zope.interface/slack-desc19
-rw-r--r--development/zope.interface/zope.interface.SlackBuild56
-rw-r--r--development/zope.interface/zope.interface.info8
4 files changed, 93 insertions, 0 deletions
diff --git a/development/zope.interface/README b/development/zope.interface/README
new file mode 100644
index 0000000000..48af903300
--- /dev/null
+++ b/development/zope.interface/README
@@ -0,0 +1,10 @@
+zope.interface (Zope 3 Interface Infrastructure)
+
+Interfaces are a mechanism for labeling objects as conforming to a
+given API or contract.
+
+NOTE: Building zope.interface requires Python setuptools to be
+installed (available at SlackBuilds.org as "pysetuptools").
+No runtime dependencies beyond Python.
+
+Running the test suite requires zope.testing, but that is optional.
diff --git a/development/zope.interface/slack-desc b/development/zope.interface/slack-desc
new file mode 100644
index 0000000000..83f06c97bc
--- /dev/null
+++ b/development/zope.interface/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+zope.interface: zope.interface (Zope 3 Interface Infrastructure)
+zope.interface:
+zope.interface: Interfaces are a mechanism for labeling objects as conforming
+zope.interface: to a given API or contract.
+zope.interface:
+zope.interface: http://pypi.python.org/pypi/zope.interface/
+zope.interface:
+zope.interface:
+zope.interface:
+zope.interface:
+zope.interface:
diff --git a/development/zope.interface/zope.interface.SlackBuild b/development/zope.interface/zope.interface.SlackBuild
new file mode 100644
index 0000000000..e096042992
--- /dev/null
+++ b/development/zope.interface/zope.interface.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+
+# Slackware build script for zope.interface
+
+# Written by Mikko Varri (vmj@linuxbox.fi)
+# Public domain
+
+PRGNAM=zope.interface
+VERSION=${VERSION:-3.5.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt PKG-INFO README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/zope.interface/zope.interface.info b/development/zope.interface/zope.interface.info
new file mode 100644
index 0000000000..f1e0b59228
--- /dev/null
+++ b/development/zope.interface/zope.interface.info
@@ -0,0 +1,8 @@
+PRGNAM="zope.interface"
+VERSION="3.5.0"
+HOMEPAGE="http://pypi.python.org/pypi/zope.interface/"
+DOWNLOAD="http://pypi.python.org/packages/source/z/zope.interface/zope.interface-3.5.0.zip"
+MD5SUM="478d05add7cd7faf25a2fd880a739ddb"
+MAINTAINER="Mikko Varri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="rworkman"