summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Grissiom <chaos.proton@gmail.com>2010-05-12 23:28:34 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:28:34 +0200
commit03981ef99c22dafc6c53a9b5b70d7ee1105e8faf (patch)
treee9d74364227ba5223735cc9cb4797fb244b95244 /development
parentb841502afe4cf5e35398d317dde2d67d50c39796 (diff)
downloadslackbuilds-03981ef99c22dafc6c53a9b5b70d7ee1105e8faf.tar.gz
slackbuilds-03981ef99c22dafc6c53a9b5b70d7ee1105e8faf.tar.xz
development/Pygments: Added to 12.2 repository
Diffstat (limited to 'development')
-rw-r--r--development/Pygments/Pygments.SlackBuild46
-rw-r--r--development/Pygments/Pygments.info8
-rw-r--r--development/Pygments/README11
-rw-r--r--development/Pygments/slack-desc19
4 files changed, 84 insertions, 0 deletions
diff --git a/development/Pygments/Pygments.SlackBuild b/development/Pygments/Pygments.SlackBuild
new file mode 100644
index 0000000000..c75fdaf4f1
--- /dev/null
+++ b/development/Pygments/Pygments.SlackBuild
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+# Slackware build script for Pygments
+
+# Written by Grissiom <chaos.proton@gmail.com>
+
+
+PRGNAM=Pygments
+VERSION=${VERSION:-1.0}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE TODO AUTHORS CHANGES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/Pygments/Pygments.info b/development/Pygments/Pygments.info
new file mode 100644
index 0000000000..dad811ebbf
--- /dev/null
+++ b/development/Pygments/Pygments.info
@@ -0,0 +1,8 @@
+PRGNAM="Pygments"
+VERSION="1.0"
+HOMEPAGE="http://pygments.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/P/Pygments/Pygments-1.0.tar.gz"
+MD5SUM="70c40ff5331460cabfcb24f86a8d451d"
+MAINTAINER="Grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="dsomero"
diff --git a/development/Pygments/README b/development/Pygments/README
new file mode 100644
index 0000000000..975ce911d5
--- /dev/null
+++ b/development/Pygments/README
@@ -0,0 +1,11 @@
+Pygments is a generic syntax highlighter for general use in all kinds of
+software such as forum systems, wikis or other applications that need to
+prettify source code.
+
+Highlights are:
+ * A wide range of common languages and markup formats is supported.
+ * Special attention is paid to details, increasing quality by a fair amount.
+ * Support for new languages and formats are added easily.
+ * A number of output formats, presently HTML, LaTeX, RTF, SVG and ANSI
+ sequences.
+ * It is usable as a command-line tool and as a library.
diff --git a/development/Pygments/slack-desc b/development/Pygments/slack-desc
new file mode 100644
index 0000000000..31af28f8ad
--- /dev/null
+++ b/development/Pygments/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+Pygments: Pygments (syntax highlighting package written in Python)
+Pygments:
+Pygments: It is a generic syntax highlighter for general use in all kinds of
+Pygments: software such as forum systems, wikis or other applications that need
+Pygments: to prettify source code. A wide range of common languages and markup
+Pygments: formats is supported.
+Pygments:
+Pygments:
+Pygments:
+Pygments:
+Pygments: