summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2010-05-12 23:28:51 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:28:51 +0200
commit72a2101b534d8f62326ba56a457930dca1845b1c (patch)
tree8bd8246e597ef5807bce477c71d357475b775578 /development
parent29ec79b9939c41327042ff5cd081b7001e65b11e (diff)
downloadslackbuilds-72a2101b534d8f62326ba56a457930dca1845b1c.tar.gz
slackbuilds-72a2101b534d8f62326ba56a457930dca1845b1c.tar.xz
development/qt-creator: Added to 12.2 repository
Diffstat (limited to 'development')
-rw-r--r--development/qt-creator/Makefile.diff11
-rw-r--r--development/qt-creator/README10
-rw-r--r--development/qt-creator/doinst.sh4
-rw-r--r--development/qt-creator/qt-creator.SlackBuild102
-rw-r--r--development/qt-creator/qt-creator.desktop11
-rw-r--r--development/qt-creator/qt-creator.info8
-rw-r--r--development/qt-creator/slack-desc19
7 files changed, 165 insertions, 0 deletions
diff --git a/development/qt-creator/Makefile.diff b/development/qt-creator/Makefile.diff
new file mode 100644
index 0000000000..bf3740e40b
--- /dev/null
+++ b/development/qt-creator/Makefile.diff
@@ -0,0 +1,11 @@
+--- Makefile 2009-05-05 12:04:53.863056970 -0300
++++ Makefile.new 2009-05-05 12:05:45.556052356 -0300
+@@ -147,7 +147,7 @@
+ -$(DEL_DIR) $(INSTALL_ROOT)/share/doc/qtcreator/
+
+
+-install: install_subtargets install_qch_docs FORCE
++install: install_subtargets FORCE
+
+ uninstall: uninstall_qch_docs uninstall_subtargets FORCE
+
diff --git a/development/qt-creator/README b/development/qt-creator/README
new file mode 100644
index 0000000000..fd2915fe60
--- /dev/null
+++ b/development/qt-creator/README
@@ -0,0 +1,10 @@
+qt-creator (Cross-Platform Qt IDE)
+
+Qt Creator is a new cross-platform integrated development environment
+(IDE) tailored to the needs of Qt developers.
+
+Note:
+qdoc3 must be installed to build docs (This should be considered a bug).
+If you intend to install docs you have to build qt4 from source applying
+a patch to enable building qdoc3. There is an online version of the
+docs here: http://doc.trolltech.com/qtcreator-1.1/
diff --git a/development/qt-creator/doinst.sh b/development/qt-creator/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/development/qt-creator/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/development/qt-creator/qt-creator.SlackBuild b/development/qt-creator/qt-creator.SlackBuild
new file mode 100644
index 0000000000..f023e43bb9
--- /dev/null
+++ b/development/qt-creator/qt-creator.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for qt-creator
+
+# Copyright 2009 Andre Barboza
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Written by Andre Barboza <bmg.andre@gmail.com>
+# Modified by the SlackBuilds.org project.
+
+PRGNAM=qt-creator
+VERSION=${VERSION:-1.1.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+QTDIR=${QT4DIR:-$QT4DIR}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION-src
+unzip $CWD/$PRGNAM-$VERSION-src.zip
+cd $PRGNAM-$VERSION-src
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ qmake-qt4 ../qtcreator.pro
+
+ # qdoc3 must be installed to build docs.
+ # if you intend to install docs you should patch qt4
+ if [ ! -x /usr/lib/qt4/tools/qdoc3/qdoc3 ]
+ then
+ patch < $CWD/Makefile.diff
+ fi
+
+ make
+ make install INSTALL_ROOT=$PKG/usr
+cd -
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/bin; ln -s qtcreator.bin qtcreator )
+
+mkdir -p $PKG/usr/share/applications
+cat $CWD/qt-creator.desktop > $PKG/usr/share/applications/qt-creator.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a HACKING LICENSE.LGPL README LGPL_EXCEPTION.TXT $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+
diff --git a/development/qt-creator/qt-creator.desktop b/development/qt-creator/qt-creator.desktop
new file mode 100644
index 0000000000..bfaf50cc4b
--- /dev/null
+++ b/development/qt-creator/qt-creator.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Qt Creator IDE
+Exec=qtcreator
+Icon=/usr/share/pixmaps/qtcreator_logo_48.png
+Categories=Development;IDE
+Version=1.0
+StartupNotify=true
+Type=Application
+Terminal=0
+
diff --git a/development/qt-creator/qt-creator.info b/development/qt-creator/qt-creator.info
new file mode 100644
index 0000000000..0bc2d8e89a
--- /dev/null
+++ b/development/qt-creator/qt-creator.info
@@ -0,0 +1,8 @@
+PRGNAM="qt-creator"
+VERSION="1.1.0"
+HOMEPAGE="http://www.qtsoftware.com/products/developer-tools"
+DOWNLOAD="http://get.qtsoftware.com/qtcreator/qt-creator-1.1.0-src.zip"
+MD5SUM="f0fd01f7c5a1f50c479bed13db2134bf"
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
+APPROVED="dsomero"
diff --git a/development/qt-creator/slack-desc b/development/qt-creator/slack-desc
new file mode 100644
index 0000000000..ca18ae39e4
--- /dev/null
+++ b/development/qt-creator/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+qt-creator: qt-creator (Cross-Platform Qt IDE)
+qt-creator:
+qt-creator: Qt Creator is a new cross-platform integrated development environment
+qt-creator: (IDE) tailored to the needs of Qt developers.
+qt-creator:
+qt-creator:
+qt-creator:
+qt-creator:
+qt-creator:
+qt-creator: Homepage: http://http://www.qtsoftware.com/products/developer-tools
+qt-creator: