summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:07:14 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:07:14 +0200
commit255e377abeeb2d3d24e1c88671a3c46dafbdb4b4 (patch)
tree436c5ef9944a0aac7f76ff2f144e7c4db46526d9 /development
parent776b83379dd97d390acf5473c2205a335fdaaf21 (diff)
downloadslackbuilds-255e377abeeb2d3d24e1c88671a3c46dafbdb4b4.tar.gz
slackbuilds-255e377abeeb2d3d24e1c88671a3c46dafbdb4b4.tar.xz
development/motor: Removed from 13.0 repository
Diffstat (limited to 'development')
-rw-r--r--development/motor/Makefile.patch13
-rw-r--r--development/motor/README6
-rw-r--r--development/motor/motor.SlackBuild82
-rw-r--r--development/motor/motor.info8
-rw-r--r--development/motor/slack-desc19
5 files changed, 0 insertions, 128 deletions
diff --git a/development/motor/Makefile.patch b/development/motor/Makefile.patch
deleted file mode 100644
index 73dc52797a..0000000000
--- a/development/motor/Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- share/Makefile.orig 2007-02-11 09:56:05.000000000 -0500
-+++ share/Makefile 2007-02-11 09:56:41.000000000 -0500
-@@ -225,8 +225,8 @@
- -if test -d templates; then rm -f tmpl.tar.gz; fi
-
- install-data-local: tmpl.tar.gz
-- tar zxvf tmpl.tar.gz -C $(datadir)/motor/
-- -find $(datadir)/motor/ -name CVS -type d -exec rm -rf {} \;
-+ tar zxvf tmpl.tar.gz -C ${DESTDIR}/$(datadir)/motor/
-+ -find ${DESTDIR}/$(datadir)/motor/ -name CVS -type d -exec rm -rf {} \;
- if test -d templates; then rm -f tmpl.tar.gz; fi
-
- uninstall-local:
diff --git a/development/motor/README b/development/motor/README
deleted file mode 100644
index 299370c85e..0000000000
--- a/development/motor/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Motor is a text mode based programming environment for Linux. It
-consists of a powerful editor with syntax highlight feature, project
-manager, makefile generator, gcc and gdb front-end, etc. Deep CVS
-integration is also provided. A symbol browser is provided to make it
-easier to move between various definitions in the source, and the
-regexper tool helps you to create and debug regular expressions.
diff --git a/development/motor/motor.SlackBuild b/development/motor/motor.SlackBuild
deleted file mode 100644
index 931c0a17b1..0000000000
--- a/development/motor/motor.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for motor
-
-# Copyright 2007 Martin Lefebvre <dadexter@slackadelic.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-set -e
-
-PRGNAM=motor
-VERSION=3.4.0
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man
-
-# Thanks to rworkman for this patch!
-patch -p0 < $CWD/Makefile.patch
-
-make
-make DESTDIR=$PKG install
-
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ABOUT-NLS AUTHORS COPYING ChangeLog FAQ INSTALL README TODO tutorial \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Set the right permissions through out the tarball.
-chown -R root:root $PKG/usr/share/$PRGNAM
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/motor/motor.info b/development/motor/motor.info
deleted file mode 100644
index d2faff722a..0000000000
--- a/development/motor/motor.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="motor"
-VERSION="3.4.0"
-HOMEPAGE="http://thekonst.net/motor"
-DOWNLOAD="http://www.thekonst.net/download/motor-3.4.0.tar.bz2"
-MD5SUM="0fcf7ce0386b269e8bdbb7a86e9bee19"
-MAINTAINER="Michiel van Wessem"
-EMAIL="michiel@slackbuilds.org"
-APPROVED="rworkman"
diff --git a/development/motor/slack-desc b/development/motor/slack-desc
deleted file mode 100644
index 7e2cac1c3d..0000000000
--- a/development/motor/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-motor: motor (text mode integrated development environment)
-motor:
-motor: Motor is a text mode based programming environment for Linux. It
-motor: consists of a powerful editor with syntax highlight feature, project
-motor: manager, makefile generator, gcc and gdb front-end, etc. Deep CVS
-motor: integration is also provided. A symbol browser is provided to make it
-motor: easier to move between various definitions in the source, and the
-motor: regexper tool helps you to create and debug regular expressions.
-motor:
-motor:
-motor: