summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2010-05-11 14:05:53 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 14:05:53 +0200
commit4521da10816ef243a80db8748aebb82b9d3e1480 (patch)
tree1a8eb084b14ea046148326dbcc5e1f86dde8990b /development
parent6c78afdd0876295fe428e392adf7e9eb9d741b42 (diff)
downloadslackbuilds-4521da10816ef243a80db8748aebb82b9d3e1480.tar.gz
slackbuilds-4521da10816ef243a80db8748aebb82b9d3e1480.tar.xz
development/scons: Initial import
Diffstat (limited to 'development')
-rw-r--r--development/scons/README8
-rw-r--r--development/scons/scons.SlackBuild44
-rw-r--r--development/scons/scons.info8
-rw-r--r--development/scons/slack-desc11
4 files changed, 71 insertions, 0 deletions
diff --git a/development/scons/README b/development/scons/README
new file mode 100644
index 0000000000..01d40aef21
--- /dev/null
+++ b/development/scons/README
@@ -0,0 +1,8 @@
+SCons is an Open Source software construction tool--that is, a next-generation
+build tool. Think of SCons as an improved, cross-platform substitute for the
+classic Make utility with integrated functionality similar to
+autoconf/automake and compiler caches such as ccache. In short, SCons is an
+easier, more reliable and faster way to build software.
+
+SCons consists of several Python scripts. You will need to have Python
+installed in order to use SCons.
diff --git a/development/scons/scons.SlackBuild b/development/scons/scons.SlackBuild
new file mode 100644
index 0000000000..7847939089
--- /dev/null
+++ b/development/scons/scons.SlackBuild
@@ -0,0 +1,44 @@
+#!/bin/sh
+
+# Slackware build script for scons
+# Written by Kyle Guinn
+
+# Modified by the SlackBuilds.org project
+
+PRGNAM=scons
+VERSION=0.97
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python ./setup.py build || exit 1
+python ./setup.py install --root=$PKG --symlink-scons || exit 1
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt LICENSE.txt README.txt RELEASE.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/scons/scons.info b/development/scons/scons.info
new file mode 100644
index 0000000000..9961e4c90d
--- /dev/null
+++ b/development/scons/scons.info
@@ -0,0 +1,8 @@
+PRGNAM="scons"
+VERSION="0.97"
+HOMEPAGE="http://www.scons.org/"
+DOWNLOAD="http://downloads.sourceforge.net/scons/scons-0.97.tar.gz"
+MD5SUM="de530fa29e83f3b6efb618873398fa31"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
+APPROVED="rworkman"
diff --git a/development/scons/slack-desc b/development/scons/slack-desc
new file mode 100644
index 0000000000..9b1c24e784
--- /dev/null
+++ b/development/scons/slack-desc
@@ -0,0 +1,11 @@
+scons: SCons
+scons:
+scons: SCons is an Open Source software construction tool--that is,
+scons: a next-generation build tool. Think of SCons as an improved,
+scons: cross-platform substitute for the classic Make utility with
+scons: integrated functionality similar to autoconf/automake and
+scons: compiler caches such as ccache. In short, SCons is an easier,
+scons: more reliable and faster way to build software.
+scons:
+scons:
+scons: