summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Daniel de Kok <danieldk@pobox.com>2010-05-11 14:05:53 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 14:05:53 +0200
commit6e67ed1e21d06bab6d8c37f1295dc88118c13796 (patch)
treeab211869d27b7c2b1f2353c005b58995ed806783 /development
parent1e71a72fbfc631a6eb5bcb987e6ed58aefece4ba (diff)
downloadslackbuilds-6e67ed1e21d06bab6d8c37f1295dc88118c13796.tar.gz
slackbuilds-6e67ed1e21d06bab6d8c37f1295dc88118c13796.tar.xz
development/webpy: Initial import
Diffstat (limited to 'development')
-rw-r--r--development/webpy/README12
-rw-r--r--development/webpy/slack-desc19
-rw-r--r--development/webpy/webpy.SlackBuild71
-rw-r--r--development/webpy/webpy.info8
4 files changed, 110 insertions, 0 deletions
diff --git a/development/webpy/README b/development/webpy/README
new file mode 100644
index 0000000000..1488381e84
--- /dev/null
+++ b/development/webpy/README
@@ -0,0 +1,12 @@
+web.py is a simple and powerful web framework for Python. It
+provides a simple database abstraction, a template engine, and
+abstractions for HTTP requests. A simple webserver is also included,
+which can be used to quickly try and test code.
+
+web.py does not have any additional requirements than stock Python
+from Slackware Linux. To use the database functionality, you could
+install pysqlite2, psycopg2, or MySQLdb modules.
+
+web.py was donated to the public domain by Aaron Swartz, and is
+available from: http://webpy.org/
+
diff --git a/development/webpy/slack-desc b/development/webpy/slack-desc
new file mode 100644
index 0000000000..7b70b7d6be
--- /dev/null
+++ b/development/webpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+webpy: web.py (a Python web framework)
+webpy:
+webpy: web.py is a simple and powerful web framework for Python. It
+webpy: provides a simple database abstraction, a template engine, and
+webpy: abstractions for HTTP requests. A simple webserver is also included,
+webpy: which can be used to quickly try and test code.
+webpy:
+webpy: web.py was donated to the public domain by Aaron Swartz, and is
+webpy: available from: http://webpy.org/
+webpy:
+webpy:
diff --git a/development/webpy/webpy.SlackBuild b/development/webpy/webpy.SlackBuild
new file mode 100644
index 0000000000..6fd14d702e
--- /dev/null
+++ b/development/webpy/webpy.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for web.py
+
+# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=webpy
+DISTNAM=web.py
+VERSION=0.2
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzvf $CWD/$DISTNAM-$VERSION.tar.gz
+cd $DISTNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist
+
+tar -C $PKG -zxvf dist/$DISTNAM-$VERSION.linux-i686.tar.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat << EOF > $PKG/usr/doc/$PRGNAM-$VERSION/README
+web.py does not include any documentation yet, a tutorial can be found
+on the web.py website: http://webpy.org/
+
+web.py was written by Aaron Swartz, and is in the public domain.
+EOF
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/webpy/webpy.info b/development/webpy/webpy.info
new file mode 100644
index 0000000000..95a3818888
--- /dev/null
+++ b/development/webpy/webpy.info
@@ -0,0 +1,8 @@
+PRGNAM="webpy"
+VERSION="0.2"
+HOMEPAGE="http://webpy.org/"
+DOWNLOAD="http://webpy.org/web.py-0.2.tar.gz"
+MD5SUM="0cee2d4ebcdf8a0bf26369f1eebc427d"
+MAINTAINER="Daniel de Kok"
+EMAIL="danieldk@pobox.com"
+APPROVED="robw810"