summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Vincent Batts <vbatts@hashbangbash.com>2011-07-03 13:40:40 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:54:02 -0300
commit7ba2ccd2a0006abcd31a9ee71c0dfc339466a5f5 (patch)
treec50e7b2c0d82142fee231bfbee4f79392d6d07bd /development
parent769dadaf444a25834210f5f88b222913e9d7f92f (diff)
downloadslackbuilds-7ba2ccd2a0006abcd31a9ee71c0dfc339466a5f5.tar.gz
slackbuilds-7ba2ccd2a0006abcd31a9ee71c0dfc339466a5f5.tar.xz
development/dissy: Added (graphical objdump disassembler)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/dissy/README4
-rw-r--r--development/dissy/dissy.SlackBuild103
-rw-r--r--development/dissy/dissy.desktop9
-rw-r--r--development/dissy/dissy.info10
-rw-r--r--development/dissy/doinst.sh4
-rw-r--r--development/dissy/slack-desc19
6 files changed, 149 insertions, 0 deletions
diff --git a/development/dissy/README b/development/dissy/README
new file mode 100644
index 0000000000..d1addb2c88
--- /dev/null
+++ b/development/dissy/README
@@ -0,0 +1,4 @@
+Dissy is a graphical frontend to the objdump disassembler.
+Dissy can be used for debugging and browsing compiler-generated code.
+
+Requires: pywebkitgtk (which requires icu4c, libsoup, and webkitgtk)
diff --git a/development/dissy/dissy.SlackBuild b/development/dissy/dissy.SlackBuild
new file mode 100644
index 0000000000..974a4db78d
--- /dev/null
+++ b/development/dissy/dissy.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for dissy
+
+# Copyright 2010,2011 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=dissy
+VERSION=${VERSION:-10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix manpage location.
+sed -i -e"s|share/man|man|" setup.py
+
+python setup.py install --root=$PKG
+
+# establish it in the xdg space
+mkdir -p $PKG/usr/share/applications
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/share/pixmaps
+( cd $PKG/usr/share/pixmaps
+ ln -s ../dissy/gfx/icon.svg dissy.svg
+)
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING ChangeLog MANIFEST README TODO UPGRADE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/development/dissy/dissy.desktop b/development/dissy/dissy.desktop
new file mode 100644
index 0000000000..9031cd9b70
--- /dev/null
+++ b/development/dissy/dissy.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=dissy
+GenericName=objdump Disassembler
+Comment=a graphical frontend to the objdump disassembler
+Exec=dissy
+Icon=dissy
+Categories=Development;
+Terminal=false
+Type=Application
diff --git a/development/dissy/dissy.info b/development/dissy/dissy.info
new file mode 100644
index 0000000000..f7667a87e0
--- /dev/null
+++ b/development/dissy/dissy.info
@@ -0,0 +1,10 @@
+PRGNAM="dissy"
+VERSION="10"
+HOMEPAGE="http://code.google.com/p/dissy/"
+DOWNLOAD="http://dissy.googlecode.com/files/dissy-10.tar.gz"
+MD5SUM="04e50e2aa21e34df15617ff04acf4d1e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Vincent Batts"
+EMAIL="vbatts@hashbangbash.com"
+APPROVED="dsomero"
diff --git a/development/dissy/doinst.sh b/development/dissy/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/development/dissy/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/development/dissy/slack-desc b/development/dissy/slack-desc
new file mode 100644
index 0000000000..f1cb561466
--- /dev/null
+++ b/development/dissy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+dissy: dissy (graphical objdump disassembler)
+dissy:
+dissy: Dissy is a graphical frontend to the objdump disassembler.
+dissy: Dissy can be used for debugging and browsing compiler-generated code.
+dissy:
+dissy:
+dissy:
+dissy:
+dissy:
+dissy:
+dissy: