summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-11 14:05:52 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 14:05:52 +0200
commit8ac1a463dbcc85bc2296ce729da7d200cda142cd (patch)
tree96f07bd2adb02246e0db25d4e6cd24933772f8af /development
parent6d0baba5920cea6e9efa57d56feb7046cc1282ae (diff)
downloadslackbuilds-8ac1a463dbcc85bc2296ce729da7d200cda142cd.tar.gz
slackbuilds-8ac1a463dbcc85bc2296ce729da7d200cda142cd.tar.xz
development/pysetuptools: Initial import
Diffstat (limited to 'development')
-rw-r--r--development/pysetuptools/README19
-rw-r--r--development/pysetuptools/pysetuptools.SlackBuild53
-rw-r--r--development/pysetuptools/pysetuptools.info8
-rw-r--r--development/pysetuptools/slack-desc7
4 files changed, 87 insertions, 0 deletions
diff --git a/development/pysetuptools/README b/development/pysetuptools/README
new file mode 100644
index 0000000000..0a24d7b352
--- /dev/null
+++ b/development/pysetuptools/README
@@ -0,0 +1,19 @@
+pysetuptools (a collection of enhancements to Python distutils)
+Note: the name of the source package is 'setuptools'. Since 'setuptools'
+is such a generic name, this package uses the name 'pysetuptools' to avoid
+any potential future conflicts. The actual installation paths and file
+names are not modified in any way.
+
+setuptools allow you to more easily build and distribute Python packages,
+especially ones that have dependencies on other packages.
+
+Packages built and distributed using setuptools look to the user like ordinary
+Python packages based on the distutils. Your users don't need to install or
+even know about setuptools in order to use them, and you don't have to include
+the entire setuptools package in your distributions. By including just a single
+bootstrap module (an 8K .py file), your package will automatically download and
+install setuptools if the user is building your package from source and doesn't
+have a suitable version already installed.
+
+Requires: >=python-2.3.5 on 32-bit systems >=python-2.4 on 64-bit systems
+
diff --git a/development/pysetuptools/pysetuptools.SlackBuild b/development/pysetuptools/pysetuptools.SlackBuild
new file mode 100644
index 0000000000..d08da37ef9
--- /dev/null
+++ b/development/pysetuptools/pysetuptools.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+
+# Modified by the SlackBuilds.org project
+
+if [ "$(id -u)" != "0" ]; then
+ echo "This script must be run as root!"
+ exit
+fi
+
+NAME=setuptools
+PKG_NAME=pysetuptools
+VERSION=0.6c3
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $NAME-$VERSION
+tar -zxvf $CWD/$NAME-$VERSION.tar.gz || exit 1
+cd $NAME-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist || exit 1
+
+tar -C $PKG -zxvf dist/$NAME-$VERSION.linux-i686.tar.gz || exit 1
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$PKG_NAME-$VERSION
+cp -a PKG_INFO $PKG/usr/doc/$PKG_NAME-$VERSION
+install -m 0644 *.txt $PKG/usr/doc/$PKG_NAME-$VERSION
+cat $CWD/$PKG_NAME.SlackBuild > $PKG/usr/doc/$PKG_NAME-$VERSION/$PKG_NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$PKG_NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/pysetuptools/pysetuptools.info b/development/pysetuptools/pysetuptools.info
new file mode 100644
index 0000000000..9e56d2bc59
--- /dev/null
+++ b/development/pysetuptools/pysetuptools.info
@@ -0,0 +1,8 @@
+PRGNAM="pysetuptools"
+VERSION="0.6c3"
+HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
+DOWNLOAD="http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-0.6c3.tar.gz"
+MD5SUM="76cb98b779d356c64323125490f88d17"
+MAINTAINER="hollywoodb"
+EMAIL="hollywoodb@fastmail.fm"
+APPROVED="robw810"
diff --git a/development/pysetuptools/slack-desc b/development/pysetuptools/slack-desc
new file mode 100644
index 0000000000..5321df0e6a
--- /dev/null
+++ b/development/pysetuptools/slack-desc
@@ -0,0 +1,7 @@
+pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
+pysetuptools:
+pysetuptools: setuptools allow you to more easily build and distribute Python
+pysetuptools: packages, especially ones that have dependencies on other packages.
+pysetuptools:
+pysetuptools:
+pysetuptools: