summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2010-09-17 04:38:52 -0400
committer Robby Workman <rworkman@slackbuilds.org>2010-09-21 22:09:37 -0500
commit9795bb800a5c3992e8ba4501d50016efce8ee0fe (patch)
tree8f58ed31f4371a81ecac1a5270464e2b7bb8d2fd /development
parent4fd7d5c97eaef1f46252ed4664a706bf0131747c (diff)
downloadslackbuilds-9795bb800a5c3992e8ba4501d50016efce8ee0fe.tar.gz
slackbuilds-9795bb800a5c3992e8ba4501d50016efce8ee0fe.tar.xz
development/distribute: Added (fork of the Setuptools project)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/distribute/README14
-rw-r--r--development/distribute/distribute.SlackBuild48
-rw-r--r--development/distribute/distribute.info10
-rw-r--r--development/distribute/slack-desc19
4 files changed, 91 insertions, 0 deletions
diff --git a/development/distribute/README b/development/distribute/README
new file mode 100644
index 0000000000..3ba0c42347
--- /dev/null
+++ b/development/distribute/README
@@ -0,0 +1,14 @@
+distribute is a fork of the setuptools project.
+
+Distribute is intended to replace Setuptools as the standard method for working
+with Python module distributions.
+
+For those who may wonder why they should switch to Distribute over Setuptools,
+it's quite simple:
+
+- Distribute is a drop-in replacement for Setuptools.
+- The code is actively maintained, and has over 10 commiters.
+- Distribute offers Python 3 support!
+
+If you have pysetuptools installed, you need to remove it before installing
+this package.
diff --git a/development/distribute/distribute.SlackBuild b/development/distribute/distribute.SlackBuild
new file mode 100644
index 0000000000..a2b54f7767
--- /dev/null
+++ b/development/distribute/distribute.SlackBuild
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+# Slackware build script for distribute
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=distribute
+VERSION=${VERSION:-0.6.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Don't need this.
+rm -f setuptools/*.exe
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/distribute/distribute.info b/development/distribute/distribute.info
new file mode 100644
index 0000000000..246324c8ff
--- /dev/null
+++ b/development/distribute/distribute.info
@@ -0,0 +1,10 @@
+PRGNAM="distribute"
+VERSION="0.6.14"
+HOMEPAGE="http://packages.python.org/distribute/"
+DOWNLOAD="http://pypi.python.org/packages/source/d/distribute/distribute-0.6.14.tar.gz"
+MD5SUM="ac607e05682116c06383b27a15e2db90"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="dsomero"
diff --git a/development/distribute/slack-desc b/development/distribute/slack-desc
new file mode 100644
index 0000000000..fa712f2e70
--- /dev/null
+++ b/development/distribute/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+distribute: Distribute (a fork of the Setuptools project)
+distribute:
+distribute: Distribute is intended to replace Setuptools as the standard method
+distribute: for working with Python module distributions.
+distribute:
+distribute: Homepage: http://packages.python.org/distribute/
+distribute:
+distribute:
+distribute:
+distribute:
+distribute: