summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-12-21 12:12:16 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-21 21:27:24 +0100
commitcc91f441277924ab710b3cded9953fbc6c66a8eb (patch)
tree9245a3bfc63aa1f1c0a4414f609ff345ae06fb0e /development
parenta0c8747e511eb02e1b7e38c24d8110f8a49f1550 (diff)
downloadslackbuilds-cc91f441277924ab710b3cded9953fbc6c66a8eb.tar.gz
slackbuilds-cc91f441277924ab710b3cded9953fbc6c66a8eb.tar.xz
development/ninja-ide: Added (python coding IDE).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/ninja-ide/README6
-rw-r--r--development/ninja-ide/doinst.sh4
-rw-r--r--development/ninja-ide/ninja-ide.SlackBuild74
-rw-r--r--development/ninja-ide/ninja-ide.desktop10
-rw-r--r--development/ninja-ide/ninja-ide.info10
-rw-r--r--development/ninja-ide/slack-desc19
6 files changed, 123 insertions, 0 deletions
diff --git a/development/ninja-ide/README b/development/ninja-ide/README
new file mode 100644
index 0000000000..118dff0731
--- /dev/null
+++ b/development/ninja-ide/README
@@ -0,0 +1,6 @@
+NINJA-IDE (from the recursive acronym: "Ninja-IDE Is Not Just Another
+IDE"), is a cross-platform integrated development environment (IDE).
+NINJA-IDE runs on Linux/X11, Mac OS X and Windows desktop operating
+systems, and allows developers to create applications for several
+purposes using all the tools and utilities of NINJA-IDE, making the
+task of writing software easier and more enjoyable.
diff --git a/development/ninja-ide/doinst.sh b/development/ninja-ide/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/development/ninja-ide/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/development/ninja-ide/ninja-ide.SlackBuild b/development/ninja-ide/ninja-ide.SlackBuild
new file mode 100644
index 0000000000..a5ef86718a
--- /dev/null
+++ b/development/ninja-ide/ninja-ide.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for ninja-ide
+
+# Copyright 2012 Binh Nguyen <binhvng@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ninja-ide
+VERSION=${VERSION:-2.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+unzip $CWD/$PRGNAM-v$VERSION.zip
+cd $PRGNAM
+chown -R root:root .
+chmod -R u+w,go+r-w,a+X-s .
+
+python setup.py install --root=$PKG -O1
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Install icon file:
+install -D -m 644 icon.png $PKG/usr/share/pixmaps/ninja-ide.png
+# Install desktop file (borrowed from Arch Linux):
+install -D -m 644 $CWD/ninja-ide.desktop \
+ $PKG/usr/share/applications/ninja-ide.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/ninja-ide/ninja-ide.desktop b/development/ninja-ide/ninja-ide.desktop
new file mode 100644
index 0000000000..35b4cc0913
--- /dev/null
+++ b/development/ninja-ide/ninja-ide.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Ninja IDE
+Comment=A Python IDE
+Exec=ninja-ide
+Icon=ninja-ide
+Terminal=false
+Type=Application
+Categories=Development;
+StartupNotify=true
+MimeType=application/x-python;application/x-ninja-ide;
diff --git a/development/ninja-ide/ninja-ide.info b/development/ninja-ide/ninja-ide.info
new file mode 100644
index 0000000000..04d5106d1c
--- /dev/null
+++ b/development/ninja-ide/ninja-ide.info
@@ -0,0 +1,10 @@
+PRGNAM="ninja-ide"
+VERSION="2.1.1"
+HOMEPAGE="http://ninja-ide.org/"
+DOWNLOAD="http://cloud.github.com/downloads/ninja-ide/ninja-ide/ninja-ide-v2.1.1.zip"
+MD5SUM="d12de39bb678a1db510bbb830bfc8f33"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="distribute pyinotify"
+MAINTAINER="Binh Nguyen"
+EMAIL="binhvng@gmail.com"
diff --git a/development/ninja-ide/slack-desc b/development/ninja-ide/slack-desc
new file mode 100644
index 0000000000..3dc62efdea
--- /dev/null
+++ b/development/ninja-ide/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ninja-ide: ninja-ide (Cross-platform IDE focused on Python app. development)
+ninja-ide:
+ninja-ide: NINJA-IDE (from the recursive acronym: "Ninja-IDE Is Not Just Another
+ninja-ide: IDE"), is a cross-platform integrated development environment (IDE).
+ninja-ide: NINJA-IDE runs on Linux/X11, Mac OS X and Windows desktop operating
+ninja-ide: systems, and allows developers to create applications for several
+ninja-ide: purposes using all the tools and utilities of NINJA-IDE, making the
+ninja-ide: task of writing software easier and more enjoyable.
+ninja-ide:
+ninja-ide: Homepage: http://ninja-ide.org/
+ninja-ide: