summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-11 19:44:20 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 19:44:20 +0200
commitda48ae0e47066ab5fa7d5cd23dc420bbd780fa4c (patch)
tree0eb6b3e3f4eb646ad07afd15a2a910e12d83ea6b /development
parentfcf63922c649bebfaae1dfae383a6d8b789e2550 (diff)
downloadslackbuilds-da48ae0e47066ab5fa7d5cd23dc420bbd780fa4c.tar.gz
slackbuilds-da48ae0e47066ab5fa7d5cd23dc420bbd780fa4c.tar.xz
development/pysetuptools: Updated for version 0.6c6
Diffstat (limited to 'development')
-rw-r--r--development/pysetuptools/README1
-rw-r--r--development/pysetuptools/pysetuptools.SlackBuild22
-rw-r--r--development/pysetuptools/pysetuptools.info6
-rw-r--r--development/pysetuptools/slack-desc16
4 files changed, 26 insertions, 19 deletions
diff --git a/development/pysetuptools/README b/development/pysetuptools/README
index 0a24d7b352..a7e5aa9e21 100644
--- a/development/pysetuptools/README
+++ b/development/pysetuptools/README
@@ -16,4 +16,3 @@ install setuptools if the user is building your package from source and doesn't
have a suitable version already installed.
Requires: >=python-2.3.5 on 32-bit systems >=python-2.4 on 64-bit systems
-
diff --git a/development/pysetuptools/pysetuptools.SlackBuild b/development/pysetuptools/pysetuptools.SlackBuild
index d08da37ef9..171e2b875b 100644
--- a/development/pysetuptools/pysetuptools.SlackBuild
+++ b/development/pysetuptools/pysetuptools.SlackBuild
@@ -7,20 +7,15 @@
## so that I don't recieve emails about a script I
## did not write. Thanks.
-# Modified by the SlackBuilds.org project
-
-if [ "$(id -u)" != "0" ]; then
- echo "This script must be run as root!"
- exit
-fi
+# Mofified by the SlackBuilds.org project
NAME=setuptools
PKG_NAME=pysetuptools
-VERSION=0.6c3
+VERSION=0.6c6
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=${PKG:-$TMP/package-$NAME}
OUTPUT=${OUTPUT:-/tmp}
@@ -35,14 +30,15 @@ chown -R root:root .
chmod -R u+w,go+r-w,a-s .
python setup.py bdist || exit 1
+tar zxvf dist/$NAME-$VERSION.linux-i686.tar.gz -C $PKG || exit 1
-tar -C $PKG -zxvf dist/$NAME-$VERSION.linux-i686.tar.gz || exit 1
-
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
mkdir -p $PKG/usr/doc/$PKG_NAME-$VERSION
-cp -a PKG_INFO $PKG/usr/doc/$PKG_NAME-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PKG_NAME-$VERSION
install -m 0644 *.txt $PKG/usr/doc/$PKG_NAME-$VERSION
cat $CWD/$PKG_NAME.SlackBuild > $PKG/usr/doc/$PKG_NAME-$VERSION/$PKG_NAME.SlackBuild
diff --git a/development/pysetuptools/pysetuptools.info b/development/pysetuptools/pysetuptools.info
index 9e56d2bc59..339c096121 100644
--- a/development/pysetuptools/pysetuptools.info
+++ b/development/pysetuptools/pysetuptools.info
@@ -1,8 +1,8 @@
PRGNAM="pysetuptools"
-VERSION="0.6c3"
+VERSION="0.6c6"
HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
-DOWNLOAD="http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-0.6c3.tar.gz"
+DOWNLOAD="http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-0.6c6.tar.gz"
MD5SUM="76cb98b779d356c64323125490f88d17"
MAINTAINER="hollywoodb"
EMAIL="hollywoodb@fastmail.fm"
-APPROVED="robw810"
+APPROVED="rworkman"
diff --git a/development/pysetuptools/slack-desc b/development/pysetuptools/slack-desc
index 5321df0e6a..f0d5f78410 100644
--- a/development/pysetuptools/slack-desc
+++ b/development/pysetuptools/slack-desc
@@ -1,7 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
pysetuptools:
-pysetuptools: setuptools allow you to more easily build and distribute Python
-pysetuptools: packages, especially ones that have dependencies on other packages.
+pysetuptools: setuptools allow you to more easily build and distribute
+pysetuptools: Python packages, especially ones that have dependencies on
+pysetuptools: other packages.
+pysetuptools:
+pysetuptools:
+pysetuptools:
pysetuptools:
pysetuptools:
pysetuptools: