summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2010-05-11 22:53:38 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:53:38 +0200
commit4e9d1f3b9ede0b989a4fb9bd3da0dcfb483f4bad (patch)
tree976c009bb2d42c48656e500c597ab33d4dfc5350 /development
parent2ed77e80d4e0c9fbc4a63aee6432f1f423e5f933 (diff)
downloadslackbuilds-4e9d1f3b9ede0b989a4fb9bd3da0dcfb483f4bad.tar.gz
slackbuilds-4e9d1f3b9ede0b989a4fb9bd3da0dcfb483f4bad.tar.xz
development/pyparsing: Added to 12.1 repository
Diffstat (limited to 'development')
-rw-r--r--development/pyparsing/README5
-rw-r--r--development/pyparsing/pyparsing.SlackBuild72
-rw-r--r--development/pyparsing/pyparsing.info8
-rw-r--r--development/pyparsing/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/development/pyparsing/README b/development/pyparsing/README
new file mode 100644
index 0000000000..2834826056
--- /dev/null
+++ b/development/pyparsing/README
@@ -0,0 +1,5 @@
+The pyparsing module is an alternative approach to creating and
+executing simple grammars, vs. the traditional lex/yacc
+approach, or the use of regular expressions. The pyparsing
+module provides a library of classes that client code uses to
+construct the grammar directly in Python code. \ No newline at end of file
diff --git a/development/pyparsing/pyparsing.SlackBuild b/development/pyparsing/pyparsing.SlackBuild
new file mode 100644
index 0000000000..ee7db34c06
--- /dev/null
+++ b/development/pyparsing/pyparsing.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for pyparsing
+
+# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyparsing
+VERSION=1.5.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py bdist
+
+tar xzf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
+ | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE PKG-INFO README HowToUsePyparsing.html \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/pyparsing/pyparsing.info b/development/pyparsing/pyparsing.info
new file mode 100644
index 0000000000..d14e1237f6
--- /dev/null
+++ b/development/pyparsing/pyparsing.info
@@ -0,0 +1,8 @@
+PRGNAM="pyparsing"
+VERSION="1.5.1"
+HOMEPAGE="http://pyparsing.wikispaces.com/"
+DOWNLOAD="http://downloads.sourceforge.net/pyparsing/pyparsing-1.5.1.tar.gz"
+MD5SUM="d0777821fc4c5f2474cda1081229d76b"
+MAINTAINER="ppr:kut"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="dsomero"
diff --git a/development/pyparsing/slack-desc b/development/pyparsing/slack-desc
new file mode 100644
index 0000000000..53c17d5249
--- /dev/null
+++ b/development/pyparsing/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------|
+pyparsing: pyparsing (parsing module for python)
+pyparsing:
+pyparsing: The pyparsing module is an alternative approach to creating and
+pyparsing: executing simple grammars, vs. the traditional lex/yacc
+pyparsing: approach, or the use of regular expressions. The pyparsing
+pyparsing: module provides a library of classes that client code uses to
+pyparsing: construct the grammar directly in Python code.
+pyparsing:
+pyparsing: Homepage: http://pyparsing.wikispaces.com/
+pyparsing:
+pyparsing: