summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2012-09-25 12:40:36 -0500
committer Robby Workman <rworkman@slackbuilds.org>2012-09-28 21:36:04 -0500
commit73b69ff59653315f3274902908da86e17cdfb4ad (patch)
tree0c7eec43ddbdfba960d82e4e78ce257a977b0ea2 /development
parentfc47905f75f804369b9cd30eff2d3334b00f4cb6 (diff)
downloadslackbuilds-73b69ff59653315f3274902908da86e17cdfb4ad.tar.gz
slackbuilds-73b69ff59653315f3274902908da86e17cdfb4ad.tar.xz
development/gforth: Removed (build failure)
This appears to be unmaintained upstream. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/gforth/README8
-rw-r--r--development/gforth/gforth.SlackBuild88
-rw-r--r--development/gforth/gforth.info10
-rw-r--r--development/gforth/slack-desc20
4 files changed, 0 insertions, 126 deletions
diff --git a/development/gforth/README b/development/gforth/README
deleted file mode 100644
index c31ed6a30b..0000000000
--- a/development/gforth/README
+++ /dev/null
@@ -1,8 +0,0 @@
-GNU Forth interpreter that is ANSI compliant.
-
-NOTE: If you Compile or otherwise install the Ffcall package, GForth will
-also have the ability to call libraries of C software. Ffcall must be
-installed first in order for GForth to detect this, however.
-However, GForth can run on its own without Ffcall. For this reason, Ffcall
-is not listed as a dependency.
-
diff --git a/development/gforth/gforth.SlackBuild b/development/gforth/gforth.SlackBuild
deleted file mode 100644
index e192f33df1..0000000000
--- a/development/gforth/gforth.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for gforth
-
-# Written by Zbigniew Baniewski, zb@ispid.com.pl
-
-PRGNAM=gforth
-VERSION=0.7.0
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix old-style flag
-sed -i "s/-m486/-mtune=i486/g" configure.in
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-rm -f $PKG/usr/info/dir
-gzip -9 $PKG/usr/info/*.info*
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- doc/gforth.ps AUTHORS BUGS COPYING* ChangeLog NEWS* README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gforth/gforth.info b/development/gforth/gforth.info
deleted file mode 100644
index c464fd7820..0000000000
--- a/development/gforth/gforth.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="gforth"
-VERSION="0.7.0"
-HOMEPAGE="http://www.gnu.org/software/gforth/"
-DOWNLOAD="http://mirrors.kernel.org/gnu/gforth/gforth-0.7.0.tar.gz"
-MD5SUM="2979ae86ede73ce2b3576dae957f4098"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Zbigniew Baniewski"
-EMAIL="zb@ispid.com.pl"
diff --git a/development/gforth/slack-desc b/development/gforth/slack-desc
deleted file mode 100644
index ea76fa7bfb..0000000000
--- a/development/gforth/slack-desc
+++ /dev/null
@@ -1,20 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-gforth: gforth (GNU Forth interpreter)
-gforth:
-gforth: GNU Forth interpreter that is ANSI compliant.
-gforth:
-gforth: http://www.gnu.org/software/gforth/
-gforth:
-gforth:
-gforth:
-gforth:
-gforth:
-gforth:
-