summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Aleksandar Samardzic <asamardzic@gmail.com>2010-05-11 22:53:39 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:53:39 +0200
commit98568aa25a389ad0c2e98eab1986b972b97226b9 (patch)
tree45ceb0da82315f3df7103fb4a6c23b185f390979 /development
parent4e9d1f3b9ede0b989a4fb9bd3da0dcfb483f4bad (diff)
downloadslackbuilds-98568aa25a389ad0c2e98eab1986b972b97226b9.tar.gz
slackbuilds-98568aa25a389ad0c2e98eab1986b972b97226b9.tar.xz
development/pyplusplus: Added to 12.1 repository
Diffstat (limited to 'development')
-rw-r--r--development/pyplusplus/README11
-rw-r--r--development/pyplusplus/pyplusplus.SlackBuild60
-rw-r--r--development/pyplusplus/pyplusplus.info8
-rw-r--r--development/pyplusplus/slack-desc19
4 files changed, 98 insertions, 0 deletions
diff --git a/development/pyplusplus/README b/development/pyplusplus/README
new file mode 100644
index 0000000000..1caa88770f
--- /dev/null
+++ b/development/pyplusplus/README
@@ -0,0 +1,11 @@
+Py++ is an object-oriented framework for creating a code generator for
+Boost.Python library. Py++ uses few different programming paradigms
+to help you to expose C++ declarations to Python. This code generator
+will not stand on your way. It will guide you through the whole
+process. It will raise warnings in the case you are doing something
+wrong with a link to the explanation. And the most important it will
+save your time - you will not have to update code generator script
+every time source code is changed.
+
+Py++ package is dependent upon Boost, gccxml and pygccxml packages,
+all available on SlackBuilds.org.
diff --git a/development/pyplusplus/pyplusplus.SlackBuild b/development/pyplusplus/pyplusplus.SlackBuild
new file mode 100644
index 0000000000..d5b09a8edf
--- /dev/null
+++ b/development/pyplusplus/pyplusplus.SlackBuild
@@ -0,0 +1,60 @@
+#!/bin/sh
+
+# Slackware build script for Py++
+
+# Written by Aleksandar Samardzic <asamardzic@gmail.com>
+
+PRGNAM=pyplusplus
+VERSION=${VERSION:-1.0.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+NAME=Py++
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $NAME-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $NAME-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE_1_0.txt MANIFEST README.txt announcement.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/pyplusplus/pyplusplus.info b/development/pyplusplus/pyplusplus.info
new file mode 100644
index 0000000000..4938f03eb9
--- /dev/null
+++ b/development/pyplusplus/pyplusplus.info
@@ -0,0 +1,8 @@
+PRGNAM="pyplusplus"
+VERSION="1.0.0"
+HOMEPAGE="http://www.language-binding.net/pyplusplus/pyplusplus.html"
+DOWNLOAD="http://downloads.sourceforge.net/pygccxml/pyplusplus-1.0.0.zip"
+MD5SUM="4997f61fa27a432e36fa0142dc3dc06c"
+MAINTAINER="Aleksandar Samardzic"
+EMAIL="asamardzic@gmail.com"
+APPROVED="dsomero"
diff --git a/development/pyplusplus/slack-desc b/development/pyplusplus/slack-desc
new file mode 100644
index 0000000000..5c6fd39f09
--- /dev/null
+++ b/development/pyplusplus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyplusplus: Py++ (code generator framework)
+pyplusplus:
+pyplusplus: Py++ is an object-oriented framework for creating a code
+pyplusplus: generator for Boost.Python library.
+pyplusplus:
+pyplusplus: Homepage:
+pyplusplus: http://www.language-binding.net/pyplusplus/pyplusplus.html
+pyplusplus:
+pyplusplus:
+pyplusplus:
+pyplusplus: