summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2010-05-11 22:53:30 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:53:30 +0200
commite28d49dce45143dd546823081188c941ae4721c2 (patch)
treefb84aee733dede09f3cddc0aaeaab0064517de1d /development
parent15bd032b578c8c2cf81b59fb3aac001df9fca785 (diff)
downloadslackbuilds-e28d49dce45143dd546823081188c941ae4721c2.tar.gz
slackbuilds-e28d49dce45143dd546823081188c941ae4721c2.tar.xz
development/egenix-mx-base: Added to 12.1 repository
Diffstat (limited to 'development')
-rw-r--r--development/egenix-mx-base/README3
-rw-r--r--development/egenix-mx-base/egenix-mx-base.SlackBuild72
-rw-r--r--development/egenix-mx-base/egenix-mx-base.info8
-rw-r--r--development/egenix-mx-base/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/development/egenix-mx-base/README b/development/egenix-mx-base/README
new file mode 100644
index 0000000000..9597bf0dbe
--- /dev/null
+++ b/development/egenix-mx-base/README
@@ -0,0 +1,3 @@
+This is the eGenix-mx Base Distribution for Python.
+It includes mxDateTime, mxTextTools, mxProxy, mxTools,
+mxBeeBase, mxStack, mxQueue, mxURL, and mxUID.
diff --git a/development/egenix-mx-base/egenix-mx-base.SlackBuild b/development/egenix-mx-base/egenix-mx-base.SlackBuild
new file mode 100644
index 0000000000..ac61a9ec46
--- /dev/null
+++ b/development/egenix-mx-base/egenix-mx-base.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for egenix-mx-base
+
+# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=egenix-mx-base
+VERSION=3.1.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep "shared object" | grep ELF | \
+ cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYRIGHT LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/egenix-mx-base/egenix-mx-base.info b/development/egenix-mx-base/egenix-mx-base.info
new file mode 100644
index 0000000000..afcf6a9c74
--- /dev/null
+++ b/development/egenix-mx-base/egenix-mx-base.info
@@ -0,0 +1,8 @@
+PRGNAM="egenix-mx-base"
+VERSION="3.1.1"
+HOMEPAGE="http://www.egenix.com/products/python/mxBase/"
+DOWNLOAD="http://downloads.egenix.com/python/egenix-mx-base-3.1.1.tar.gz"
+MD5SUM="d0f3b1adca33a68867bf50f000060cd6"
+MAINTAINER="ppr:kut"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="David Somero" \ No newline at end of file
diff --git a/development/egenix-mx-base/slack-desc b/development/egenix-mx-base/slack-desc
new file mode 100644
index 0000000000..c268971ece
--- /dev/null
+++ b/development/egenix-mx-base/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------|
+egenix-mx-base: egenix-mx-base (eGenix mx Base Distribution for python)
+egenix-mx-base:
+egenix-mx-base: This is the eGenix mx Base Distribution for Python.
+egenix-mx-base: It includes mxDateTime, mxTextTools, mxProxy, mxTools,
+egenix-mx-base: mxBeeBase, mxStack, mxQueue, mxURL, and mxUID.
+egenix-mx-base:
+egenix-mx-base: Homepage: http://www.egenix.com/products/python/mxBase/
+egenix-mx-base:
+egenix-mx-base:
+egenix-mx-base:
+egenix-mx-base: