summaryrefslogtreecommitdiffstats
path: root/games/PyLotRO/PyLotRO.SlackBuild
diff options
context:
space:
mode:
author JK Wood <joshuakwood[at]gmail.com>2012-12-16 22:24:50 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-16 22:25:20 +0100
commit58ab28e64f037d788f4b9c5e4b91ab2bb6e1d5e4 (patch)
tree4c58788ffaab379934573eea9db00e67f4bc6ef3 /games/PyLotRO/PyLotRO.SlackBuild
parent8d0150f686ed0c03f6ec2a224277a3afa15b4213 (diff)
downloadslackbuilds-58ab28e64f037d788f4b9c5e4b91ab2bb6e1d5e4.tar.gz
slackbuilds-58ab28e64f037d788f4b9c5e4b91ab2bb6e1d5e4.tar.xz
games/PyLotRO: Added (Python launcher of Lord of the Rings Online).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/PyLotRO/PyLotRO.SlackBuild')
-rw-r--r--games/PyLotRO/PyLotRO.SlackBuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/games/PyLotRO/PyLotRO.SlackBuild b/games/PyLotRO/PyLotRO.SlackBuild
new file mode 100644
index 0000000000..85db53c15f
--- /dev/null
+++ b/games/PyLotRO/PyLotRO.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackbuild for PyLotRO
+
+# Slackbuild is released under the Dog-on-Fire License:
+# If use of this script causes your dog to catch on fire,
+# you agree to send me five dollars. Or a picture
+# of the dog on fire.
+# Otherwise, you're on your own. I've tested the script
+# on my own computer, and it hasn't broken anything.
+# So if it does it on your computer, that falls in
+# the realm of "Not my problem."
+#
+# Of course, if you'll send a bug report to the above
+# email address, I may be able to see what you did
+# wrong and prevent it from happening in the future.
+# In which case, I may just send YOU five dollars.
+
+# Oh, and feel free to copy it and modify it as you
+# see fit. Or as I see fit. Or as I fit. Although
+# that is unlikely, as I am rather tall.
+
+
+PRGNAM=PyLotRO
+VERSION=${VERSION:-0.1.15}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+mv $PRGNAM $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}