summaryrefslogtreecommitdiffstats
path: root/games/PyLotRO
diff options
context:
space:
mode:
author JK Wood <joshuakwood[at]gmail.com>2012-12-16 22:24:50 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-16 22:25:20 +0100
commit58ab28e64f037d788f4b9c5e4b91ab2bb6e1d5e4 (patch)
tree4c58788ffaab379934573eea9db00e67f4bc6ef3 /games/PyLotRO
parent8d0150f686ed0c03f6ec2a224277a3afa15b4213 (diff)
downloadslackbuilds-58ab28e64f037d788f4b9c5e4b91ab2bb6e1d5e4.tar.gz
slackbuilds-58ab28e64f037d788f4b9c5e4b91ab2bb6e1d5e4.tar.xz
games/PyLotRO: Added (Python launcher of Lord of the Rings Online).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/PyLotRO')
-rw-r--r--games/PyLotRO/PyLotRO.SlackBuild74
-rw-r--r--games/PyLotRO/PyLotRO.info10
-rw-r--r--games/PyLotRO/README11
-rw-r--r--games/PyLotRO/slack-desc19
4 files changed, 114 insertions, 0 deletions
diff --git a/games/PyLotRO/PyLotRO.SlackBuild b/games/PyLotRO/PyLotRO.SlackBuild
new file mode 100644
index 0000000000..85db53c15f
--- /dev/null
+++ b/games/PyLotRO/PyLotRO.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackbuild for PyLotRO
+
+# Slackbuild is released under the Dog-on-Fire License:
+# If use of this script causes your dog to catch on fire,
+# you agree to send me five dollars. Or a picture
+# of the dog on fire.
+# Otherwise, you're on your own. I've tested the script
+# on my own computer, and it hasn't broken anything.
+# So if it does it on your computer, that falls in
+# the realm of "Not my problem."
+#
+# Of course, if you'll send a bug report to the above
+# email address, I may be able to see what you did
+# wrong and prevent it from happening in the future.
+# In which case, I may just send YOU five dollars.
+
+# Oh, and feel free to copy it and modify it as you
+# see fit. Or as I see fit. Or as I fit. Although
+# that is unlikely, as I am rather tall.
+
+
+PRGNAM=PyLotRO
+VERSION=${VERSION:-0.1.15}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+mv $PRGNAM $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/PyLotRO/PyLotRO.info b/games/PyLotRO/PyLotRO.info
new file mode 100644
index 0000000000..2f87bdd0b3
--- /dev/null
+++ b/games/PyLotRO/PyLotRO.info
@@ -0,0 +1,10 @@
+PRGNAM="PyLotRO"
+VERSION="0.1.15"
+HOMEPAGE="https://sites.google.com/site/leeslinuxblog/installing-lotro-in-wine"
+DOWNLOAD="https://sites.google.com/site/leeslinuxblog/PyLotRO-0.1.15.zip"
+MD5SUM="ff7f0baf94290c44263a1618e7e6a116"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="JK Wood"
+EMAIL="joshuakwood[at]gmail.com"
diff --git a/games/PyLotRO/README b/games/PyLotRO/README
new file mode 100644
index 0000000000..cbed665fa7
--- /dev/null
+++ b/games/PyLotRO/README
@@ -0,0 +1,11 @@
+PyLotRO is a launcher for The Lord of the Rings Online and Dungeons
+and Dragons Online for Linux and Mac OSX. This application gives a
+graphical interface that allows both starting and patching/updating
+the game when installed in Wine.
+
+The homepage for PyLotRO disappeared some time ago, but no further
+development appears to be necessary.
+
+PyLotRO does not have any extra build dependencies beyond those
+present in a full install of Slackware, but wine is required to
+actually play either LOTRO or DDO.
diff --git a/games/PyLotRO/slack-desc b/games/PyLotRO/slack-desc
new file mode 100644
index 0000000000..1495beabe7
--- /dev/null
+++ b/games/PyLotRO/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+PyLotRO: PyLotRO (Python launcher of Lord of the Rings Online)
+PyLotRO:
+PyLotRO: PyLotRO is a launcher for the Lord of the Rings Online MMO written
+PyLotRO: in Python. It allows patching and beginning the game under Linux
+PyLotRO: when installed in wine.
+PyLotRO: PyLotRO should also work with Dungeons and Dragons Online (DDO).
+PyLotRO:
+PyLotRO: Homepage:
+PyLotRO: https://sites.google.com/site/leeslinuxblog/installing-lotro-in-wine
+PyLotRO:
+PyLotRO: