summaryrefslogtreecommitdiffstats
path: root/games/assaultcube/assaultcube.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-05-13 00:58:06 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:58:06 +0200
commit3e0f09fb81fee4ed33861ab0dc5996128711c478 (patch)
treeebc624b6cfb7c874aed81f2e4239af56461e0dec /games/assaultcube/assaultcube.SlackBuild
parent436ac22550e0c596636a09c93e6742bd6ddeafdc (diff)
downloadslackbuilds-3e0f09fb81fee4ed33861ab0dc5996128711c478.tar.gz
slackbuilds-3e0f09fb81fee4ed33861ab0dc5996128711c478.tar.xz
games/assaultcube: Added to 13.0 repository
Diffstat (limited to 'games/assaultcube/assaultcube.SlackBuild')
-rw-r--r--games/assaultcube/assaultcube.SlackBuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/games/assaultcube/assaultcube.SlackBuild b/games/assaultcube/assaultcube.SlackBuild
new file mode 100644
index 0000000000..568987bb52
--- /dev/null
+++ b/games/assaultcube/assaultcube.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for assaultcube
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+SRCNAM=AssaultCube
+PRGNAM=assaultcube
+VERSION=${VERSION:-1.0.4}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${SRCNAM}_v1.0.2
+tar xvf $CWD/${SRCNAM}_v1.0.2.tar.bz2
+cd ${SRCNAM}_v1.0.2
+tar xvf $CWD/${SRCNAM}_v${VERSION}-Update.tar.bz2
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# We need to change the order of the enet libs and includes. Enet libs and include
+# directories need to be declared first as compile will fail if enet is already
+# installed on the system and the Makefile uses system files instead. Also, use
+# custom SLKCFLAGS.
+patch -p1 < $CWD/Makefile.patch
+sed -i "s|-O2|$SLKCFLAGS|" source/enet/configure
+
+CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
+make -C source/src
+CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
+make -C source/src install
+
+mkdir -p $PKG/usr/games $PKG/usr/share/$PRGNAM
+sed -i "/^CUBE_DIR/s|=.*|=\"/usr/share/${PRGNAM}\"|" $PRGNAM.sh
+install -m 0755 $PRGNAM.sh $PKG/usr/games/$PRGNAM
+chmod 0755 bin_unix/*
+cp -ar \
+ bin_unix config bot demos mods packages screenshots \
+ $PKG/usr/share/$PRGNAM
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+convert icon.ico $PRGNAM.png
+install -m 0644 $PRGNAM-0.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ source/*.txt source/src/*.txt docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}