summaryrefslogtreecommitdiffstats
path: root/games/cgmadness
diff options
context:
space:
mode:
author Zbigniew Baniewski <zbigniew.baniewski@gmail.com>2012-12-19 19:58:49 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-19 19:59:09 +0100
commit7d6c2e473d3eea74b0d2d184f0b6596b2456f9ea (patch)
treed067c3794398a94192730664d422b53063c0c301 /games/cgmadness
parentf0a2380b1c22216f31a63031daa48b821878b396 (diff)
downloadslackbuilds-7d6c2e473d3eea74b0d2d184f0b6596b2456f9ea.tar.gz
slackbuilds-7d6c2e473d3eea74b0d2d184f0b6596b2456f9ea.tar.xz
games/cgmadness: Added (Marble Madness-like game).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/cgmadness')
-rw-r--r--games/cgmadness/01-Makefile.patch30
-rw-r--r--games/cgmadness/README5
-rw-r--r--games/cgmadness/cgmadness.SlackBuild82
-rw-r--r--games/cgmadness/cgmadness.desktop10
-rw-r--r--games/cgmadness/cgmadness.info10
-rw-r--r--games/cgmadness/cgmadness.pngbin0 -> 21623 bytes
-rw-r--r--games/cgmadness/doinst.sh9
-rw-r--r--games/cgmadness/slack-desc19
8 files changed, 165 insertions, 0 deletions
diff --git a/games/cgmadness/01-Makefile.patch b/games/cgmadness/01-Makefile.patch
new file mode 100644
index 0000000000..731f081481
--- /dev/null
+++ b/games/cgmadness/01-Makefile.patch
@@ -0,0 +1,30 @@
+diff -Nur cgmadness/Makefile cgmadness.new/Makefile
+--- cgmadness/Makefile 2011-09-09 19:55:46.000000000 +0200
++++ cgmadness.new/Makefile 2012-10-30 23:36:52.000000000 +0100
+@@ -18,7 +18,7 @@
+ CPREFIX :=
+
+ CC := $(CPREFIX)gcc
+-CFLAGS := -Wall -Werror
++CFLAGS := -Wall
+
+ CXX := $(CPREFIX)g++
+ CXXFLAGS = $(CFLAGS) -pedantic -I.
+@@ -53,7 +53,7 @@
+ LIBS_NETWORK += -lpthreadGCE2 -lwsock32 -lws2_32
+ EXECSUFFIX := .exe
+ endif
+-ifneq ($(findstring linux-gnu,$(MACHINE)),)
++ifneq ($(findstring slackware-linux,$(MACHINE)),)
+ CXXFLAGS += -ansi
+ LIBS_OPENGL += -lglut -lGLEW
+ LIBS_NETWORK += -lpthread
+@@ -115,7 +115,7 @@
+
+ %$(EXECSUFFIX): $(BUILD)/%.o
+ @echo " LINK $@"
+- @$(LD) $(LDFLAGS) $^ $(foreach find, $(FIND_LIBS), $(call $(find),$^)) -o $@
++ @$(LD) $(LDFLAGS) $^ $(foreach find, $(FIND_LIBS), $(call $(find),$^)) -o $@ -lGL -lGLU
+
+ $(BUILD)/%.o: %.c | $$(@D)/.
+ @echo " CC $@"
diff --git a/games/cgmadness/README b/games/cgmadness/README
new file mode 100644
index 0000000000..c6b10b67ae
--- /dev/null
+++ b/games/cgmadness/README
@@ -0,0 +1,5 @@
+CG Madness is based on the classic game Marble Madness.
+It is runs on OpenGL and uses current CG techniques like light maps,
+bump-mapping and reflection shader.
+It also has an editor where you can create your own levels. If you
+have done so and you want to share the level, you can upload it.
diff --git a/games/cgmadness/cgmadness.SlackBuild b/games/cgmadness/cgmadness.SlackBuild
new file mode 100644
index 0000000000..4a8022b0c4
--- /dev/null
+++ b/games/cgmadness/cgmadness.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for cgmadness
+
+# Written by Zbigniew Baniewski <zbigniew.baniewski@gmail.com.
+
+PRGNAM=cgmadness
+VERSION=1.3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM-$VERSION-src.tar.bz2
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cat $CWD/01-Makefile.patch | patch -p1 || exit 1
+
+make
+mkdir -p $PKG/usr/share/games/cgmadness/data $PKG/usr/share/games/cgmadness/levels \
+ $PKG/usr/bin $PKG/usr/share/pixmaps
+cp -a ballshadow.frag convert-cgm ballshadow.vert golfball.frag cgmadness \
+ dedicated_server golfball.vert $PKG/usr/share/games/cgmadness
+cp -a data/* $PKG/usr/share/games/cgmadness/data
+cp -a levels/* $PKG/usr/share/games/cgmadness/levels
+echo "cd /usr/share/games/cgmadness ; ./cgmadness" > $PKG/usr/bin/cgmadness
+chmod 0755 $PKG/usr/bin/cgmadness
+install -m 0644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/applications
+cat $CWD/cgmadness.desktop > $PKG/usr/share/applications/cgmadness.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a credits.txt known_bugs.txt license.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/cgmadness/cgmadness.desktop b/games/cgmadness/cgmadness.desktop
new file mode 100644
index 0000000000..7908d7ad99
--- /dev/null
+++ b/games/cgmadness/cgmadness.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=CG Madness
+GenericName=Marble Madness-like game
+Comment=Game based on the classic Marble Madness
+Exec=/usr/share/games/cgmadness/cgmadness
+Icon=/usr/share/pixmaps/cgmadness.png
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/games/cgmadness/cgmadness.info b/games/cgmadness/cgmadness.info
new file mode 100644
index 0000000000..34c6ab30c0
--- /dev/null
+++ b/games/cgmadness/cgmadness.info
@@ -0,0 +1,10 @@
+PRGNAM="cgmadness"
+VERSION="1.3"
+HOMEPAGE="http://www.fluxparticle.com/cgmadness/"
+DOWNLOAD="http://www.fluxparticle.com/cgmadness/downloads/cgmadness-1.3-src.tar.bz2"
+MD5SUM="6846b860921e6c8db34b0ee5349a1690"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Zbigniew Baniewski"
+EMAIL="zbigniew.baniewski@gmail.com"
diff --git a/games/cgmadness/cgmadness.png b/games/cgmadness/cgmadness.png
new file mode 100644
index 0000000000..12aef7000d
--- /dev/null
+++ b/games/cgmadness/cgmadness.png
Binary files differ
diff --git a/games/cgmadness/doinst.sh b/games/cgmadness/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/games/cgmadness/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/cgmadness/slack-desc b/games/cgmadness/slack-desc
new file mode 100644
index 0000000000..a26ef9443d
--- /dev/null
+++ b/games/cgmadness/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+cgmadness: CG Madness (Marble Madness-like game)
+cgmadness:
+cgmadness: Game based on the classic Marble Madness.
+cgmadness:
+cgmadness: http://www.fluxparticle.com/cgmadness/
+cgmadness:
+cgmadness:
+cgmadness:
+cgmadness:
+cgmadness:
+cgmadness: