summaryrefslogtreecommitdiffstats
path: root/games/homm3_shareware_data
diff options
context:
space:
mode:
author Petar Petrov <slackalaxy@gmail.com>2021-05-18 17:20:59 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-18 23:40:19 +0700
commita8c59c472e8a59521c2034ae1f13030e63288d1b (patch)
tree82ead13f74e4ea45480a5c1c0015f33900b010fd /games/homm3_shareware_data
parentd6d0309e9649d440ef1db2c9bc691ba933dec26c (diff)
downloadslackbuilds-a8c59c472e8a59521c2034ae1f13030e63288d1b.tar.gz
slackbuilds-a8c59c472e8a59521c2034ae1f13030e63288d1b.tar.xz
games/homm3_shareware_data: added. Heroes III demo data for VCMI.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/homm3_shareware_data')
-rw-r--r--games/homm3_shareware_data/README22
-rw-r--r--games/homm3_shareware_data/homm3_shareware_data.SlackBuild76
-rw-r--r--games/homm3_shareware_data/homm3_shareware_data.info10
-rw-r--r--games/homm3_shareware_data/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/games/homm3_shareware_data/README b/games/homm3_shareware_data/README
new file mode 100644
index 0000000000..4a778251e6
--- /dev/null
+++ b/games/homm3_shareware_data/README
@@ -0,0 +1,22 @@
+Heroes of Might and Magic III: The Restoration of Erathia Demo
+
+In Heroes III, you control the actions of heroes to complete mission
+objectives in a variety of conflicts taking place in the mythical land
+of Erathia. As heroes travel across the land with their armies, they can
+explore, seek artifacts, and find treasure, as well as lead their armies
+into battle. Towns can also have armies garrisoned for their defense and
+act as centers for recruitment, learning of magic spells and trading.
+Towns you conquer become part of your territory. You may develop your
+towns to provide yourself with offensive, defensive, and logistical
+advantages.
+
+This repackages the demo game data and makes it ready to use with the
+VCMI Heroes III engine that runs natively on Linux. The demo for Mac is
+used, since it is supposedly more complete than the one for Windows
+(which does not seem to work with VCMI). For more info, check this
+discussion:
+https://forum.vcmi.eu/t/support-for-demo-versions/1079/17
+
+The package installs the data system-wide and the game is playable and
+will give you an idea about how VCMI works, however there are graphics
+glitches and probably other problems. Consider buying the full game.
diff --git a/games/homm3_shareware_data/homm3_shareware_data.SlackBuild b/games/homm3_shareware_data/homm3_shareware_data.SlackBuild
new file mode 100644
index 0000000000..2507c4dae4
--- /dev/null
+++ b/games/homm3_shareware_data/homm3_shareware_data.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for homm3_shareware_data
+
+# Copyright 2021 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=homm3_shareware_data
+VERSION=${VERSION:-4.0} # This is the version stated in the ReadMe
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+DEMO=heroes_3_complete_demo.sit
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+
+# Steps are taken from the PKGBUILD at Arch linux AUR. Thanks K5HV!
+# https://aur.archlinux.org/packages/vcmi-demo/
+unar -f -t $CWD/$DEMO
+cd Heroes\ III\ Demo/
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p $PKG/usr/share/vcmi/
+cp -a data $PKG/usr/share/vcmi/Data
+cp -a maps $PKG/usr/share/vcmi/Maps
+cp -a music $PKG/usr/share/vcmi/Mp3
+
+# Remove these, as they are Mac-specific
+rm -rf $PKG/usr/share/Data/*.rsrc
+rm -rf $PKG/usr/share/Maps/*.rsrc
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Read\ Me $PKG/usr/doc/$PRGNAM-$VERSION/ReadMe.txt
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/homm3_shareware_data/homm3_shareware_data.info b/games/homm3_shareware_data/homm3_shareware_data.info
new file mode 100644
index 0000000000..4cbff19da2
--- /dev/null
+++ b/games/homm3_shareware_data/homm3_shareware_data.info
@@ -0,0 +1,10 @@
+PRGNAM="homm3_shareware_data"
+VERSION="4.0"
+HOMEPAGE="https://archive.org/details/heroes_3_complete_demo"
+DOWNLOAD="https://archive.org/download/heroes_3_complete_demo/heroes_3_complete_demo.sit"
+MD5SUM="49343f4fc8c5820c28f4bc8c39a2e149"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="vcmi unar"
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"
diff --git a/games/homm3_shareware_data/slack-desc b/games/homm3_shareware_data/slack-desc
new file mode 100644
index 0000000000..dc3df0ef23
--- /dev/null
+++ b/games/homm3_shareware_data/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+homm3_shareware_data: homm3_shareware_data (Heroes of Might and Magic III Demo)
+homm3_shareware_data:
+homm3_shareware_data: In Heroes III, you control the actions of heroes to complete
+homm3_shareware_data: mission objectives in a variety of conflicts taking place in the
+homm3_shareware_data: mythical land of Erathia.
+homm3_shareware_data:
+homm3_shareware_data: This is meant to be used with vcmi.
+homm3_shareware_data:
+homm3_shareware_data:
+homm3_shareware_data:
+homm3_shareware_data: