summaryrefslogtreecommitdiffstats
path: root/games/ivan
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-11 14:28:19 +0200
committer Erik Hanson <erik@slackbuilds.org>2010-05-11 14:28:19 +0200
commit637edc2a2438d9a1832759e225151790276601ea (patch)
tree1afd6369d135fa44038b2c1f0cf77c6a46f370c2 /games/ivan
parentdb40c228c77ed083d37f306efe4a8eefed91785a (diff)
downloadslackbuilds-637edc2a2438d9a1832759e225151790276601ea.tar.gz
slackbuilds-637edc2a2438d9a1832759e225151790276601ea.tar.xz
games/ivan: Initial import
Diffstat (limited to 'games/ivan')
-rw-r--r--games/ivan/Makefile.in-install.patch29
-rw-r--r--games/ivan/README4
-rw-r--r--games/ivan/doinst.sh5
-rw-r--r--games/ivan/ivan.SlackBuild76
-rw-r--r--games/ivan/ivan.desktop11
-rw-r--r--games/ivan/ivan.info8
-rw-r--r--games/ivan/ivan.pngbin0 -> 455 bytes
-rw-r--r--games/ivan/slack-desc8
8 files changed, 141 insertions, 0 deletions
diff --git a/games/ivan/Makefile.in-install.patch b/games/ivan/Makefile.in-install.patch
new file mode 100644
index 0000000000..c559e010af
--- /dev/null
+++ b/games/ivan/Makefile.in-install.patch
@@ -0,0 +1,29 @@
+--- Makefile.in 2004-12-10 15:34:29.000000000 -0600
++++ Makefile.in.Slack 2006-12-18 18:23:53.000000000 -0600
+@@ -338,16 +338,16 @@
+
+
+ install-data-local:
+- -./mkinstalldirs -p $(localstatedir) $(bindir) $(datadir)/ivan/Script/ $(datadir)/ivan/Graphics/ $(localstatedir)/ivan/Bones/
+- -touch $(localstatedir)/ivan/ivan-highscore.scores
+- -chown games.games $(localstatedir)/ivan/ivan-highscore.scores
+- -chmod 664 $(localstatedir)/ivan/ivan-highscore.scores
+- -chown -R games.games $(localstatedir)/ivan/Bones/
+- -chmod -R u=rwx $(localstatedir)/ivan/Bones/
+- -chmod -R g=rwx $(localstatedir)/ivan/Bones/
+- -chmod -R o=r $(localstatedir)/ivan/Bones/
+- -chgrp games $(bindir)/ivan
+- -chmod 2111 $(bindir)/ivan
++ -./mkinstalldirs -p $(DESTDIR)/$(localstatedir) $(DESTDIR)/$(bindir) $(DESTDIR)/$(datadir)/ivan/Script/ $(DESTDIR)/$(datadir)/ivan/Graphics/ $(DESTDIR)/$(localstatedir)/ivan/Bones/
++ -touch $(DESTDIR)/$(localstatedir)/ivan/ivan-highscore.scores
++ -chown root.games $(DESTDIR)/$(localstatedir)/ivan/ivan-highscore.scores
++ -chmod 664 $(DESTDIR)/$(localstatedir)/ivan/ivan-highscore.scores
++ -chown -R root.games $(DESTDIR)/$(localstatedir)/ivan/Bones/
++ -chmod -R u=rwx $(DESTDIR)/$(localstatedir)/ivan/Bones/
++ -chmod -R g=rwx $(DESTDIR)/$(localstatedir)/ivan/Bones/
++ -chmod -R o=r $(DESTDIR)/$(localstatedir)/ivan/Bones/
++# -chgrp games $(DESTDIR)/$(bindir)/ivan
++# -chmod 2111 $(DESTDIR)/$(bindir)/ivan
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/ivan/README b/games/ivan/README
new file mode 100644
index 0000000000..186d17b39e
--- /dev/null
+++ b/games/ivan/README
@@ -0,0 +1,4 @@
+Iter Vehemens ad Necem (IVAN) is a graphical roguelike game which currently runs in Windows, DOS, and Linux. It features advanced bodypart and material handling, multi-colored lighting and, above all, deep gameplay.
+
+Requires:
+>=sdl-1.2.0 \ No newline at end of file
diff --git a/games/ivan/doinst.sh b/games/ivan/doinst.sh
new file mode 100644
index 0000000000..22d4849bce
--- /dev/null
+++ b/games/ivan/doinst.sh
@@ -0,0 +1,5 @@
+
+if [ -x usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/games/ivan/ivan.SlackBuild b/games/ivan/ivan.SlackBuild
new file mode 100644
index 0000000000..b54012f970
--- /dev/null
+++ b/games/ivan/ivan.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+
+if [ "$(id -u)" != "0" ]; then
+ echo "This script must be run as root!"
+ exit
+fi
+
+NAME=ivan
+VERSION=0.50
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG $TMP/$NAME-$VERSION
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+tar zxvf $CWD/$NAME-$VERSION.tar.gz || exit 1
+cd $NAME-$VERSION || exit 1
+
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+# Fix Makefile.in so that it does mkdir, chown, and chmod within
+# DESTDIR like it is supposed to. Also fix own/perm settings on
+# /usr/games/ivan executable
+patch -p0 < $CWD/Makefile.in-install.patch || exit 1
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/games \
+ --datadir=/usr/share/games \
+ --libdir=/usr/lib/games \
+ --sysconfdir=/etc \
+ --localstatedir=/var/games \
+ || exit 1
+
+make || exit 1
+make install DESTDIR=$PKG || exit 1
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m 0644 $CWD/$NAME.desktop $PKG/usr/share/applications/$NAME.desktop
+install -m 0644 $CWD/$NAME.png $PKG/usr/share/pixmaps/
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+cp -a {AUTHORS,COPYING,ChangeLog,LICENSING,INSTALL} $PKG/usr/doc/$NAME-$VERSION
+chmod -x $PKG/usr/doc/$NAME-$VERSION/*
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/games/ivan/ivan.desktop b/games/ivan/ivan.desktop
new file mode 100644
index 0000000000..c4910cac74
--- /dev/null
+++ b/games/ivan/ivan.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=IVAN
+Comment=A graphical roguelike game.
+GenericName=Graphical Roguelike
+Exec=ivan
+Icon=/usr/share/pixmaps/ivan.png
+Terminal=false
+Type=Application
+X-KDE-StartupNotify=true
+Categories=Application;Game
diff --git a/games/ivan/ivan.info b/games/ivan/ivan.info
new file mode 100644
index 0000000000..490e1287b3
--- /dev/null
+++ b/games/ivan/ivan.info
@@ -0,0 +1,8 @@
+PRGNAM="ivan"
+VERSION="0.50"
+HOMEPAGE="http://ivan.sourceforge.net"
+DOWNLOAD="http://dl.sourceforge.net/sourceforge/ivan/ivan-0.50.tar.gz"
+MD5SUM="88de761ea3ed34a977cd412ff7d2a36e"
+MAINTAINER="hollywoodb"
+EMAIL="hollywoodb@fastmail.fm"
+APPROVED="elohim"
diff --git a/games/ivan/ivan.png b/games/ivan/ivan.png
new file mode 100644
index 0000000000..20f52715da
--- /dev/null
+++ b/games/ivan/ivan.png
Binary files differ
diff --git a/games/ivan/slack-desc b/games/ivan/slack-desc
new file mode 100644
index 0000000000..fa3005aef1
--- /dev/null
+++ b/games/ivan/slack-desc
@@ -0,0 +1,8 @@
+ |-----handy-ruler--------------------------------------------------------|
+ivan: ivan (a graphical roguelike game)
+ivan:
+ivan: Iter Vehemens ad Necem (IVAN) is a graphical roguelike game which
+ivan: currently runs in Windows, DOS, and Linux. It features advanced
+ivan: bodypart and material handling, multi-colored lighting and, above
+ivan: all, deep gameplay.
+ivan: