summaryrefslogtreecommitdiffstats
path: root/games/mars
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-04-26 13:27:57 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-04-27 12:18:17 -0500
commitbe57145eba4219b96afd73467eb97e7dc0aaabfa (patch)
treedc63c21aea30110b4b68ae3325add7a14b739f98 /games/mars
parent732c597f27ef3ab58ea85d7dbd375eb243234469 (diff)
downloadslackbuilds-be57145eba4219b96afd73467eb97e7dc0aaabfa.tar.gz
slackbuilds-be57145eba4219b96afd73467eb97e7dc0aaabfa.tar.xz
games/mars: Added (Space shooter game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/mars')
-rw-r--r--games/mars/README3
-rw-r--r--games/mars/doinst.sh9
-rw-r--r--games/mars/mars.SlackBuild99
-rw-r--r--games/mars/mars.info10
-rw-r--r--games/mars/mars.patch87
-rw-r--r--games/mars/slack-desc19
6 files changed, 227 insertions, 0 deletions
diff --git a/games/mars/README b/games/mars/README
new file mode 100644
index 0000000000..659f74bf0f
--- /dev/null
+++ b/games/mars/README
@@ -0,0 +1,3 @@
+This is a first attempt to create a game in OpenGL with SFML.
+It is a game for two players, flying with ships in a two-dimensional
+space setting, governed by the laws of gravity.
diff --git a/games/mars/doinst.sh b/games/mars/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/games/mars/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/mars/mars.SlackBuild b/games/mars/mars.SlackBuild
new file mode 100644
index 0000000000..43ca1cf4e0
--- /dev/null
+++ b/games/mars/mars.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/sh
+
+# Slackware build script for M.A.R.S.
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=mars_source
+PRGNAM=$(echo $SRCNAM | cut -c1-4)
+SRCDIR=$(echo $PRGNAM-game)
+VERSION=${VERSION:-0.7.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCDIR
+tar xvf $CWD/$SRCNAM\_$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $SRCDIR
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/mars.patch
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a credits.txt license.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/mars/mars.info b/games/mars/mars.info
new file mode 100644
index 0000000000..b56dee5e4d
--- /dev/null
+++ b/games/mars/mars.info
@@ -0,0 +1,10 @@
+PRGNAM="mars"
+VERSION="0.7.5"
+HOMEPAGE="http://mars-game.sourceforge.net"
+DOWNLOAD="https://github.com/downloads/thelaui/M.A.R.S./mars_source_0.7.5.tar.gz"
+MD5SUM="bbbc5fda27ce7f35a0660269c11e93d6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="SFML"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/games/mars/mars.patch b/games/mars/mars.patch
new file mode 100644
index 0000000000..9cbce2d32e
--- /dev/null
+++ b/games/mars/mars.patch
@@ -0,0 +1,87 @@
+--- mars-game/src/System/window.original.cpp 2014-04-25 21:17:55.251256504 +0300
++++ mars-game/src/System/window.cpp 2014-04-25 21:27:53.395778669 +0300
+@@ -33,11 +33,11 @@
+ # include <SFML/OpenGL.hpp>
+ # include <sstream>
+ # include <time.h>
+-# include <sys/stat.h>
+-
+-# ifdef __WIN32__
+- # include <windows.h>
+-# endif
++# include <sys/stat.h>
++
++# ifdef __WIN32__
++ # include <windows.h>
++# endif
+
+
+ namespace window {
+@@ -308,12 +308,12 @@
+ glEnable(GL_TEXTURE_2D);
+
+ if (shader)
+- shader->bind();
++ shader->bind(NULL);
+
+ window_.draw(toBeDrawn, states);
+
+ if (shader)
+- shader->unbind();
++ shader->bind(NULL);
+
+ window_.popGLStates();
+ glPopMatrix();
+@@ -361,7 +361,7 @@
+
+ std::stringstream filename;
+ filename << "ScreenShot_" << timeinfo->tm_year << timeinfo->tm_mon << timeinfo->tm_mday << timeinfo->tm_hour << timeinfo->tm_min << timeinfo->tm_sec << "." << settings::C_screenShotFormat;
+-
++
+ # ifdef __linux__
+ mkdir((settings::C_configPath + "screenshots/").c_str(), S_IRWXU | S_IRWXG | S_IROTH | S_IXOTH);
+ if (shot.saveToFile(settings::C_configPath + "screenshots/" + filename.str())) {
+@@ -369,7 +369,7 @@
+ hud::displayMessage(*locales::getLocale(locales::SavedScreenshot));
+ } else {
+ std::cout << "Failed saving screenshot to " << settings::C_configPath << "screenshots/" << filename.str() << "." << std::endl;
+- }
++ }
+ # endif
+
+ # ifdef __APPLE__
+@@ -379,17 +379,17 @@
+ hud::displayMessage(*locales::getLocale(locales::SavedScreenshot));
+ } else {
+ std::cout << "Failed saving screenshot to " << settings::C_configPath << "screenshots/" << filename.str() << "." << std::endl;
+- }
+- # endif
+-
+- # ifdef __WIN32__
+- CreateDirectory((settings::C_configPath + "screenshots/").c_str(), NULL);
++ }
++ # endif
++
++ # ifdef __WIN32__
++ CreateDirectory((settings::C_configPath + "screenshots/").c_str(), NULL);
+ if (shot.SaveToFile(settings::C_configPath + "screenshots/" + filename.str())) {
+ std::cout << "Saved screenshot to " << settings::C_configPath << "screenshots/" << filename.str() << "." << std::endl;
+ hud::displayMessage(*locales::getLocale(locales::SavedScreenshot));
+ } else {
+ std::cout << "Failed saving screenshot to " << settings::C_configPath << "screenshots/" << filename.str() << "." << std::endl;
+- }
++ }
+ # endif
+ }
+
+--- mars-game/src/CMakeLists.original.txt 2014-04-25 21:38:37.122730974 +0300
++++ mars-game/src/CMakeLists.txt 2014-04-25 21:41:51.413302008 +0300
+@@ -68,7 +68,7 @@
+ TARGETS
+ mars
+ RUNTIME DESTINATION
+- ${CMAKE_INSTALL_PREFIX}/games
++ ${CMAKE_INSTALL_PREFIX}/bin
+ )
+ install(
+ FILES
diff --git a/games/mars/slack-desc b/games/mars/slack-desc
new file mode 100644
index 0000000000..9eb5b28d8b
--- /dev/null
+++ b/games/mars/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mars: mars (Space shooter game)
+mars:
+mars: This is a first attempt to create a game in OpenGL with SFML.
+mars: It is a game for two players, flying with ships in a two-dimensional
+mars: space setting, governed by the laws of gravity.
+mars:
+mars: Homepage: http://mars-game.sourceforge.net
+mars:
+mars:
+mars:
+mars: