summaryrefslogtreecommitdiffstats
path: root/games/ppsspp
diff options
context:
space:
mode:
author Ruoh-Shoei LIN <56530472+LinRs@users.noreply.github.com>2023-01-27 10:31:04 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-28 08:22:52 +0700
commit6c8d24b1669d20da483c0324ecd1819004f3b86e (patch)
tree1f2249b08a0213c0cb74dbd90d43faa1c37a4db2 /games/ppsspp
parent6ef8f3a6196a0b5d2b6f344b01c0fde22c1b3508 (diff)
downloadslackbuilds-6c8d24b1669d20da483c0324ecd1819004f3b86e.tar.gz
slackbuilds-6c8d24b1669d20da483c0324ecd1819004f3b86e.tar.xz
games/ppsspp: Updated for version 1.14.4.
- use upstream release files - remove unused desktop files - always use system ffmpeg - default build with: sdl Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/ppsspp')
-rw-r--r--games/ppsspp/README7
-rw-r--r--games/ppsspp/ppsspp-qt.desktop9
-rw-r--r--games/ppsspp/ppsspp.SlackBuild97
-rw-r--r--games/ppsspp/ppsspp.desktop9
-rw-r--r--games/ppsspp/ppsspp.info18
-rw-r--r--games/ppsspp/slack-desc2
6 files changed, 36 insertions, 106 deletions
diff --git a/games/ppsspp/README b/games/ppsspp/README
index 43a7ef4cba..0585ea2864 100644
--- a/games/ppsspp/README
+++ b/games/ppsspp/README
@@ -12,8 +12,5 @@ keyboard
snappy is an optional dependency.
-QT=on will enable QT GUI and require qt5 installed (default is
-'QT=off').
-
-SYSTEM_FFMPEG=on: dynamically link against system FFMPEG (default is
-'SYSTEM_FFMPEG=off', using upstream's modified version).
+QT=ON will enable QT GUI and require qt5 installed (default is
+'QT=OFF').
diff --git a/games/ppsspp/ppsspp-qt.desktop b/games/ppsspp/ppsspp-qt.desktop
deleted file mode 100644
index 4bdd11d58a..0000000000
--- a/games/ppsspp/ppsspp-qt.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=PPSSPP (Qt)
-Exec=ppsspp-qt %f
-Icon=ppsspp
-Type=Application
-GenericName=PSP Emulator
-Comment=ppsspp (fast and portable PSP emulator)
-Categories=Game
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index 1c6126a2b1..cc9c91db7f 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for ppsspp
# Copyright 2016 Hunter Sezen California, USA
-# Copyright 2019-2022 Ruoh-Shoei LIN
+# Copyright 2019-2023 Ruoh-Shoei LIN
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ppsspp
-VERSION=${VERSION:-1.12.3}
+VERSION=${VERSION:-1.14.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,32 +71,9 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
-# The submodules are in a separate archive. This is equivalent to
-# git submodule update --init --recursive
-tar -xvf $CWD/zstd-a488ba1*.tar.gz \
- -C ext/zstd --strip-components=1
-tar -xvf $CWD/miniupnp-3a87be3*.tar.gz \
- -C ext/miniupnp --strip-components=1
-tar -xvf $CWD/glslang-dc11add*.tar.gz \
- -C ext/glslang --strip-components=1
-tar -xvf $CWD/SPIRV-Cross-9acb9ec*.tar.gz \
- -C ext/SPIRV-Cross --strip-components=1
-tar -xvf $CWD/armips-7885552*.tar.gz \
- -C ext/armips --strip-components=1
-
-SYSTEM_FFMPEG=${SYSTEM_FFMPEG:-off}
-if [ "$SYSTEM_FFMPEG" = "off" ]; then
- tar -xvf $CWD/ppsspp-ffmpeg-a5baf97*.tar.gz \
- --exclude '*/Windows*' --exclude '*/android' \
- --exclude '*/ios' --exclude '*/blackberry'\
- --exclude '*/macosx' --exclude '*/wiiu' \
- --exclude '*/symbian' \
- -C ffmpeg --strip-components=1
-fi
-
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -110,58 +87,44 @@ sed -i -e '/include(ccache)/d' CMakeLists.txt
# set git-version
sed -i "s/unknown/${VERSION}/" git-version.cmake
-mkdir -p build-qt build-sdl
+QT=${QT:-OFF}
+
+if [ "${QT,,}" = ON ]; then
+ cmake -B build-qt \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=TRUE \
+ -DUSING_QT_UI=ON \
+ -DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_FFMPEG=ON \
+ -DUSE_DISCORD=OFF \
+ -DUSE_SYSTEM_ZSTD=ON \
+ -DCMAKE_BUILD_TYPE=Release
+ make -C build-qt
+ install -Dm755 build-qt/PPSSPPQt -t $PKG/usr/bin/
+ install -Dm644 build-qt/ppsspp.desktop $PKG/usr/share/applications/PPSSPPQt.desktop
+fi
-QT=${QT:-off}
-if [ "$QT" = "on" ]; then
- cd build-qt
- cmake \
+cmake -B build-sdl \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_SKIP_RPATH=TRUE \
- -Wno-dev \
- -DUSING_QT_UI=ON \
+ -DUSING_QT_UI=OFF \
-DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_SYSTEM_FFMPEG=$SYSTEM_FFMPEG \
+ -DUSE_SYSTEM_FFMPEG=ON \
-DUSE_DISCORD=OFF \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- cd ..
- install -Dm755 build-qt/PPSSPPQt $PKG/usr/games/ppsspp-qt
- install -Dm644 $CWD/ppsspp-qt.desktop $PKG/usr/share/applications/ppsspp-qt.desktop
-fi
-
-cd build-sdl
-cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_SKIP_RPATH=TRUE \
- -Wno-dev \
- -DUSING_QT_UI=OFF \
- -DHEADLESS='ON' \
- -DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_SYSTEM_FFMPEG=$SYSTEM_FFMPEG \
- -DUSE_DISCORD=OFF \
- -DCMAKE_BUILD_TYPE=Release ..
-make
-cd ..
-install -Dm755 build-sdl/PPSSPPHeadless $PKG/usr/games/ppsspp-headless
-install -Dm755 build-sdl/PPSSPPSDL $PKG/usr/games/ppsspp-sdl
-
-mkdir -p $PKG/usr/{games,share/{applications,icons/hicolor,pixmaps,ppsspp}}
-install -Dm644 $CWD/ppsspp.desktop $PKG/usr/share/applications/ppsspp.desktop
-cp -r assets $PKG/usr/share/ppsspp
-cp -r icons/hicolor/* $PKG/usr/share/icons/hicolor
-cp icons/icon-512.svg $PKG/usr/share/pixmaps/ppsspp.svg
+ -DUSE_SYSTEM_ZSTD=ON \
+ -DCMAKE_BUILD_TYPE=Release
+make -C build-sdl
+make install DESTDIR=$PKG -C build-sdl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.TXT README.md history.md headless/headless.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+install -Dm644 LICENSE.TXT README.md history.md \
+ -t $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/ppsspp/ppsspp.desktop b/games/ppsspp/ppsspp.desktop
deleted file mode 100644
index 63e50e308a..0000000000
--- a/games/ppsspp/ppsspp.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=PPSSPP (SDL)
-Exec=ppsspp-sdl %f
-Icon=ppsspp
-Type=Application
-GenericName=PSP Emulator
-Comment=ppsspp (fast and portable PSP emulator)
-Categories=Game
diff --git a/games/ppsspp/ppsspp.info b/games/ppsspp/ppsspp.info
index aa1420496d..148282f574 100644
--- a/games/ppsspp/ppsspp.info
+++ b/games/ppsspp/ppsspp.info
@@ -1,20 +1,8 @@
PRGNAM="ppsspp"
-VERSION="1.12.3"
+VERSION="1.14.4"
HOMEPAGE="https://www.ppsspp.org/"
-DOWNLOAD="https://github.com/hrydgard/ppsspp/archive/v1.12.3/ppsspp-1.12.3.tar.gz \
- https://github.com/hrydgard/glslang/archive/dc11adde23c455a24e13dd54de9b4ede8bdd7db8/glslang-dc11adde23c455a24e13dd54de9b4ede8bdd7db8.tar.gz \
- https://github.com/KhronosGroup/SPIRV-Cross/archive/9acb9ec31f5a8ef80ea6b994bb77be787b08d3d1/SPIRV-Cross-9acb9ec31f5a8ef80ea6b994bb77be787b08d3d1.tar.gz \
- https://github.com/Kingcom/armips/archive/7885552b208493a6a0f21663770c446c3ba65576/armips-7885552b208493a6a0f21663770c446c3ba65576.tar.gz \
- https://github.com/hrydgard/miniupnp/archive/3a87be33e797ba947b2b2a5f8d087f6c3ff4d93e/miniupnp-3a87be33e797ba947b2b2a5f8d087f6c3ff4d93e.tar.gz \
- https://github.com/facebook/zstd/archive/a488ba114ec17ea1054b9057c26a046fc122b3b6/zstd-a488ba114ec17ea1054b9057c26a046fc122b3b6.tar.gz \
- https://github.com/hrydgard/ppsspp-ffmpeg/archive/a5baf97df4579b4614cd5e643241c7acfc36b0c4/ppsspp-ffmpeg-a5baf97df4579b4614cd5e643241c7acfc36b0c4.tar.gz"
-MD5SUM="1884395ddfd53cdfef869b454643774b \
- 939584490f40840c06301849a445e505 \
- 1338c24baf927d9ed170759370a0462c \
- 4731977e287eee39ddcc247d75095758 \
- 1b54e744eeeb42c444f4c07ff2cda6af \
- d6a2ae6d5172aa8a64cd6898af9b476e \
- b8c1813e193922663a58e751c1020fb4"
+DOWNLOAD="https://github.com/hrydgard/ppsspp/releases/download/v1.14.4/ppsspp-1.14.4.tar.xz"
+MD5SUM="ea4fa6919f27ad0b3495b460aaf51449"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/games/ppsspp/slack-desc b/games/ppsspp/slack-desc
index bdac1aa87e..00ea7e49a8 100644
--- a/games/ppsspp/slack-desc
+++ b/games/ppsspp/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-ppsspp: ppsspp (a fast and portable PSP emulator)
+ppsspp: ppsspp (fast and portable PSP emulator)
ppsspp:
ppsspp: PPSSPP can run your PSP games on your PC in full HD resolution. It
ppsspp: can even upscale textures that would otherwise be too blurry as they