summaryrefslogtreecommitdiffstats
path: root/games/ppsspp
diff options
context:
space:
mode:
author Hunter Sezen <ovariegata@yahoo.com>2016-10-26 08:12:42 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-27 05:56:36 +0700
commite4b487bbc63e69cbad44d36dc180ecf6f8fa3fac (patch)
tree9cd8247ab9111c7475835a5dd0186ceb9298ca2e /games/ppsspp
parentce043991acd6eff9897fd620463ff7ea578795e0 (diff)
downloadslackbuilds-e4b487bbc63e69cbad44d36dc180ecf6f8fa3fac.tar.gz
slackbuilds-e4b487bbc63e69cbad44d36dc180ecf6f8fa3fac.tar.xz
games/ppsspp: Updated for version 2016.10.26_cc37528.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/ppsspp')
-rw-r--r--games/ppsspp/README8
-rw-r--r--games/ppsspp/ppsspp-no-ccache.patch24
-rw-r--r--games/ppsspp/ppsspp.SlackBuild22
-rw-r--r--games/ppsspp/ppsspp.info6
-rw-r--r--games/ppsspp/slack-desc2
5 files changed, 21 insertions, 41 deletions
diff --git a/games/ppsspp/README b/games/ppsspp/README
index 74e54ca58e..fc6375ff71 100644
--- a/games/ppsspp/README
+++ b/games/ppsspp/README
@@ -1,11 +1,9 @@
-PPSSPP can run your PSP games on your PC in full HD resolution. It can
-even upscale textures that would otherwise be too blurry as they were
-made for the small screen of the original PSP.
+PPSSPP can run your PSP games on your PC in full HD resolution. It can even upscale textures that
+would otherwise be too blurry as they were made for the small screen of the original PSP.
* Play in HD resolutions and more
* Play on a tablet for big-screen mobile gaming
-* Customize on-screen touch controls or use an external controller or
- keyboard
+* Customize on-screen touch controls or use an external controller or keyboard
* Save and restore game state anywhere, anytime
* Crank up the anisotropic filtering and texture scaling
* Continue where you left off by transferring saves from your real PSP
diff --git a/games/ppsspp/ppsspp-no-ccache.patch b/games/ppsspp/ppsspp-no-ccache.patch
deleted file mode 100644
index d8884925e4..0000000000
--- a/games/ppsspp/ppsspp-no-ccache.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -u -r ppsspp-2016.07.25_fa3f219-orig/CMakeLists.txt ppsspp-2016.07.25_fa3f219/CMakeLists.txt
---- ppsspp-2016.07.25_fa3f219-orig/CMakeLists.txt 2016-08-02 05:10:55.000000000 +0100
-+++ ppsspp-2016.07.25_fa3f219/CMakeLists.txt 2016-08-02 21:56:56.983679009 +0100
-@@ -33,20 +33,6 @@
- endif()
- endif()
-
--# Using ccache greatly improves the speed of our CI builds, let's enable for all.
--# Without this, our CI can't use ccache for clang, for some reason.
--find_program(CCACHE_FOUND ccache)
--if(CCACHE_FOUND)
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
--
-- # ccache uses -I when compiling without preprocessor, which makes clang complain.
-- if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
-- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Qunused-arguments -fcolor-diagnostics")
-- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Qunused-arguments -fcolor-diagnostics")
-- endif()
--endif(CCACHE_FOUND)
--
- # Remove soon?
- set(USE_FFMPEG ON)
-
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index d637dbcef6..3a4765e2dc 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ppsspp
+VERSION=${VERSION:-2016.10.26_cc37528}
SRCNAM=$(echo $PRGNAM | tr [a-z] [A-Z])
-VERSION=${VERSION:-2016.07.25_fa3f219}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,8 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Upstream apparently utterly clueless about how to invoke ccache
-patch -p1 < $CWD/ppsspp-no-ccache.patch
+# cmake 3.6 is required.
+# https://github.com/hrydgard/ppsspp/issues/9087
+sed -i 's/VERSION 3.6/VERSION 3.5.2/' CMakeLists.txt
mkdir -p build
cd build
@@ -79,24 +80,29 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_SKIP_RPATH=TRUE \
- -DUSE_SYSTEM_FFMPEG=ON \
-Wno-dev \
-DCMAKE_BUILD_TYPE=Release ..
make
# No install target
- mkdir -p $PKG/usr/share/{applications,icons/hicolor,$PRGNAM}
install -Dm0755 ${SRCNAM}SDL $PKG/usr/games/$PRGNAM
- install -Dm0644 ../assets/unix-icons/icon-512.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
+ mkdir -p $PKG/usr/share/$PRGNAM
cp -a assets $PKG/usr/share/$PRGNAM
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-cp -a assets/unix-icons/hicolor/* $PKG/usr/share/icons/hicolor/
+# Install hicolor
+for dir in icons/hicolor/* ; do
+ if [ -f $dir/apps/$PRGNAM.png ]; then
+ install -Dm0644 $dir/apps/$PRGNAM.png $PKG/usr/share/$dir/apps/$PRGNAM.png
+ fi
+done
+install -Dm0644 icons/icon-512.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
# Write a desktop file
+mkdir -p $PKG/usr/share/applications
cat > $PKG/usr/share/applications/$PRGNAM.desktop <<EOF
[Desktop Entry]
Name=$SRCNAM
@@ -116,4 +122,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/ppsspp/ppsspp.info b/games/ppsspp/ppsspp.info
index 8b53502dce..5abe7da123 100644
--- a/games/ppsspp/ppsspp.info
+++ b/games/ppsspp/ppsspp.info
@@ -1,8 +1,8 @@
PRGNAM="ppsspp"
-VERSION="2016.07.25_fa3f219"
+VERSION="2016.10.26_cc37528"
HOMEPAGE="http://www.ppsspp.org/"
-DOWNLOAD="http://ks392457.kimsufi.com/orbea/stuff/slackbuilds/src/ppsspp-2016.07.25_fa3f219.tar.xz"
-MD5SUM="d17140afc3ec3e60cae000263332ef5d"
+DOWNLOAD="http://ks392457.kimsufi.com/orbea/stuff/slackbuilds/src/ppsspp-2016.10.26_cc37528.tar.xz"
+MD5SUM="be5bcbe0d2513b1503abcc6ce577212d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="SDL2"
diff --git a/games/ppsspp/slack-desc b/games/ppsspp/slack-desc
index 00ea7e49a8..bdac1aa87e 100644
--- a/games/ppsspp/slack-desc
+++ b/games/ppsspp/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-ppsspp: ppsspp (fast and portable PSP emulator)
+ppsspp: ppsspp (a fast and portable PSP emulator)
ppsspp:
ppsspp: PPSSPP can run your PSP games on your PC in full HD resolution. It
ppsspp: can even upscale textures that would otherwise be too blurry as they