summaryrefslogtreecommitdiffstats
path: root/games/tuxnes/patches
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2010-05-12 17:39:38 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 17:39:38 +0200
commitf01fa50fe20f634dcd4165ac3b4023d34c3be3d1 (patch)
tree47dd3c27a06f2865a3c5724cc80267ba51f67ca0 /games/tuxnes/patches
parent83e64ec7fd5c06b56f3af5a0d855576105d21a89 (diff)
downloadslackbuilds-f01fa50fe20f634dcd4165ac3b4023d34c3be3d1.tar.gz
slackbuilds-f01fa50fe20f634dcd4165ac3b4023d34c3be3d1.tar.xz
games/tuxnes: Updated for version 0.75
Diffstat (limited to 'games/tuxnes/patches')
-rw-r--r--games/tuxnes/patches/Makefile.patch11
-rw-r--r--games/tuxnes/patches/configure.in.patch56
-rw-r--r--games/tuxnes/patches/emu.c.patch38
3 files changed, 105 insertions, 0 deletions
diff --git a/games/tuxnes/patches/Makefile.patch b/games/tuxnes/patches/Makefile.patch
new file mode 100644
index 0000000000..041bb27927
--- /dev/null
+++ b/games/tuxnes/patches/Makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile~ 2007-06-30 09:16:58.000000000 -0500
++++ Makefile 2007-06-30 09:18:26.000000000 -0500
+@@ -3,7 +3,7 @@
+ panels.o debug.o config.o `gtk-config --cflags --libs`
+
+ %.o: %.c gtuxnes.h
+- gcc `gtk-config --cflags` -c $*.c -o $@
++ gcc $(CFLAGS) `gtk-config --cflags` -c $*.c -o $@
+
+ clean:
+ rm -f *.o
diff --git a/games/tuxnes/patches/configure.in.patch b/games/tuxnes/patches/configure.in.patch
new file mode 100644
index 0000000000..38a91de2cb
--- /dev/null
+++ b/games/tuxnes/patches/configure.in.patch
@@ -0,0 +1,56 @@
+--- configure.in~ 2007-06-30 08:03:35.000000000 -0500
++++ configure.in 2007-06-30 08:21:46.000000000 -0500
+@@ -8,15 +8,16 @@
+ ##
+
+ dnl --------------------------------------------------------------------
+-dnl Made the prerequisite autoconf 2.13, lower it to each version we
++dnl Made the prerequisite autoconf 2.60, lower it to each version we
+ dnl find to work correctly with this script
+ dnl --------------------------------------------------------------------
+-AC_PREREQ(2.13)
++AC_PREREQ(2.60)
+
+ dnl --------------------------------------------------------------------
+ dnl Process this file with autoconf to produce a configure script
+ dnl --------------------------------------------------------------------
+-AC_INIT(consts.h)
++AC_INIT
++AC_CONFIG_SRCDIR([consts.h])
+ AM_INIT_AUTOMAKE(tuxnes,0.75)
+ #AM_INIT_AUTOMAKE(tuxnes,devel)
+
+@@ -28,16 +29,10 @@
+ AC_CANONICAL_HOST
+
+ dnl --------------------------------------------------------------------
+-dnl Don't assume we want high level optimisations, it is known to
+-dnl produce broken code on certain architectures using certain compilers
+-dnl --------------------------------------------------------------------
+-CFLAGS="-O"
+-AC_SUBST(CFLAGS)
+-
+-dnl --------------------------------------------------------------------
+ dnl Check for programs which we might need
+ dnl --------------------------------------------------------------------
+ AC_PROG_CC
++AM_PROG_AS
+ AC_PROG_INSTALL
+
+ dnl --------------------------------------------------------------------
+@@ -175,7 +170,7 @@
+ *-freebsd*)
+ OLDFLAGS="$LDFLAGS"
+ LDFLAGS="-L/usr/local/lib"
+- AC_CHECK_LIB(gnugetopt, getopt, [AC_DEFINE(HAVE_LIBGNUGETOPT) GNUGETOPT_LIB="-lgnugetopt"])
++ AC_CHECK_LIB(gnugetopt, getopt, [AC_DEFINE([HAVE_LIBGNUGETOPT], 1, [Define to 1 if you have the `gnugetopt' library (-lgnugetopt).]) GNUGETOPT_LIB="-lgnugetopt"])
+ if test -n "$GNUGETOPT_LIB"; then
+ LDFLAGS="$OLDFLAGS -L/usr/local/lib -lgnugetopt"
+ AC_SUBST(LDFLAGS)
+@@ -209,4 +204,5 @@
+ AC_TYPE_SIGNAL
+ AC_CHECK_FUNCS(gettimeofday strtod strtoul)
+
+-AC_OUTPUT(Makefile)
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/games/tuxnes/patches/emu.c.patch b/games/tuxnes/patches/emu.c.patch
new file mode 100644
index 0000000000..0b33a7190c
--- /dev/null
+++ b/games/tuxnes/patches/emu.c.patch
@@ -0,0 +1,38 @@
+--- emu.c~ 2007-06-30 02:02:34.000000000 -0500
++++ emu.c 2007-06-30 02:04:48.000000000 -0500
+@@ -890,7 +890,7 @@
+ len = strlen(palfile) + 1;
+ if (! (buffer = malloc(len)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("loadpal: malloc");
+ return;
+ }
+ memcpy (buffer, palfile, len);
+@@ -912,7 +912,7 @@
+ len = strlen(filename) + 1;
+ if (! (buffer = malloc(len)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("loadpal: malloc");
+ return;
+ }
+ memcpy (buffer, filename, len);
+@@ -924,7 +924,7 @@
+ return;
+ if (!(palfile = malloc ((len = strlen (filename)) + 11)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("loadpal: malloc");
+ return;
+ }
+ strcpy (palfile, filename);
+@@ -1602,7 +1602,7 @@
+
+ if (! (basefilename = malloc(baseend - basestart + 1)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("main: malloc");
+ exit (1);
+ }
+