summaryrefslogtreecommitdiffstats
path: root/games/vbam/vbam.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2017-01-26 15:47:43 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-04 07:00:04 +0700
commit31ffcff300758edcc3486d0432be760bb8978e70 (patch)
tree95f2935a2469a9b69d7719b4e1ea804b72e2f2e9 /games/vbam/vbam.SlackBuild
parent1b452b611e92199d0db099be5bdb03aab009e8d7 (diff)
downloadslackbuilds-31ffcff300758edcc3486d0432be760bb8978e70.tar.gz
slackbuilds-31ffcff300758edcc3486d0432be760bb8978e70.tar.xz
games/vbam: Updated for version 2.0.0beta3.
Diffstat (limited to 'games/vbam/vbam.SlackBuild')
-rw-r--r--games/vbam/vbam.SlackBuild54
1 files changed, 43 insertions, 11 deletions
diff --git a/games/vbam/vbam.SlackBuild b/games/vbam/vbam.SlackBuild
index dc91a31b42..a03e5154c6 100644
--- a/games/vbam/vbam.SlackBuild
+++ b/games/vbam/vbam.SlackBuild
@@ -1,9 +1,11 @@
#!/bin/sh
# Slackbuild for vbam
-# Currently maintained by Dugan Chen <thedoogster@gmail.com>
+# Currently maintained by B. Watson <yalhcru@gmail.com>
-# Written by JK Wood <joshuakwood@gmail.com>
+# Previously maintained by Dugan Chen <email removed>
+
+# Written by JK Wood <email removed>
# Slackbuild is released under the Dog-on-Fire License:
# If use of this script causes your dog to catch on fire,
@@ -21,11 +23,29 @@
# Modified by the SlackBuilds.org project.
+# 20170126 bkw:
+# - New maintainer, remove old maintainers' email addresses.
+# - Update for 2.0.0beta3. This adds SDL2 and SFML as deps.
+# Actually I could make SFML optional, it's only used for emulating
+# the GBA link cable. If anyone *really* wants to do this, add
+# -DENABLE_LINK=OFF to the cmake command. Not going to add it as
+# an option unless someone requests it.
+# - Install binary in /usr/games, not /usr/bin.
+# - Use correct wx-config, even if /usr/bin/wx-config symlink points
+# to 2.8 instead of 3.0.
+# - Get rid of Windows-only doc.
+# - Binary & source name has changed to visualboyadvance-m, keep the
+# old vbam name as symlinks.
+# - Correct README, plus cosmetic reformatting.
+
PRGNAM=vbam
-VERSION=${VERSION:-r1507}
+VERSION=${VERSION:-2.0.0beta3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCVER="Beta-3"
+SRCNAM="visualboyadvance-m"
+
# Set to ON to enable FFMPEG A/V recording.
FFMPEG=${FFMPEG:-OFF}
@@ -65,9 +85,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz || tar xvf $CWD/$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -75,9 +95,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# if both wx(Python|GTK) 2 and 3 are installed, /usr/bin/wx-config
+# is a symlink to the config for whichever was installed last. Avoid
+# confusion, force the correct version.
+WXCONF=${WXCONF:-/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0}
+
+# install binary to /usr/games, since it's got a section 6 man page.
+sed -i '/DESTINATION bin/s,bin,games,' CMakeLists.txt
+
+# man pages go in Slack standard location.
+sed -i 's,share/man,man,g' CMakeLists.txt
+
mkdir -p build
cd build
cmake \
+ -DwxWidgets_CONFIG_EXECUTABLE=$WXCONF \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -89,14 +121,14 @@ cd build
make install DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+strip $PKG/usr/games/$SRCNAM
+ln -s $SRCNAM $PKG/usr/games/$PRGNAM
-mv $PKG/usr/share/man $PKG/usr/man
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip $PKG/usr/man/man6/$SRCNAM.6
+ln -s $SRCNAM.6.gz $PKG/usr/man/man6/$PRGNAM.6.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+rm -f doc/ReadMe.MFC.txt # this is for Windows only
cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild