summaryrefslogtreecommitdiffstats
path: root/games/vegastrike/patches/patch-0.5.1.r1_2
diff options
context:
space:
mode:
author CRTS <crts [at] gmx [dot] net>2021-01-24 19:34:40 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-04-18 00:04:03 -0500
commita569ecc1f95142fae653b2c75079d87a9c1f32b3 (patch)
tree14858a60c74981df276749edd313ea1f4e05b941 /games/vegastrike/patches/patch-0.5.1.r1_2
parentad1208115f0dc3c27bfaec00de1f3db7dd7550b2 (diff)
downloadslackbuilds-a569ecc1f95142fae653b2c75079d87a9c1f32b3.tar.gz
slackbuilds-a569ecc1f95142fae653b2c75079d87a9c1f32b3.tar.xz
games/vegastrike: Adjustments for -current.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/vegastrike/patches/patch-0.5.1.r1_2')
-rw-r--r--games/vegastrike/patches/patch-0.5.1.r1_2216
1 files changed, 180 insertions, 36 deletions
diff --git a/games/vegastrike/patches/patch-0.5.1.r1_2 b/games/vegastrike/patches/patch-0.5.1.r1_2
index 7780674c0c..8f6d622177 100644
--- a/games/vegastrike/patches/patch-0.5.1.r1_2
+++ b/games/vegastrike/patches/patch-0.5.1.r1_2
@@ -1,6 +1,6 @@
-diff -ruN ./CMakeLists.txt ../c/CMakeLists.txt
+diff -ruN ./CMakeLists.txt ../b/CMakeLists.txt
--- ./CMakeLists.txt 2012-03-26 02:50:49.000000000 +0200
-+++ ../c/CMakeLists.txt 2020-09-03 16:25:55.870086658 +0200
++++ ../b/CMakeLists.txt 2020-09-02 22:37:20.707393347 +0200
@@ -10,7 +10,7 @@
project (vsUTCS)
@@ -10,7 +10,56 @@ diff -ruN ./CMakeLists.txt ../c/CMakeLists.txt
include_directories(${vsUTCS_SOURCE_DIR}/src
${vsUTCS_SOURCE_DIR}/src/cmd
-@@ -828,33 +828,33 @@
+@@ -685,14 +685,42 @@
+ SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${vsUTCS_SOURCE_DIR})
+
+
+-find_package(PythonLibs REQUIRED)
+-IF(PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
+- SET(TST_INCLUDES ${PYTHON_INCLUDE_PATH})
++#find_package(PythonLibs REQUIRED)
++#IF(PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
++# SET(TST_INCLUDES ${PYTHON_INCLUDE_PATH})
++# SET(TST_LIBS ${PYTHON_LIBRARIES})
++# SET(HAVE_PYTHON 1)
++#ELSE(PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
++# message(FATAL_ERROR "Can't find python")
++#ENDIF(PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
++
++# Python 3 has a SASL compatibility issue which causes an error
++# on some installations that prefer Python 3
++# -- Python 2.7 is default for now
++OPTION(USE_PYTHON_3 "Use Python 3 instead of Python 2.7 (default is 2.7)" OFF)
++IF (USE_PYTHON_3)
++ # We want at least Python 3.4, but we prefer newer versions
++ SET(Python_ADDITIONAL_VERSIONS 3.8 3.7 3.6 3.5 3.4)
++ELSE (USE_PYTHON_3)
++ SET(Python_ADDITIONAL_VERSIONS 2.7)
++ENDIF (USE_PYTHON_3)
++# If we don't unset cache variables
++# ccmake won't pick up changes to the USE_PYTHON_3 option
++UNSET(PYTHON_INCLUDE_DIR CACHE)
++UNSET(PYTHON_LIBRARY CACHE)
++# The python version we want is set via Python_ADDITIONAL_VERSIONS
++MESSAGE("++ Python release(s) searched for : ${Python_ADDITIONAL_VERSIONS}")
++FIND_PACKAGE(PythonLibs REQUIRED)
++MESSAGE("++ Python library : ${PYTHON_LIBRARY} (${PYTHONLIBS_VERSION_STRING})")
++MESSAGE("++ Python include dir : ${PYTHON_INCLUDE_DIR}")
++IF (PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_DIRS)
++ SET(TST_INCLUDES ${PYTHON_INCLUDE_DIRS})
+ SET(TST_LIBS ${PYTHON_LIBRARIES})
+ SET(HAVE_PYTHON 1)
+-ELSE(PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
+- message(FATAL_ERROR "Can't find python")
+-ENDIF(PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_PATH)
++ELSE (PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_DIRS)
++ MESSAGE(FATAL_ERROR "Can't find python")
++ENDIF (PYTHONLIBS_FOUND OR PYTHON_LIBRARIES AND PYTHON_INCLUDE_DIRS)
++
+
+ # Find Boost with boost_python library
+ OPTION(USE_SYSTEM_BOOST "Use system boost" OFF)
+@@ -828,33 +856,33 @@
#Find FFMpeg
@@ -68,7 +117,7 @@ diff -ruN ./CMakeLists.txt ../c/CMakeLists.txt
IF(NOT BEOS)
FIND_LIBRARY(UTIL_LIB util)
-@@ -977,12 +977,12 @@
+@@ -977,12 +1005,12 @@
HAVE_AVFORMAT_H
HAVE_AVCODEC_H
HAVE_AVIO_H
@@ -86,9 +135,9 @@ diff -ruN ./CMakeLists.txt ../c/CMakeLists.txt
GTK2_ATK_INCLUDE_DIR
GTK2_ATK_LIBRARY
GTK2_CAIRO_INCLUDE_DIR
-diff -ruN ./objconv/basemaker/base_maker_texture.cpp ../c/objconv/basemaker/base_maker_texture.cpp
+diff -ruN ./objconv/basemaker/base_maker_texture.cpp ../b/objconv/basemaker/base_maker_texture.cpp
--- ./objconv/basemaker/base_maker_texture.cpp 2010-03-10 03:56:23.000000000 +0100
-+++ ../c/objconv/basemaker/base_maker_texture.cpp 2020-09-03 16:25:55.871086646 +0200
++++ ../b/objconv/basemaker/base_maker_texture.cpp 2020-09-02 15:08:07.760351554 +0200
@@ -6,9 +6,12 @@
#define XMD_H
#define HAVE_BOOLEAN
@@ -102,9 +151,9 @@ diff -ruN ./objconv/basemaker/base_maker_texture.cpp ../c/objconv/basemaker/base
}
#define strip_16 true
-diff -ruN ./objconv/mesher/to_OgreMesh.cpp ../c/objconv/mesher/to_OgreMesh.cpp
+diff -ruN ./objconv/mesher/to_OgreMesh.cpp ../b/objconv/mesher/to_OgreMesh.cpp
--- ./objconv/mesher/to_OgreMesh.cpp 2011-06-02 01:47:36.000000000 +0200
-+++ ../c/objconv/mesher/to_OgreMesh.cpp 2020-09-03 16:25:55.872086633 +0200
++++ ../b/objconv/mesher/to_OgreMesh.cpp 2020-09-02 15:08:07.762351529 +0200
@@ -1078,10 +1078,15 @@
Ogre::VertexDeclaration *newDcl =
data->vertexDeclaration->getAutoOrganisedDeclaration(
@@ -187,9 +236,9 @@ diff -ruN ./objconv/mesher/to_OgreMesh.cpp ../c/objconv/mesher/to_OgreMesh.cpp
void DoneMeshes( void *outputcontext )
{
-diff -ruN ./objconv/mesher/to_OgreMesh.h ../c/objconv/mesher/to_OgreMesh.h
+diff -ruN ./objconv/mesher/to_OgreMesh.h ../b/objconv/mesher/to_OgreMesh.h
--- ./objconv/mesher/to_OgreMesh.h 2010-02-25 16:22:25.000000000 +0100
-+++ ../c/objconv/mesher/to_OgreMesh.h 2020-09-03 16:25:55.873086621 +0200
++++ ../b/objconv/mesher/to_OgreMesh.h 2020-09-02 15:08:07.763351517 +0200
@@ -20,7 +20,7 @@
float RadialSize( void *outputcontext ); //returns the size of the resulting mesh (it's maximum distance from 0,0,0). Useful for LODding.
@@ -199,9 +248,9 @@ diff -ruN ./objconv/mesher/to_OgreMesh.h ../c/objconv/mesher/to_OgreMesh.h
void AutoEdgeList( void *outputcontext ); //a good idea - prepares the mesh for stencil shadows
void AutoTangents( void *outputcontext ); //prepares the mesh for normal mapping (only needed if the material uses normal mapping)
}
-diff -ruN ./setup/src/c/setup.cpp ../c/setup/src/c/setup.cpp
+diff -ruN ./setup/src/c/setup.cpp ../b/setup/src/c/setup.cpp
--- ./setup/src/c/setup.cpp 2011-03-15 01:28:47.000000000 +0100
-+++ ../c/setup/src/c/setup.cpp 2020-09-03 16:25:55.873086621 +0200
++++ ../b/setup/src/c/setup.cpp 2020-09-02 15:08:07.764351504 +0200
@@ -110,10 +110,22 @@
return 1;
}
@@ -250,9 +299,9 @@ diff -ruN ./setup/src/c/setup.cpp ../c/setup/src/c/setup.cpp
//Win32 data should be "."
char tmppath[16384];
for (vector< string >::iterator vsit = data_paths.begin(); vsit != data_paths.end(); vsit++) {
-diff -ruN ./setup/src/include/central.cpp ../c/setup/src/include/central.cpp
+diff -ruN ./setup/src/include/central.cpp ../b/setup/src/include/central.cpp
--- ./setup/src/include/central.cpp 2004-10-25 04:27:13.000000000 +0200
-+++ ../c/setup/src/include/central.cpp 2020-09-03 17:45:35.786329482 +0200
++++ ../b/setup/src/include/central.cpp 2020-09-03 02:22:34.948442084 +0200
@@ -20,6 +20,8 @@
struct group GROUPS;
struct global_settings CONFIG;
@@ -271,9 +320,9 @@ diff -ruN ./setup/src/include/central.cpp ../c/setup/src/include/central.cpp
}
struct catagory *GetCatStruct(char *name) {
-diff -ruN ./src/cmd/music.cpp ../c/src/cmd/music.cpp
+diff -ruN ./src/cmd/music.cpp ../b/src/cmd/music.cpp
--- ./src/cmd/music.cpp 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/cmd/music.cpp 2020-09-03 16:25:55.874086608 +0200
++++ ../b/src/cmd/music.cpp 2020-09-02 15:08:07.765351492 +0200
@@ -448,7 +448,9 @@
if (foundcache) {
*me->music_load_info = wherecache->second;
@@ -285,9 +334,9 @@ diff -ruN ./src/cmd/music.cpp ../c/src/cmd/music.cpp
}
if (me->freeWav && docacheme) {
me->freeWav = false;
-diff -ruN ./src/cmd/unit.cpp ../c/src/cmd/unit.cpp
+diff -ruN ./src/cmd/unit.cpp ../b/src/cmd/unit.cpp
--- ./src/cmd/unit.cpp 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/cmd/unit.cpp 2020-09-03 16:25:55.875086596 +0200
++++ ../b/src/cmd/unit.cpp 2020-09-02 15:56:51.644797969 +0200
@@ -80,6 +80,7 @@
template < class UnitType >GameUnit< UnitType >::GameUnit( int ) : sparkle_accum( 0 )
, phalos( new HaloSystem() )
@@ -311,9 +360,9 @@ diff -ruN ./src/cmd/unit.cpp ../c/src/cmd/unit.cpp
}
template < class UnitType >GameUnit< UnitType >::~GameUnit()
-diff -ruN ./src/cmd/unit_collide.h ../c/src/cmd/unit_collide.h
+diff -ruN ./src/cmd/unit_collide.h ../b/src/cmd/unit_collide.h
--- ./src/cmd/unit_collide.h 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/cmd/unit_collide.h 2020-09-03 17:34:09.178913256 +0200
++++ ../b/src/cmd/unit_collide.h 2020-09-02 21:27:47.524565312 +0200
@@ -94,9 +94,9 @@
{
if ( !hugeobjects.empty() )
@@ -326,9 +375,30 @@ diff -ruN ./src/cmd/unit_collide.h ../c/src/cmd/unit_collide.h
hb.clear();
acc_huge.clear();
act_huge.clear();
-diff -ruN ./src/cmd/unit_generic.cpp ../c/src/cmd/unit_generic.cpp
+diff -ruN ./src/cmd/unit_generic.cpp ../b/src/cmd/unit_generic.cpp
--- ./src/cmd/unit_generic.cpp 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/cmd/unit_generic.cpp 2020-09-03 16:25:55.879086546 +0200
++++ ../b/src/cmd/unit_generic.cpp 2020-09-02 21:47:36.695698627 +0200
+@@ -630,13 +630,13 @@
+ jump.drive = -1;
+ }
+
+-float copysign( float x, float y )
+-{
+- if (y > 0)
+- return x;
+- else
+- return -x;
+-}
++//float copysign( float x, float y )
++//{
++// if (y > 0)
++// return x;
++// else
++// return -x;
++//}
+
+ float rand01()
+ {
@@ -4903,16 +4903,26 @@
static const string LOAD_FAILED = "LOAD_FAILED";
@@ -423,9 +493,9 @@ diff -ruN ./src/cmd/unit_generic.cpp ../c/src/cmd/unit_generic.cpp
if (tmpammo > mounts[jmod].ammo) {
cancompletefully = true;
if (touchme)
-diff -ruN ./src/cmd/unit_jump.h ../c/src/cmd/unit_jump.h
+diff -ruN ./src/cmd/unit_jump.h ../b/src/cmd/unit_jump.h
--- ./src/cmd/unit_jump.h 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/cmd/unit_jump.h 2020-09-03 16:25:55.880086533 +0200
++++ ../b/src/cmd/unit_jump.h 2020-09-02 15:08:07.766351479 +0200
@@ -108,7 +108,7 @@
(tester = *i) != NULL; ++i)
if (tester->isUnit() == UNITPTR && tester != this)
@@ -435,9 +505,21 @@ diff -ruN ./src/cmd/unit_jump.h ../c/src/cmd/unit_jump.h
*( 4*( this->rSize()+tester->rSize() ) ) );
DealPossibleJumpDamage( this );
static int jumparrive = AUDCreateSound( vs_config->getVariable( "unitaudio", "jumparrive", "sfx43.wav" ), false );
-diff -ruN ./src/gfx/cockpit_xml.cpp ../c/src/gfx/cockpit_xml.cpp
+diff -ruN ./src/cmd/unit_physics.h ../b/src/cmd/unit_physics.h
+--- ./src/cmd/unit_physics.h 2012-03-19 09:20:14.000000000 +0100
++++ ../b/src/cmd/unit_physics.h 2020-09-03 00:27:15.498947107 +0200
+@@ -41,7 +41,7 @@
+ #include "networking/lowlevel/vsnet_clientstate.h"
+ #include "networking/netclient.h"
+
+-extern float copysign( float x, float y );
++//extern float copysign( float x, float y );
+
+ extern unsigned int apply_float_to_unsigned_int( float tmp ); //short fix
+
+diff -ruN ./src/gfx/cockpit_xml.cpp ../b/src/gfx/cockpit_xml.cpp
--- ./src/gfx/cockpit_xml.cpp 2010-12-15 09:53:40.000000000 +0100
-+++ ../c/src/gfx/cockpit_xml.cpp 2020-09-03 16:30:00.313030701 +0200
++++ ../b/src/gfx/cockpit_xml.cpp 2020-09-03 00:14:13.810719555 +0200
@@ -315,7 +315,7 @@
for (counter = 0; counter < 4; ++counter)
if (!replaced[counter]) {
@@ -447,9 +529,9 @@ diff -ruN ./src/gfx/cockpit_xml.cpp ../c/src/gfx/cockpit_xml.cpp
}
break;
case UnitImages< void >::SHIELD4:
-diff -ruN ./src/gfx/quadsquare.cpp ../c/src/gfx/quadsquare.cpp
+diff -ruN ./src/gfx/quadsquare.cpp ../b/src/gfx/quadsquare.cpp
--- ./src/gfx/quadsquare.cpp 2010-03-10 06:27:01.000000000 +0100
-+++ ../c/src/gfx/quadsquare.cpp 2020-09-03 16:25:55.881086521 +0200
++++ ../b/src/gfx/quadsquare.cpp 2020-09-02 15:08:07.767351467 +0200
@@ -13,9 +13,9 @@
#include <float.h>
#include <math.h>
@@ -461,9 +543,9 @@ diff -ruN ./src/gfx/quadsquare.cpp ../c/src/gfx/quadsquare.cpp
using std::vector;
unsigned int*quadsquare::VertexAllocated;
-diff -ruN ./src/gui/text_area.cpp ../c/src/gui/text_area.cpp
+diff -ruN ./src/gui/text_area.cpp ../b/src/gui/text_area.cpp
--- ./src/gui/text_area.cpp 2010-02-25 15:26:53.000000000 +0100
-+++ ../c/src/gui/text_area.cpp 2020-09-03 17:46:51.883378138 +0200
++++ ../b/src/gui/text_area.cpp 2020-09-03 00:05:06.687559535 +0200
@@ -32,6 +32,8 @@
* };
*/
@@ -482,9 +564,9 @@ diff -ruN ./src/gui/text_area.cpp ../c/src/gui/text_area.cpp
if (type == 1) return search->name;
else return search->description;
-diff -ruN ./src/networking/lowlevel/packetmem.cpp ../c/src/networking/lowlevel/packetmem.cpp
+diff -ruN ./src/networking/lowlevel/packetmem.cpp ../b/src/networking/lowlevel/packetmem.cpp
--- ./src/networking/lowlevel/packetmem.cpp 2008-03-31 10:20:19.000000000 +0200
-+++ ../c/src/networking/lowlevel/packetmem.cpp 2020-09-03 16:25:55.881086521 +0200
++++ ../b/src/networking/lowlevel/packetmem.cpp 2020-09-02 15:08:07.768351454 +0200
@@ -102,7 +102,7 @@
}
else
@@ -494,9 +576,21 @@ diff -ruN ./src/networking/lowlevel/packetmem.cpp ../c/src/networking/lowlevel/p
_len = 0;
}
}
-diff -ruN ./src/pk3.cpp ../c/src/pk3.cpp
+diff -ruN ./src/physics.h ../b/src/physics.h
+--- ./src/physics.h 2011-02-12 04:19:03.000000000 +0100
++++ ../b/src/physics.h 2020-09-02 21:32:31.049020768 +0200
+@@ -27,7 +27,7 @@
+ static const float oocc = (float) 0.0000000000000000111265005605; //1/c^2
+ static const float c = (float) 299792458.0;
+ static const float co10 = (float) 29979245.8;
+-float copysign( float x, float y );
++//float copysign( float x, float y );
+
+ struct Force
+ {
+diff -ruN ./src/pk3.cpp ../b/src/pk3.cpp
--- ./src/pk3.cpp 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/pk3.cpp 2020-09-03 16:31:12.819124250 +0200
++++ ../b/src/pk3.cpp 2020-09-02 23:06:42.933362491 +0200
@@ -356,7 +356,7 @@
}
//if the file isn't in the archive
@@ -506,9 +600,59 @@ diff -ruN ./src/pk3.cpp ../c/src/pk3.cpp
int flength = GetFileLen( index );
buffer = new char[flength];
-diff -ruN ./src/vsfilesystem.cpp ../c/src/vsfilesystem.cpp
+diff -ruN ./src/python/python_compile.h ../b/src/python/python_compile.h
+--- ./src/python/python_compile.h 2010-02-25 16:44:43.000000000 +0100
++++ ../b/src/python/python_compile.h 2020-09-02 21:07:32.272758050 +0200
+@@ -10,6 +10,7 @@
+ #include "hashtable.h"
+ #include <string>
+ #include <compile.h>
++#include <boost/version.hpp>
+
+ extern Hashtable< std::string, PyCodeObject, 1023 >compiled_python;
+
+@@ -40,8 +41,11 @@
+ switch (type)
+ {
+ case MYSTRING:
++#if BOOST_VERSION <= 104500
+ return PyString_FromString( objects.c_str() );
+-
++#else
++ return PyUnicode_FromString( objects.c_str() );
++#endif
+ case MYLONG:
+ return PyLong_FromLong( objecti );
+
+diff -ruN ./src/ship_commands.cpp ../b/src/ship_commands.cpp
+--- ./src/ship_commands.cpp 2012-03-19 09:20:14.000000000 +0100
++++ ../b/src/ship_commands.cpp 2020-09-03 00:11:42.010617317 +0200
+@@ -5,14 +5,14 @@
+ #include "universe_util.h"
+ #include "gldrv/winsys.h"
+
+-static inline float fmin( float a, float b )
+-{
+- return (a < b) ? a : b;
+-}
+-static inline float fmax( float a, float b )
+-{
+- return (a > b) ? a : b;
+-}
++//static inline float fmin( float a, float b )
++//{
++// return (a < b) ? a : b;
++//}
++//static inline float fmax( float a, float b )
++//{
++// return (a > b) ? a : b;
++//}
+
+ class ShipCommands
+ {
+diff -ruN ./src/vsfilesystem.cpp ../b/src/vsfilesystem.cpp
--- ./src/vsfilesystem.cpp 2012-03-19 09:20:14.000000000 +0100
-+++ ../c/src/vsfilesystem.cpp 2020-09-03 16:25:55.882086508 +0200
++++ ../b/src/vsfilesystem.cpp 2020-09-02 16:02:24.060642199 +0200
@@ -460,13 +460,15 @@
int vs_fprintf( FILE *fp, const char *format, ... )