summaryrefslogtreecommitdiffstats
path: root/games/yabause
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-06-25 21:28:11 -0400
committer dsomero <xgizzmo@slackbuilds.org>2012-06-25 21:28:11 -0400
commit0f13261cc803f32a6aaa04c7f001b84c66722e78 (patch)
treecad949254a47109620e89f5480711c74570c5fa2 /games/yabause
parent70527e466add6ef6376f9630cf6caaf0fa561b0d (diff)
downloadslackbuilds-0f13261cc803f32a6aaa04c7f001b84c66722e78.tar.gz
slackbuilds-0f13261cc803f32a6aaa04c7f001b84c66722e78.tar.xz
games/yabause: Updated for version 0.9.11.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games/yabause')
-rw-r--r--games/yabause/README5
-rw-r--r--games/yabause/yabause.SlackBuild64
-rw-r--r--games/yabause/yabause.info8
3 files changed, 38 insertions, 39 deletions
diff --git a/games/yabause/README b/games/yabause/README
index 8ccc5ca787..7acfdbfbf2 100644
--- a/games/yabause/README
+++ b/games/yabause/README
@@ -13,5 +13,10 @@ Requires: gtkglext
Optional: mini18n and OpenAL
For translation support install mini18n.
+By default the QT version of yabause is built. To use the GTK
+version then pass USE_GUI=gtk to the slackbuild.
+
+USE_GUI=gtk ./yabause.SlackBuild
+
Before using Yabause, you need to configure a few things in
the Preferences dialog (File>Settings).
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index 87d48aae26..5ee718adac 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -5,16 +5,14 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=yabause
-VERSION=${VERSION:-0.9.10}
+VERSION=${VERSION:-0.9.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -24,9 +22,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-# Variable to determine gtk/qt4 interface.
-HAVE_QT4=${HAVE_QT4:-yes}
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -56,35 +51,34 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Determine if the user wants to use the gtk/qt4 interface.
-if [ "${HAVE_QT4}" == "yes" ]; then
- USE_PORT="qt"
-else
- USE_PORT="gtk"
-fi
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --enable-network \
- --enable-mic-shaders \
- --enable-perkeyname \
- --disable-dependency-tracking \
- --with-x \
- --with-q68 \
- --with-port=${USE_PORT} \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+# Variable to determine gtk/qt interface. Default is qt.
+USE_GUI=${USE_GUI:-qt}
+
+# Fix location of man file and use SLKCFLAGS.
+sed -i 's|share/man|man|' src/${USE_GUI}/CMakeLists.txt
+sed -i "s|-O3|$SLKCFLAGS|" src/CMakeLists.txt
+
+mkdir build
+cd build
+ cmake "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DYAB_PORTS="$USE_GUI" \
+ -DYAB_MULTIBUILD=OFF \
+ -DYAB_NETWORK=ON \
+ -DYAB_OPTIMIZED_DMA=ON \
+ -DYAB_PERKEYNAME=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/games/yabause/yabause.info b/games/yabause/yabause.info
index 03076d2f03..b288e0f5b4 100644
--- a/games/yabause/yabause.info
+++ b/games/yabause/yabause.info
@@ -1,10 +1,10 @@
PRGNAM="yabause"
-VERSION="0.9.10"
+VERSION="0.9.11"
HOMEPAGE="http://yabause.org/"
-DOWNLOAD="http://downloads.sourceforge.net/yabause/yabause-0.9.10.tar.gz"
-MD5SUM="7e39dd1eb37539d8f24e644fd52a72a7"
+DOWNLOAD="http://downloads.sourceforge.net/yabause/yabause-0.9.11.tar.gz"
+MD5SUM="b0c70080b07db3b709f252b9988701b5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="rworkman"
+APPROVED="dsomero"