summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2010-12-29 01:03:32 -0600
committer Robby Workman <rworkman@slackbuilds.org>2010-12-29 01:08:50 -0600
commit6e3846098698f57de85e957fcc3ec572ca7ba907 (patch)
tree36ad389a9227b2d464a6e12b09a6f2289d602435 /games
parent679bfeebbe9f78cd821d7eb8b49f7f3a1874be73 (diff)
downloadslackbuilds-6e3846098698f57de85e957fcc3ec572ca7ba907.tar.gz
slackbuilds-6e3846098698f57de85e957fcc3ec572ca7ba907.tar.xz
games/maelstrom: Fixed download link and desktop file
This commit also includes some rearrangement of script parts - done by me. Yes, I'm difficult ;-) Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/maelstrom/maelstrom.SlackBuild36
-rw-r--r--games/maelstrom/maelstrom.desktop3
-rw-r--r--games/maelstrom/maelstrom.info8
3 files changed, 20 insertions, 27 deletions
diff --git a/games/maelstrom/maelstrom.SlackBuild b/games/maelstrom/maelstrom.SlackBuild
index cd31964dfa..18bd8ae4f7 100644
--- a/games/maelstrom/maelstrom.SlackBuild
+++ b/games/maelstrom/maelstrom.SlackBuild
@@ -6,21 +6,20 @@
# Note to 64-bit users: Maelstrom-netd and the -server option to Maelstrom
# do not work correctly. I haven't investigated why. You can still play
-# networked games in non-server mode (see man page). Users of actual
+# networked games in non-server mode (see man page). Users of 32-bit
# Slackware are not affected by this.
PRGNAM=maelstrom
-SRCNAM=Maelstrom
VERSION=${VERSION:-3.0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
+SRCNAM=Maelstrom
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -72,35 +71,30 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-strip $PKG/usr/games/*
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-make install_gamedocs target=$PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Why does `make install' install this?
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Docs/Makefile
-
-install -m0755 -o root -g root $CWD/maelstrom_addon_package.pl $PKG/usr/games
+strip --strip-unneeded $PKG/usr/games/*
# CLI users would probably prefer to type 'maelstrom', not 'Maelstrom'
( cd $PKG/usr/games && ln -s $SRCNAM $PRGNAM )
-mkdir -p $PKG/usr/share/pixmaps
-( cd $PKG/usr/share/pixmaps
- ln -s ../games/$SRCNAM/icon.xpm $PRGNAM.xpm
-)
+install -m0755 -o root -g root $CWD/maelstrom_addon_package.pl $PKG/usr/games
mkdir -p $PKG/usr/share/applications
cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+mkdir -p $PKG/usr/share/pixmaps
+( cd $PKG/usr/share/pixmaps ; ln -s ../games/$SRCNAM/icon.xpm $PRGNAM.xpm )
+
mkdir -p $PKG/usr/man/man6
gzip -9c $CWD/$SRCNAM.6 > $PKG/usr/man/man6/$SRCNAM.6.gz
-
( cd $PKG/usr/man/man6
ln -s $SRCNAM.6.gz $PRGNAM.6.gz
- ln -s $SRCNAM.6.gz $SRCNAM-netd.6.gz
-)
+ ln -s $SRCNAM.6.gz $SRCNAM-netd.6.gz )
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+make install_gamedocs target=$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Why does `make install' install this?
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Docs/Makefile
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/games/maelstrom/maelstrom.desktop b/games/maelstrom/maelstrom.desktop
index 1c968032b8..9a94043690 100644
--- a/games/maelstrom/maelstrom.desktop
+++ b/games/maelstrom/maelstrom.desktop
@@ -1,8 +1,7 @@
[Desktop Entry]
-Encoding=UTF-8
Name=Maelstrom
Exec=Maelstrom
Type=Application
Icon=maelstrom
GenericName=Maelstrom
-Categories=Game;Arcade;
+Categories=Game;ArcadeGame;
diff --git a/games/maelstrom/maelstrom.info b/games/maelstrom/maelstrom.info
index 4ab6f1ee1d..d69f069c75 100644
--- a/games/maelstrom/maelstrom.info
+++ b/games/maelstrom/maelstrom.info
@@ -1,10 +1,10 @@
PRGNAM="maelstrom"
VERSION="3.0.6"
-HOMEPAGE="http://www.devolution.com/~slouken/Maelstrom/"
-DOWNLOAD="http://www.devolution.com/~slouken/Maelstrom/src/Maelstrom-3.0.6.tar.gz"
-MD5SUM="4fbeb6070eebdf161bd156b083b8804e"
+HOMEPAGE="http://www.happypenguin.org/show?maelstrom"
+DOWNLOAD="http://mirrors.kernel.org/gentoo/distfiles/Maelstrom-3.0.6.tar.gz"
+MD5SUM="8aab0e75ca52808fd6777535ebb1f1c4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
-APPROVED="dsomero"
+APPROVED="rworkman"