summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author CRTS <crts@gmx.net>2020-05-02 17:12:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-02 17:13:33 +0700
commit88823eaf78f38fa9cc2965cf788dcb4f406d4cff (patch)
tree46e86fd86a050f4210b6951ad33ab4523e48051f /games
parent495edecaac772164bb3675d5bd13d6aa1a2602a9 (diff)
downloadslackbuilds-88823eaf78f38fa9cc2965cf788dcb4f406d4cff.tar.gz
slackbuilds-88823eaf78f38fa9cc2965cf788dcb4f406d4cff.tar.xz
games/fs-uae-arcade: Updated for version 3.0.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/fs-uae-arcade/README1
-rw-r--r--games/fs-uae-arcade/doinst.sh9
-rw-r--r--games/fs-uae-arcade/fs-uae-arcade.SlackBuild87
-rw-r--r--games/fs-uae-arcade/fs-uae-arcade.info10
-rw-r--r--games/fs-uae-arcade/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/games/fs-uae-arcade/README b/games/fs-uae-arcade/README
new file mode 100644
index 0000000000..3d7668c656
--- /dev/null
+++ b/games/fs-uae-arcade/README
@@ -0,0 +1 @@
+FS-UAE Arcade is a fullscreen Amiga game browser for FS-UAE.
diff --git a/games/fs-uae-arcade/doinst.sh b/games/fs-uae-arcade/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/games/fs-uae-arcade/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/fs-uae-arcade/fs-uae-arcade.SlackBuild b/games/fs-uae-arcade/fs-uae-arcade.SlackBuild
new file mode 100644
index 0000000000..4ecb9b33b7
--- /dev/null
+++ b/games/fs-uae-arcade/fs-uae-arcade.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# SlackBuild script for "fs-uae-arcade".
+
+# Copyright 2020- CRTS <crts@gmx.net>
+# Copyright 2013-2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fs-uae-arcade
+VERSION=${VERSION:-3.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build
+make
+make install prefix=/usr DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/fs-uae-arcade/fs-uae-arcade.info b/games/fs-uae-arcade/fs-uae-arcade.info
new file mode 100644
index 0000000000..8b8956edb1
--- /dev/null
+++ b/games/fs-uae-arcade/fs-uae-arcade.info
@@ -0,0 +1,10 @@
+PRGNAM="fs-uae-arcade"
+VERSION="3.0.3"
+HOMEPAGE="https://fs-uae.net/"
+DOWNLOAD="https://fs-uae.net/stable/3.0.3/fs-uae-arcade-3.0.3.tar.gz"
+MD5SUM="25bec0da027877e2e183a46c71c861d2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-PyQt5 python3-lhafile fs-uae python-requests python3-certifi"
+MAINTAINER="CRTS"
+EMAIL="crts@gmx.net"
diff --git a/games/fs-uae-arcade/slack-desc b/games/fs-uae-arcade/slack-desc
new file mode 100644
index 0000000000..7fc57b1154
--- /dev/null
+++ b/games/fs-uae-arcade/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fs-uae-arcade: fs-uae-arcade (fullscreen game browser)
+fs-uae-arcade:
+fs-uae-arcade: FS-UAE Arcade is a fullscreen Amiga game browser for FS-UAE.
+fs-uae-arcade:
+fs-uae-arcade: Homepage: http://fs-uae.net/
+fs-uae-arcade:
+fs-uae-arcade:
+fs-uae-arcade:
+fs-uae-arcade:
+fs-uae-arcade:
+fs-uae-arcade: