summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Steven Voges <svoges.sbo@gmail.com>2023-03-30 23:32:00 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-01 09:14:14 +0700
commit80988cdbdb9691f13ed1f71acc83ecad962bf2ff (patch)
tree8f3320b8ea9c3215ce22e715fa292de70609d4e3 /games
parente65449c63103afa6c4f476ebdf43318b56d9978b (diff)
downloadslackbuilds-80988cdbdb9691f13ed1f71acc83ecad962bf2ff.tar.gz
slackbuilds-80988cdbdb9691f13ed1f71acc83ecad962bf2ff.tar.xz
games/dolphin-emu: Updated for version 5.0.19115.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/dolphin-emu/README10
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild20
-rw-r--r--games/dolphin-emu/dolphin-emu.info14
3 files changed, 30 insertions, 14 deletions
diff --git a/games/dolphin-emu/README b/games/dolphin-emu/README
index 4632060994..e3e767f8a3 100644
--- a/games/dolphin-emu/README
+++ b/games/dolphin-emu/README
@@ -4,8 +4,8 @@ two consoles in full HD (1080p) with several enhancements:
compatibility with all PC controllers, turbo speed, networked
multiplayer, and even more!
-Optional dependencies: SFML, cubeb, fmt, gtest, hidapi, jack, mbedtls,
-miniupnpc, pugixml, qt6
+Optional dependencies: SFML, cubeb, fmt, gtest, hidapi, jack, mgba,
+mbedtls, miniupnpc, pugixml, qt6
Analytic data collection is enabled by default, however, users are
prompted about this on first launch. To disable analytics without being
@@ -16,3 +16,9 @@ functionality, pass DISCORD=ON to the build script.
If you would like to disable Gameboy Advance controller support, pass
USEMGBA=OFF to the build script. This will remove the mgba dependecy.
+
+If you have installed mgba <= 0.10.0, this build will fail, please
+install 0.10.0+ or 'removepkg mgba' prior to running this script.
+
+qt6 is an optional dependency and will be built against it if present
+at build time. Otherwise, qt5 will be used.
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index 059d3d0056..079b437d22 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dolphin-emu
-# Copyright 2022 Steven Voges <Oregon, USA>
+# Copyright 2022-2023 Steven Voges <Oregon, USA>
# Copyright 2013-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
@@ -27,10 +27,12 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dolphin-emu
SRCNAM=dolphin
-VERSION=${VERSION:-5.0.17738}
-SRCVER=${SRCVER:-5ee7a555887f4365c61f99aa18a29ff822e4b8d8}
+VERSION=${VERSION:-5.0.19115}
+COMMIT=$(echo $VERSION | cut -c 5-)
+SRCVER=${SRCVER:-806ea59d77809aa7c6c17a4b61ae304b0f19e284}
+IMPLOT=${IMPLOT:-d87512353495e7760e7fda7566a05beef7627d8f}
LIBSPNG=${LIBSPNG:-dc5b1032c08efac68ad30170f7ccbf0aa8dd55c9}
-MGBA=${MGBA:-40d4c430fc36caeb7ea32fd39624947ed487d2f2}
+MGBA=${MGBA:-89f8873df366a99dfdf40347f72e68763fb50bd9}
SPIRVCROSS=${SPIRVCROSS:-50b4d5389b6a06f86fb63a2848e1a7da6d9755ca}
VULKANMEMORYALLOCATOR=${VULKANMEMORYALLOCATOR:-c351692490513cdb0e5a2c925aaf7ea4a9b672f4}
ZLIBNG=${ZLIBNG:-ce01b1e41da298334f8214389cc9369540a7560f}
@@ -80,11 +82,14 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$SRCVER
tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
tar xvf $CWD/SPIRV-Cross-$SPIRVCROSS.tar.gz -C \
$DEPS/spirv_cross/SPIRV-Cross --strip-components 1
tar xvf $CWD/VulkanMemoryAllocator-$VULKANMEMORYALLOCATOR.tar.gz -C \
$DEPS/VulkanMemoryAllocator --strip-components 1
+tar xvf $CWD/implot-$IMPLOT.tar.gz -C \
+ $DEPS/implot/implot --strip-components 1
tar xvf $CWD/libspng-$LIBSPNG.tar.gz -C \
$DEPS/libspng/libspng --strip-components 1
if [ ${USEMGBA} = "ON" ]; then
@@ -94,7 +99,8 @@ fi
tar xvf $CWD/zlib-ng-$ZLIBNG.tar.gz -C \
$DEPS/zlib-ng/zlib-ng --strip-components 1
-cd $SRCNAM-$SRCVER
+sed -i "s/ (no further info)/-$COMMIT/g" CMakeLists.txt
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -122,6 +128,8 @@ cd build
make install/strip DESTDIR=$PKG
cd ..
+mv $PKG/usr/share/man $PKG/usr/man
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -130,7 +138,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- docs LICENSES/* COPYING Contributing.md Readme.md \
+ docs LICENSES/* *.md COPYING \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/games/dolphin-emu/dolphin-emu.info b/games/dolphin-emu/dolphin-emu.info
index f317b9a16f..035732a609 100644
--- a/games/dolphin-emu/dolphin-emu.info
+++ b/games/dolphin-emu/dolphin-emu.info
@@ -1,20 +1,22 @@
PRGNAM="dolphin-emu"
-VERSION="5.0.17738"
+VERSION="5.0.19115"
HOMEPAGE="https://dolphin-emu.org"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/dolphin-emu/dolphin/archive/5ee7a555887f4365c61f99aa18a29ff822e4b8d8/dolphin-5ee7a555887f4365c61f99aa18a29ff822e4b8d8.tar.gz \
+DOWNLOAD_x86_64="https://github.com/dolphin-emu/dolphin/archive/806ea59d77809aa7c6c17a4b61ae304b0f19e284/dolphin-806ea59d77809aa7c6c17a4b61ae304b0f19e284.tar.gz \
https://github.com/KhronosGroup/SPIRV-Cross/archive/50b4d5389b6a06f86fb63a2848e1a7da6d9755ca/SPIRV-Cross-50b4d5389b6a06f86fb63a2848e1a7da6d9755ca.tar.gz \
https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator/archive/c351692490513cdb0e5a2c925aaf7ea4a9b672f4/VulkanMemoryAllocator-c351692490513cdb0e5a2c925aaf7ea4a9b672f4.tar.gz \
+ https://github.com/epezent/implot/archive/d87512353495e7760e7fda7566a05beef7627d8f/implot-d87512353495e7760e7fda7566a05beef7627d8f.tar.gz \
https://github.com/randy408/libspng/archive/dc5b1032c08efac68ad30170f7ccbf0aa8dd55c9/libspng-dc5b1032c08efac68ad30170f7ccbf0aa8dd55c9.tar.gz \
- https://github.com/mgba-emu/mgba/archive/40d4c430fc36caeb7ea32fd39624947ed487d2f2/mgba-40d4c430fc36caeb7ea32fd39624947ed487d2f2.tar.gz \
+ https://github.com/mgba-emu/mgba/archive/89f8873df366a99dfdf40347f72e68763fb50bd9/mgba-89f8873df366a99dfdf40347f72e68763fb50bd9.tar.gz \
https://github.com/zlib-ng/zlib-ng/archive/ce01b1e41da298334f8214389cc9369540a7560f/zlib-ng-ce01b1e41da298334f8214389cc9369540a7560f.tar.gz"
-MD5SUM_x86_64="c2d1d0f6cbc95afe24e78407b86f7b08 \
+MD5SUM_x86_64="35a870c23a714e94978c5c8b541b2507 \
ccbd4691aa98e09c48ca52938780f485 \
9eb7af01d2b36d8d5964696ecd257011 \
+ 47bc6ef34b7c577c7a0835f686f90107 \
5c563b774605b0bad9f6ed244bd9e14d \
- 640f4014848dbe1e40d09a138956be38 \
+ 1dba2ed39f63a90f52c0016a76d8bd35 \
59bc34854f5bb7492810e30f20b844eb"
-REQUIRES=""
+REQUIRES="cubeb"
MAINTAINER="Steven Voges"
EMAIL="svoges.sbo@gmail.com"