summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-08-24 00:19:43 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-08-29 15:32:12 -0500
commit11aac8fc2335853835b894949fcdaba0702bb026 (patch)
tree90290fdeffec225995ce2d0af3f8427330b388ed /games
parente9b01c5092012f12900b112730d41c09cb6d542e (diff)
downloadslackbuilds-11aac8fc2335853835b894949fcdaba0702bb026.tar.gz
slackbuilds-11aac8fc2335853835b894949fcdaba0702bb026.tar.xz
games/sauerbraten: Added (FPS game based on the original Cube FPS)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/sauerbraten/README5
-rw-r--r--games/sauerbraten/doinst.sh4
-rw-r--r--games/sauerbraten/sauerbraten.668
-rw-r--r--games/sauerbraten/sauerbraten.SlackBuild91
-rw-r--r--games/sauerbraten/sauerbraten.desktop10
-rw-r--r--games/sauerbraten/sauerbraten.info10
-rw-r--r--games/sauerbraten/slack-desc19
7 files changed, 207 insertions, 0 deletions
diff --git a/games/sauerbraten/README b/games/sauerbraten/README
new file mode 100644
index 0000000000..5469e427a9
--- /dev/null
+++ b/games/sauerbraten/README
@@ -0,0 +1,5 @@
+Sauerbraten is a networked fast-paced 3D first person first-person shooter
+game. It supports rather modern graphic effects and a some nice graphic
+details. The game client also works as the map editor. It is even possible
+to create and/or edit a map together with other people over a network
+connection. This package installs the game client and map editor.
diff --git a/games/sauerbraten/doinst.sh b/games/sauerbraten/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/games/sauerbraten/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/games/sauerbraten/sauerbraten.6 b/games/sauerbraten/sauerbraten.6
new file mode 100644
index 0000000000..fc1c1f78c4
--- /dev/null
+++ b/games/sauerbraten/sauerbraten.6
@@ -0,0 +1,68 @@
+.TH SAUERBRATEN 6 "January 9, 2007"
+.SH NAME
+sauerbraten \- a 3D first person shooter
+.SH SYNOPSIS
+.B sauerbraten
+[\-d] [\-w\fIwidth\fP] [\-h\fIheight\fP] [\-z\fIdepth\fP] [\-b\fIbpp\fP] [\-a\fIsamples\fP] [\-t] [\-k\fIdirectory\fP] [\-f\fIshaderprecision\fP]
+.SH DESCRIPTION
+.PP
+This manual page documents briefly the
+.B sauerbraten
+command.
+.PP
+\fBsauerbraten\fP is the client and map editor of the Sauerbraten game. Sauerbraten is a fast 3D first person shooter.
+.SH OPTIONS
+.TP
+\fB\-d\fR
+Run as a dedicated server and don't start the client.
+.TP
+\fB\-w\fR\fIwidth\fP
+Set window width in pixels.
+.TP
+\fB\-h\fR\fIheight\fP
+Set window height in pixels.
+.TP
+\fB\-z\fR\fIdepth\fP
+Set the z-buffer precision to \fIdepth\fP in bits.
+.TP
+\fB\-b\fR\fIbpp\fP
+Set the bits per pixel to \fIbpp\fP bits.
+.TP
+\fB\-a\fR\fIsamples\fP
+Set Full Scene Antialiasing to \fIsamples\fP samples.
+.TP
+\fB\-t\fR
+Run in windowed mode (default is fullscreen mode).
+.TP
+\fB\-k\fR\fIdirectory\fP
+Adds \fIdirectory\fP to the list of paths, in which the engine searches for files.
+.TP
+\fB\-f\fR\fIshaderprecision\fP
+Set the precision quality. Values from 0 to 3 are allowed. 0 disabled shaders. The lower the value, the faster sauerbraten will run.
+.TP
+\fB\-f\fR
+Don't use any shaders.
+.BR
+.SH SEE ALSO
+.BR sauerbraten-server (6)
+.br
+http://sauerbraten.org/docs/config.html
+.br
+.SH AUTHOR
+Sauerbraten was written by
+.br
+Wouter "Aardappel" van Oortmerssen,
+.br
+Lee "Eihrul" Salzman
+.br
+Mike "Gilt" Dysart
+.br
+Adrian "driAn" Henke
+.br
+Jerry Siebe
+.br
+Julian Mayer
+.PP
+This manual page was written by Bruno "Fuddl" Kleinert <fuddl@tauware.de> for the Debian project (but may be used by others). Permission is granted to copy, distribute and/or modify this document under the terms of the GNU General Public License, Version 2 any later version published by the Free Software Foundation.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/doc/sauerbrauten-2009_06_19/.
diff --git a/games/sauerbraten/sauerbraten.SlackBuild b/games/sauerbraten/sauerbraten.SlackBuild
new file mode 100644
index 0000000000..a266de687e
--- /dev/null
+++ b/games/sauerbraten/sauerbraten.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for sauerbraten
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=sauerbraten
+VERSION=${VERSION:-2010_07_28}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/${PRGNAM}_${VERSION}_justice_edition_linux.tar.bz2
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Use custom SLKCFLAGS and remove precompiled executables.
+cp bin_unix/readme.txt .
+rm -f bin_unix/*
+sed -i \
+ -e "s|-O3|$SLKCFLAGS|" \
+ -e '/\$(STRIP) \.\./d' \
+ -e "s|\./configure|CFLAGS=\"$SLKCFLAGS\" \./configure|" \
+ src/Makefile
+
+make -C src
+make -C src install
+
+# Install the files.
+mkdir -p $PKG/usr/games $PKG/usr/share/$PRGNAM
+chmod 0755 bin_unix/*
+cp -ar bin_unix data packages server-init.cfg $PKG/usr/share/$PRGNAM
+sed -i "/^SAUER_DATA/s|=.*|=\"/usr/share/${PRGNAM}\"|" ${PRGNAM}_unix
+install -m 0755 ${PRGNAM}_unix $PKG/usr/games/$PRGNAM
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man/man6
+gzip -9c $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+install -m 0644 data/cube.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.html docs readme.txt src/readme_source.txt src/enet/LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/sauerbraten/sauerbraten.desktop b/games/sauerbraten/sauerbraten.desktop
new file mode 100644
index 0000000000..a84e83b931
--- /dev/null
+++ b/games/sauerbraten/sauerbraten.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Sauerbraten Client
+Comment=A networked, fast-paced 3D first-person shooter
+Comment[de]=Ein schnelles netzwerkfähiges 3D Ego-Shooter Spiel
+Exec=sauerbraten
+Icon=sauerbraten
+Terminal=false
+Type=Application
+StartupNotify=false
+Categories=Game;ArcadeGame;
diff --git a/games/sauerbraten/sauerbraten.info b/games/sauerbraten/sauerbraten.info
new file mode 100644
index 0000000000..420175379a
--- /dev/null
+++ b/games/sauerbraten/sauerbraten.info
@@ -0,0 +1,10 @@
+PRGNAM="sauerbraten"
+VERSION="2010_07_28"
+HOMEPAGE="http://www.sauerbraten.org/"
+DOWNLOAD="http://downloads.sourceforge.net/sauerbraten/sauerbraten_2010_07_28_justice_edition_linux.tar.bz2"
+MD5SUM="0947cb37b628873063270be1fcce27f6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/games/sauerbraten/slack-desc b/games/sauerbraten/slack-desc
new file mode 100644
index 0000000000..bdb24ccb98
--- /dev/null
+++ b/games/sauerbraten/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+sauerbraten: Sauerbrauten (FPS game based on the original Cube FPS)
+sauerbraten:
+sauerbraten: Sauerbraten is a free multiplayer/singleplayer first person shooter,
+sauerbraten: built as a major redesign of the Cube FPS. Much like the original
+sauerbraten: Cube, the aim of this game is not necessarily to produce the most
+sauerbraten: features & eyecandy possible, but rather to allow map/geometry
+sauerbraten: editing to be done dynamically in-game, to create fun gameplay and
+sauerbraten: an elegant engine.
+sauerbraten:
+sauerbraten: Homepage: http://www.sauerbraten.org/
+sauerbraten: