summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2020-04-16 20:21:16 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-04-19 10:52:28 +0700
commit1af65dc144391b3588e94c14b1e629f62d3607ac (patch)
tree2f6cc4caca230370aa383b0362591a1fd1070193 /games
parentffa5ded1218bbf7e04ef6d2d40850bd66592157e (diff)
downloadslackbuilds-1af65dc144391b3588e94c14b1e629f62d3607ac.tar.gz
slackbuilds-1af65dc144391b3588e94c14b1e629f62d3607ac.tar.xz
games/SLADE: Updated for version 3.1.11, new maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/SLADE/README8
-rw-r--r--games/SLADE/SLADE.SlackBuild56
-rw-r--r--games/SLADE/SLADE.info10
3 files changed, 48 insertions, 26 deletions
diff --git a/games/SLADE/README b/games/SLADE/README
index fb14fe9253..50370e5c0b 100644
--- a/games/SLADE/README
+++ b/games/SLADE/README
@@ -1,5 +1,5 @@
-SLADE is a modern editor for DOOM-engine based games and source ports. It has
-the ability to view, modify and write many different game-specific formats, and
-even convert between some of them.
+SLADE (DOOM editor)
-Credit to Arch Linux for the .desktop file.
+SLADE is a modern editor for DOOM-engine based games and source ports. It
+has the ability to view, modify and write many different game-specific
+formats, and even convert between some of them.
diff --git a/games/SLADE/SLADE.SlackBuild b/games/SLADE/SLADE.SlackBuild
index 35c37ca39c..1108a86711 100644
--- a/games/SLADE/SLADE.SlackBuild
+++ b/games/SLADE/SLADE.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for SLADE
# Copyright 2015 Dugan Chen Canada
+# Copyright 2020 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,8 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20200416 bkw:
+# - take over maintenance
+# - update for v3.1.11
+# - binary in /usr/games
+# - install icon in right place, symlink to old location
+# - get rid of our .desktop file (upstream provides one now)
+
PRGNAM=SLADE
-VERSION=${VERSION:-3.1.1.5}
+VERSION=${VERSION:-3.1.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,37 +68,51 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# 20200416 bkw: game binaries do not belong in /usr/bin.
+sed -i 's,\<bin\>,games,' src/CMakeLists.txt
-mkdir -p build
+# 20200416 bkw: don't depend on unstable /usr/bin/wx-config symlink.
+# stupid thing insists on searching for wx-config in PATH, instead of
+# allowing us to explicitly give a full path and name for the script, so:
+WXCONF=/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0
+WXTMP=$( pwd )/wxtmp
+mkdir -p $WXTMP
+ln -s $WXCONF $WXTMP/wx-config
+
+# 20200416 bkw: our wxGTK3 package doesn't include wxWebView, and it's built
+# with gtk+-2, not 3. This stuff isn't autodetected so we help it along.
cd build
cmake \
+ -DWITH_WXPATH=$WXTMP \
+ -DNO_WEBVIEW=ON \
+ -DWX_GTK3=OFF \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-mkdir -p $PKG/usr/share/applications
-cp $CWD/SLADE.desktop $PKG/usr/share/applications
-
-mkdir -p $PKG/usr/share/pixmaps
-convert dist/res/slade.ico[3] $PKG/usr/share/pixmaps/${PRGNAM}.ico
+mkdir -p $PKG/usr/share/icons/hicolor/128x128/apps \
+ $PKG/usr/share/pixmaps
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20200416 bkw: don't want to hardcode the icon name here.
+cd $PKG/usr/share/icons
+ icon="$( /bin/ls *$PRGNAM.png | head -1 )"
+ mv $icon hicolor/128x128/apps
+ ln -s hicolor/128x128/apps/$icon .
+ ln -s ../icons/hicolor/128x128/apps/$icon ../pixmaps/$PRGNAM.png
+cd -
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* gpl-2.0.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/SLADE/SLADE.info b/games/SLADE/SLADE.info
index adbb9ee289..bba4042fda 100644
--- a/games/SLADE/SLADE.info
+++ b/games/SLADE/SLADE.info
@@ -1,10 +1,10 @@
PRGNAM="SLADE"
-VERSION="3.1.1.5"
+VERSION="3.1.11"
HOMEPAGE="http://slade.mancubus.net/"
-DOWNLOAD="https://github.com/sirjuddington/SLADE/archive/3.1.1.5/SLADE-3.1.1.5.tar.gz"
-MD5SUM="ce693b861ae962878370be80c1a3284f"
+DOWNLOAD="https://github.com/sirjuddington/SLADE/archive/3.1.11/SLADE-3.1.11.tar.gz"
+MD5SUM="41f7592730bb88daf3b5b957bc19dae7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="wxGTK3 SFML ftgl fluidsynth FreeImage"
-MAINTAINER="Dugan Chen"
-EMAIL="thedoogster [at] gmail [dot] com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"