summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2021-04-18 16:24:03 +0200
committer Matteo Bernardini <ponce@slackbuilds.org>2021-04-18 16:24:03 +0200
commit302218856d1c00ca8cf807435a4f14d7153a0f0c (patch)
tree14d4f8df533889c1591c8588941f92339b1d0a95 /games
parent5ed8dd7c66d4aadc492a9fdd53514a5a5f8d533b (diff)
downloadslackbuilds-302218856d1c00ca8cf807435a4f14d7153a0f0c.tar.gz
slackbuilds-302218856d1c00ca8cf807435a4f14d7153a0f0c.tar.xz
games/nethack: Removed (added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/nethack/README8
-rw-r--r--games/nethack/nethack-366.patch33
-rw-r--r--games/nethack/nethack.SlackBuild136
-rw-r--r--games/nethack/nethack.info10
-rw-r--r--games/nethack/slack-desc19
5 files changed, 0 insertions, 206 deletions
diff --git a/games/nethack/README b/games/nethack/README
deleted file mode 100644
index 1bf7f12cb7..0000000000
--- a/games/nethack/README
+++ /dev/null
@@ -1,8 +0,0 @@
-Nethack is a single-player dungeon exploration game. The emphasis is
-on discovering the detail of the dungeon. Each game presents a
-different landscape - the random number generator provides an
-essentially unlimited number of variations of the dungeon and its
-denizens to be discovered by the player in one of a number of
-characters: you can pick your race, your role, and your gender.
-
-User accounts that play this need to be members of the "games" group.
diff --git a/games/nethack/nethack-366.patch b/games/nethack/nethack-366.patch
deleted file mode 100644
index c8295c896e..0000000000
--- a/games/nethack/nethack-366.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- /var/lib/sbopkg/r0t/14.2/games/nethack/nethack.SlackBuild 2019-06-08 22:37:23.000000000 +0000
-+++ nethack.SlackBuild 2020-03-26 02:19:34.386984395 +0000
-@@ -25,7 +25,8 @@
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
- PRGNAM=nethack
--VERSION=${VERSION:-3.6.2}
-+VERSION=${VERSION:-3.6.6}
-+SRCDIR=NetHack-NetHack-${VERSION}_Released
- SRCVERSION=$(echo $VERSION | sed "s,\.,,g")
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
-@@ -63,9 +64,9 @@
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
--rm -rf $PRGNAM-$VERSION
-+rm -rf $SRCDIR
- tar xvf $CWD/$PRGNAM-$SRCVERSION-src.tgz
--cd $PRGNAM-$VERSION
-+cd $SRCDIR
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-@@ -97,7 +98,7 @@
- cd sys/unix
- sh setup.sh hints/linux
- cd ../..
--make -j1 install PREFIX=$PKG
-+make -j1 install PREFIX=$PKG WINTTYLIB=-lncurses
- mkdir -p $PKG/usr/man/man6
- make PREFIX=$PKG -j1 install manpages # Multi-threaded builds fail.
-
diff --git a/games/nethack/nethack.SlackBuild b/games/nethack/nethack.SlackBuild
deleted file mode 100644
index 10fddde55c..0000000000
--- a/games/nethack/nethack.SlackBuild
+++ /dev/null
@@ -1,136 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for nethack.
-
-# Written by Dugan Chen (thedoogster [at] gmail [dot] com)
-# Based on the Arch Linux PkgBuild.
-
-# Now maintained by Dave Woodfall <dave@slackbuilds.org>
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=nethack
-VERSION=${VERSION:-3.6.6}
-SRCDIR=NetHack-NetHack-${VERSION}_Released
-SRCVERSION=$(echo $VERSION | sed "s,\.,,g")
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCDIR
-tar xvf $CWD/$PRGNAM-$SRCVERSION-src.tgz
-cd $SRCDIR
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -e 's|^/\* \(#define LINUX\) \*/|\1|' \
- -e 's|^/\* \(#define TIMED_DELAY\) \*/|\1|' -i include/unixconf.h
-
-# we are setting up for setgid games, so modify all necessary permissions
-# to allow full access for groups
-
-sed -e '/^HACKDIR/ s|/games/lib/\$(GAME)dir|/var/games/nethack/|' \
- -e '/^SHELLDIR/ s|/games|/usr/bin|' \
- -e '/^VARDIRPERM/ s|0755|0775|' \
- -e '/^VARFILEPERM/ s|0600|0664|' \
- -e '/^GAMEPERM/ s|0755|02755|' \
- -e 's|\(DSYSCF_FILE=\)\\"[^"]*\\"|\1\\"/var/games/nethack/sysconf\\"|' \
- -e 's|\(DHACKDIR=\)\\"[^"]*\\"|\1\\"/var/games/nethack/\\"|' -i sys/unix/hints/linux
-
-sed -e 's|^#GAMEUID.*|GAMEUID = root|' \
- -e 's|^#GAMEGRP.*|GAMEGRP = games|' \
- -e '/^FILEPERM\s*=/ s|0644|0664|' \
- -e '/^DIRPERM\s*=/ s|0755|0775|' -i sys/unix/Makefile.top
-
-sed -e "/^MANDIR\s*=/s|/usr/man/man6|$PKG/usr/man/man6|" -i sys/unix/Makefile.doc
-
-cd sys/unix
-sh setup.sh hints/linux
-cd ../..
-make -j1 install PREFIX=$PKG WINTTYLIB=-lncurses
-mkdir -p $PKG/usr/man/man6
-make PREFIX=$PKG -j1 install manpages # Multi-threaded builds fail.
-
-sed -e "s|HACKDIR=$PKG/|HACKDIR=/|" \
- -e "s|HACK=\$HACKDIR|HACK=/usr/lib$LIBDIRSUFFIX/nethack|" \
- -i $PKG/usr/bin/nethack
-
-mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/nethack
-mv $PKG/var/games/nethack/{nethack,recover} $PKG/usr/lib$LIBDIRSUFFIX/nethack/
-
-# FS#43414: /var/games should be owned by root:games.
-chown -R root:games $PKG/var/games/
-chown root:games $PKG/usr/lib$LIBDIRSUFFIX/nethack/nethack
-
-# FS#43414: /var/games should be owned by root:games.
-mkdir -p $PKG/var/games
-chown -R root:games $PKG/var/games/
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- doc/Guidebook.txt doc/fixes36.1 dat/license \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/nethack/nethack.info b/games/nethack/nethack.info
deleted file mode 100644
index 7a3aa538cc..0000000000
--- a/games/nethack/nethack.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="nethack"
-VERSION="3.6.6"
-HOMEPAGE="https://nethack.org"
-DOWNLOAD="https://nethack.org/download/3.6.6/nethack-366-src.tgz"
-MD5SUM="6c9a75f556d24c66801d74d8727a602e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dave Woodfall"
-EMAIL="dave@slackbuilds.org"
diff --git a/games/nethack/slack-desc b/games/nethack/slack-desc
deleted file mode 100644
index 91586f81d6..0000000000
--- a/games/nethack/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-nethack: nethack (roguelike game)
-nethack:
-nethack: Nethack is a single-player dungeon exploration game. The emphasis is
-nethack: on discovering the detail of the dungeon. Each game presents a
-nethack: different landscape - the random number generator provides an
-nethack: essentially unlimited number of variations of the dungeon and its
-nethack: denizens to be discovered by the player in one of a number of
-nethack: characters: you can pick your race, your role, and your gender.
-nethack:
-nethack: http://nethack.org
-nethack: