summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author CRTS <crts [at] gmx [dot] net>2019-06-15 08:07:52 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-15 08:07:52 +0700
commitc43107ccf7ba29eddadf58430c8a07c7100c3431 (patch)
tree7efe89ddc973ae1dcb581c02ded2b5728c071d1a /games
parent6b6c5ff56638aa251e6b0ce8a4e25f82ce9ea5f4 (diff)
downloadslackbuilds-c43107ccf7ba29eddadf58430c8a07c7100c3431.tar.gz
slackbuilds-c43107ccf7ba29eddadf58430c8a07c7100c3431.tar.xz
games/freedink: Added (free RPG).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/freedink/README36
-rw-r--r--games/freedink/freedink.SlackBuild132
-rw-r--r--games/freedink/freedink.info12
-rw-r--r--games/freedink/slack-desc19
4 files changed, 199 insertions, 0 deletions
diff --git a/games/freedink/README b/games/freedink/README
new file mode 100644
index 0000000000..97bd639f42
--- /dev/null
+++ b/games/freedink/README
@@ -0,0 +1,36 @@
+Freedink is a free role playing game in real time. You take
+control of Dink Smallwood and guide him through his many adventures.
+There are many battles to be fought and riddles to be solved.
+You can install additional adventures through additional D-Mods
+which are available at
+
+ https://www.dinknetwork.com
+
+Optional dependency:
+- upx
+ If upx is installed on the system then it is automatically
+ detected and considered at compile time.
+
+ If for some reason this is not desired then the script
+ should be called as
+
+ ENABLE_UPX=no ./freedink.Slackbuild
+
+ If UPX resides in a non-standard location then it
+ can be provided by setting
+
+ UPX=/path/to/upx ./freedink.Slackbuild
+
+Known issues:
+- Freedink might start in a maximized, not resizable window. Parts of
+ it may be outside the Desktop. If this happens then start the
+ program from CLI in windowed mode:
+
+ freedink -i -w
+
+ Afterwards you can switch to fullscreen by pressing Alt+Enter.
+
+- Some midi files may not play. The game is still playable
+ and the sound effects are all there but music may not
+ always be available.
+
diff --git a/games/freedink/freedink.SlackBuild b/games/freedink/freedink.SlackBuild
new file mode 100644
index 0000000000..b5bcc65e3f
--- /dev/null
+++ b/games/freedink/freedink.SlackBuild
@@ -0,0 +1,132 @@
+#!/bin/sh
+
+# Slackware build script for freedink
+
+# Copyright 2019 CRTS
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=freedink
+PRGDATANAME=${PRGDATANAME:-$PRGNAM-data-*}
+PRGDATANAME=${PRGDATANAME%.tar.gz}
+VERSION=${VERSION:-109.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+CONFIGURE_OPTIONS="--enable-tests=no"
+
+PATH=${UPX:+${UPX%/*}:}$PATH
+if which upx;then
+ CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS --enable-upx=${ENABLE_UPX:-yes}"
+else
+ CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS --enable-upx=no"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# ignore woeres.rc
+sed -i '/AC_CHECK_TOOL(WINDRES, windres)/d' configure.ac
+
+autoreconf --install --symlink --force
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure $CONFIGURE_OPTIONS \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp ABOUT-NLS INSTALL README.txt AUTHORS THANKS BUILD TRANSLATIONS.txt COPYING NEWS TROUBLESHOOTING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
+
+# install separate data package
+cd $TMP
+rm -rf $PRGDATANAME
+tar xvf $CWD/$PRGDATANAME.tar.gz
+cd $PRGDATANAME
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# no compilation required
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/data
+cp COPYING ChangeLog NEWS README-REPLACEMENTS.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION/data
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/freedink/freedink.info b/games/freedink/freedink.info
new file mode 100644
index 0000000000..fb30d2eb2f
--- /dev/null
+++ b/games/freedink/freedink.info
@@ -0,0 +1,12 @@
+PRGNAM="freedink"
+VERSION="109.6"
+HOMEPAGE="https://www.gnu.org/software/freedink"
+DOWNLOAD="https://ftp.gnu.org/gnu/freedink/freedink-109.6.tar.gz \
+ https://ftp.gnu.org/gnu/freedink/freedink-data-1.08.20190120.tar.gz"
+MD5SUM="cdec0ef4db6d15b767f696745ef0ae2f \
+ 6703e773f06dc53afa4094775beaff8d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="SDL2_image SDL2_mixer SDL2_ttf SDL2_gfx glm cxxtest"
+MAINTAINER="CRTS"
+EMAIL="crts [at] gmx [dot] net"
diff --git a/games/freedink/slack-desc b/games/freedink/slack-desc
new file mode 100644
index 0000000000..fe0576c3cf
--- /dev/null
+++ b/games/freedink/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+freedink: freedink (free RPG)
+freedink:
+freedink: Freedink is a free role play game in real. You take
+freedink: control of Dink Smallwood and guide through his many adventures.
+freedink: There are many battles to fought and riddles to be solved.
+freedink: Additional D-Mods are available at https://www.dinknetwork.com
+freedink:
+freedink: Homepage: https://www.gnu.org/software/freedink
+freedink:
+freedink:
+freedink: