summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Brad Hermanson <apeitheo@gmail.com>2012-06-25 21:15:41 -0400
committer dsomero <xgizzmo@slackbuilds.org>2012-06-25 21:15:41 -0400
commitf89d4c8180611db13ecfc605ca05c5ef049c49fc (patch)
treeff4e33195af8d10d3fd888a2ccd8b18093e9b4ba /games
parent77a8c67fad15556727441816b70f92851f1846c4 (diff)
downloadslackbuilds-f89d4c8180611db13ecfc605ca05c5ef049c49fc.tar.gz
slackbuilds-f89d4c8180611db13ecfc605ca05c5ef049c49fc.tar.xz
games/neverball: Updated for version 1.5.4.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/neverball/Makefile.diff29
-rw-r--r--games/neverball/README2
-rw-r--r--games/neverball/base_config.h.diff11
-rw-r--r--games/neverball/neverball.SlackBuild56
-rw-r--r--games/neverball/neverball.info12
-rw-r--r--games/neverball/slack-desc2
6 files changed, 66 insertions, 46 deletions
diff --git a/games/neverball/Makefile.diff b/games/neverball/Makefile.diff
new file mode 100644
index 0000000000..f9cc96f5a7
--- /dev/null
+++ b/games/neverball/Makefile.diff
@@ -0,0 +1,29 @@
+diff -Nur neverball-1.5.4.orig//Makefile neverball-1.5.4/Makefile
+--- neverball-1.5.4.orig//Makefile 2012-06-02 00:19:40.340921775 -0400
++++ neverball-1.5.4/Makefile 2012-06-02 21:54:52.078406763 -0400
+@@ -27,7 +27,7 @@
+ # Paths (packagers might want to set DATADIR and LOCALEDIR)
+
+ USERDIR := .neverball
+-DATADIR := ./data
++DATADIR := /usr/share/neverball/data
+ LOCALEDIR := ./locale
+
+ ifdef MINGW
+@@ -131,14 +131,14 @@
+ OGL_LIBS := -framework OpenGL
+ endif
+
+-BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS)
++BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS) -lm
+
+ ifdef DARWIN
+ BASE_LIBS += -L/opt/local/lib
+ endif
+
+ ALL_LIBS := $(SDL_LIBS) $(BASE_LIBS) $(TILT_LIBS) $(INTL_LIBS) -lSDL_ttf \
+- -lvorbisfile $(OGL_LIBS)
++ -lvorbisfile $(OGL_LIBS) -lX11
+
+ #------------------------------------------------------------------------------
+
diff --git a/games/neverball/README b/games/neverball/README
index 15be26bfd7..2f1f9a10d6 100644
--- a/games/neverball/README
+++ b/games/neverball/README
@@ -3,3 +3,5 @@ time runs out. Neverball is part puzzle game, part action game,
and entirely a test of skill. Also found here is Neverputt, a
hot-seat multiplayer miniature golf game using the physics and
graphics of Neverball.
+
+Requires SDL_ttf and physfs
diff --git a/games/neverball/base_config.h.diff b/games/neverball/base_config.h.diff
deleted file mode 100644
index ba72ac40d6..0000000000
--- a/games/neverball/base_config.h.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- share/base_config.h.orig 2009-04-27 13:07:14.738222152 -0700
-+++ share/base_config.h 2009-04-27 13:09:08.065322026 -0700
-@@ -30,7 +30,7 @@
- #endif
-
- #ifndef CONFIG_DATA
--#define CONFIG_DATA "./data" /* Game data directory */
-+#define CONFIG_DATA "/usr/share/neverball/data" /* Game data directory */
- #endif
-
- #ifndef CONFIG_LOCALE
diff --git a/games/neverball/neverball.SlackBuild b/games/neverball/neverball.SlackBuild
index ff70ae9a50..aab1d3177e 100644
--- a/games/neverball/neverball.SlackBuild
+++ b/games/neverball/neverball.SlackBuild
@@ -5,6 +5,8 @@
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# All rights reserved.
#
+# Modified by Brad Hermanson <apeitheo@gmail.com>
+#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@@ -24,16 +26,14 @@
PRGNAM=neverball
BONUS=neverputt
-VERSION=${VERSION:-1.5.1}
+VERSION=${VERSION:-1.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -70,35 +70,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Apply base_config.h.diff patch:
-patch -p0 < $CWD/base_config.h.diff || exit 1
+# Patch Makefile to change data directory and to make it compile
+# with appropriate flags
+patch -p1 < $CWD/Makefile.diff || exit 1
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make || exit 1
+make CFLAGS="$SLKCFLAGS" || exit 1
-mkdir -p $PKG/usr/{bin,share/$PRGNAM}
-cp -a mapc $PRGNAM $BONUS $PKG/usr/bin || exit 1
-cp -a data $PKG/usr/share/$PRGNAM || exit 1
+# Fix map permissions that were created by mapc during compile
+find data/ -name '*.sol' -exec chmod 644 {} \;
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Delete the .map files that are no longer required
+find data/ -name '*.map' -exec rm {} \;
-( cd dist
- install -D -m 0644 mapc.1 $PKG/usr/man/man1/mapc.1
- install -D -m 0644 $PRGNAM.6 $PKG/usr/man/man6/$PRGNAM.6
- install -D -m 0644 $BONUS.6 $PKG/usr/man/man6/$BONUS.6
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES COPYING README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/usr/{bin,share/$PRGNAM}
+cp -a mapc $PRGNAM $BONUS $PKG/usr/bin || exit 1
+cp -a data/ $PKG/usr/share/$PRGNAM || exit 1
( cd dist
for i in $PRGNAM $BONUS ; do
@@ -114,8 +100,22 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
done
cp -a ${PRGNAM}_replay.png $PKG/usr/share/icons/hicolor/48x48/apps/${PRGNAM}_replay.png
cp -a neverlogos.svg $PKG/usr/share/icons/hicolor/scalable/apps/neverlogos.svg
+ install -D -m 0644 mapc.1 $PKG/usr/man/man1/mapc.1
+ install -D -m 0644 $PRGNAM.6 $PKG/usr/man/man6/$PRGNAM.6
+ install -D -m 0644 $BONUS.6 $PKG/usr/man/man6/$BONUS.6
)
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES COPYING README doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/games/neverball/neverball.info b/games/neverball/neverball.info
index 0f090c3877..6b471a4bc3 100644
--- a/games/neverball/neverball.info
+++ b/games/neverball/neverball.info
@@ -1,10 +1,10 @@
PRGNAM="neverball"
-VERSION="1.5.1"
-HOMEPAGE="http://icculus.org/neverball/"
-DOWNLOAD="http://icculus.org/neverball/neverball-1.5.1.tar.gz"
-MD5SUM="d58740e8a2808a41400191ab01b19ad4"
+VERSION="1.5.4"
+HOMEPAGE="http://neverball.org/"
+DOWNLOAD="http://neverball.org/neverball-1.5.4.tar.gz"
+MD5SUM="c523b0f72c2035831310e821162f7bd7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Frank Caraballo"
-EMAIL="<fecaraballo{at}gmail{dot}com>"
+MAINTAINER="Brad Hermanson"
+EMAIL="apeitheo@gmail.com"
APPROVED="dsomero"
diff --git a/games/neverball/slack-desc b/games/neverball/slack-desc
index 5eb38597ce..7fa5d00a28 100644
--- a/games/neverball/slack-desc
+++ b/games/neverball/slack-desc
@@ -14,6 +14,6 @@ neverball: and entirely a test of skill. Also found here is Neverputt, a
neverball: hot-seat multiplayer miniature golf game using the physics and
neverball: graphics of Neverball.
neverball:
-neverball: Homepage: http://icculus.org/neverball/
+neverball: Homepage: http://neverball.org/
neverball:
neverball: