summaryrefslogtreecommitdiffstats
path: root/gis/Fiona/Fiona.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-13 19:30:23 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-17 08:51:42 +0700
commitcae292ad6537dd3685c61b87394d275703366cd8 (patch)
tree9048704e37a4dbc699ed30fcc1c269ab06677cd3 /gis/Fiona/Fiona.SlackBuild
parent9b7df41a167cd7eb605ee4feafd6e94e924da3bb (diff)
downloadslackbuilds-cae292ad6537dd3685c61b87394d275703366cd8.tar.gz
slackbuilds-cae292ad6537dd3685c61b87394d275703366cd8.tar.xz
gis/Fiona: Add Python 3 support.
Diffstat (limited to 'gis/Fiona/Fiona.SlackBuild')
-rw-r--r--gis/Fiona/Fiona.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/gis/Fiona/Fiona.SlackBuild b/gis/Fiona/Fiona.SlackBuild
index 0e7c2f8655..a6f3c21f3d 100644
--- a/gis/Fiona/Fiona.SlackBuild
+++ b/gis/Fiona/Fiona.SlackBuild
@@ -64,15 +64,18 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.txt CREDITS.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION