summaryrefslogtreecommitdiffstats
path: root/gis/cligj/cligj.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-13 22:44:11 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-17 08:51:43 +0700
commitf8afedac7ee1e819bca29d772e19c14fe66100a1 (patch)
tree25fab70e5f745455aadddc1b56a2047b96b86be9 /gis/cligj/cligj.SlackBuild
parentb7ad3c60c84b809e95e03847978c1e99aab26be7 (diff)
downloadslackbuilds-f8afedac7ee1e819bca29d772e19c14fe66100a1.tar.gz
slackbuilds-f8afedac7ee1e819bca29d772e19c14fe66100a1.tar.xz
gis/cligj: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis/cligj/cligj.SlackBuild')
-rw-r--r--gis/cligj/cligj.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/gis/cligj/cligj.SlackBuild b/gis/cligj/cligj.SlackBuild
index 27bf63b894..df3778b307 100644
--- a/gis/cligj/cligj.SlackBuild
+++ b/gis/cligj/cligj.SlackBuild
@@ -31,7 +31,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -62,16 +62,19 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION