summaryrefslogtreecommitdiffstats
path: root/gis/geojson
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-14 23:07:55 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-17 08:51:43 +0700
commit0241d3c40e288ac5aab1784668192f1c202d644c (patch)
treebed15bc31f1e4e7d228d46965939119a375c0ad6 /gis/geojson
parentd8fb6076da00cd74ee6da5373d543f0979e8edf9 (diff)
downloadslackbuilds-0241d3c40e288ac5aab1784668192f1c202d644c.tar.gz
slackbuilds-0241d3c40e288ac5aab1784668192f1c202d644c.tar.xz
gis/geojson: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis/geojson')
-rw-r--r--gis/geojson/geojson.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/gis/geojson/geojson.SlackBuild b/gis/geojson/geojson.SlackBuild
index 3ce4921bff..61e2f26e3a 100644
--- a/gis/geojson/geojson.SlackBuild
+++ b/gis/geojson/geojson.SlackBuild
@@ -67,9 +67,12 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true