summaryrefslogtreecommitdiffstats
path: root/gis/ossim
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2018-04-27 21:35:06 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-28 06:30:54 +0700
commitea42ea2a6d059e7aa5b040630a3966ecf3c3cdae (patch)
tree54a88952058fd407070c102d31ab16b3d336f75d /gis/ossim
parent6c2ff927e738ba8c7950a414371cc82253d541a1 (diff)
downloadslackbuilds-ea42ea2a6d059e7aa5b040630a3966ecf3c3cdae.tar.gz
slackbuilds-ea42ea2a6d059e7aa5b040630a3966ecf3c3cdae.tar.xz
gis/ossim: Added (geospatial tools).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/ossim')
-rw-r--r--gis/ossim/README6
-rw-r--r--gis/ossim/ossim.SlackBuild113
-rw-r--r--gis/ossim/ossim.info10
-rw-r--r--gis/ossim/slack-desc19
4 files changed, 148 insertions, 0 deletions
diff --git a/gis/ossim/README b/gis/ossim/README
new file mode 100644
index 0000000000..f46c66389e
--- /dev/null
+++ b/gis/ossim/README
@@ -0,0 +1,6 @@
+OSSIM is a powerful suite of geospatial libraries and applications used to
+process imagery, maps, terrain and vector data. The software has been under
+active development since 1996 and is deployed across a number of private,
+federal and civilian agencies.
+
+Optional dependencies: hdf5.
diff --git a/gis/ossim/ossim.SlackBuild b/gis/ossim/ossim.SlackBuild
new file mode 100644
index 0000000000..7130bd0f02
--- /dev/null
+++ b/gis/ossim/ossim.SlackBuild
@@ -0,0 +1,113 @@
+#!/bin/sh
+
+# SlackBuild script for ossim
+
+# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ossim
+RELNAM=Gasparilla
+VERSION=${VERSION:-2.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$RELNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_LIBRARY_DIR:PATH=/usr/lib${LIBDIRSUFFIX} \
+ -DINSTALL_ARCHIVE_DIR:PATH=/usr/lib${LIBDIRSUFFIX} \
+ -DBUILD_GDAL_PLUGIN=ON \
+ -DBUILD_OSSIM_APPS=ON \
+ -DBUILD_OSSIM_FREETYPE_SUPPORT=ON \
+ -DBUILD_OSSIM_GUI=ON \
+ -DBUILD_OSSIM_HDF5_SUPPORT=ON \
+ -DBUILD_OSSIM_ID_SUPPORT=ON \
+ -DBUILD_OSSIM_PLANET=ON \
+ -DBUILD_OSSIM_WMS=ON \
+ -DBUILD_OSSIM_VIDEO=ON \
+ -DBUILD_SHARED_LIBS=ON \
+ ..
+
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.txt README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/ossim/ossim.info b/gis/ossim/ossim.info
new file mode 100644
index 0000000000..59f2592360
--- /dev/null
+++ b/gis/ossim/ossim.info
@@ -0,0 +1,10 @@
+PRGNAM="ossim"
+VERSION="2.3.1"
+HOMEPAGE="https://trac.osgeo.org/ossim/"
+DOWNLOAD="https://github.com/ossimlabs/ossim/archive/Gasparilla-2.3.1/ossim-2.3.1.tar.gz"
+MD5SUM="e5b63480a8e8d79c45f9af31879f1c14"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="geos jsoncpp libgeotiff"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/ossim/slack-desc b/gis/ossim/slack-desc
new file mode 100644
index 0000000000..e17fcb0e55
--- /dev/null
+++ b/gis/ossim/slack-desc
@@ -0,0 +1,19 @@
+#/ossim-2.3.1 HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ossim: ossim (geospatial tools)
+ossim:
+ossim: OSSIM is a powerful suite of geospatial libraries and applications
+ossim: used to process imagery, maps, terrain and vector data. The software
+ossim: has been under active development since 1996 and is deployed across a
+ossim: number of private, federal and civilian agencies.
+ossim:
+ossim:
+ossim:
+ossim:
+ossim: