summaryrefslogtreecommitdiffstats
path: root/gis/pyproj
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-16 23:12:02 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-24 06:50:34 +0700
commit252a01dff2e558e63ed5997320aeee88e994651d (patch)
tree6755fee1e0723f5a9fa309f7204b05d6c0bcbe43 /gis/pyproj
parent1e0ce2dbe2c56209e9e5de1406492fa6dd7ad3e1 (diff)
downloadslackbuilds-252a01dff2e558e63ed5997320aeee88e994651d.tar.gz
slackbuilds-252a01dff2e558e63ed5997320aeee88e994651d.tar.xz
gis/pyproj: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis/pyproj')
-rw-r--r--gis/pyproj/pyproj.SlackBuild27
-rw-r--r--gis/pyproj/pyproj.info2
2 files changed, 17 insertions, 12 deletions
diff --git a/gis/pyproj/pyproj.SlackBuild b/gis/pyproj/pyproj.SlackBuild
index 3e4884d123..1f55484da7 100644
--- a/gis/pyproj/pyproj.SlackBuild
+++ b/gis/pyproj/pyproj.SlackBuild
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -60,22 +60,27 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-${VERSION}rel
-tar xvf $CWD/$PRGNAM-${VERSION}rel.tar.gz || tar xvf $CWD/v${VERSION}rel.tar.gz
+tar xvf $CWD/$PRGNAM-${VERSION}rel.tar.gz
cd $PRGNAM-${VERSION}rel
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a Changelog LICENSE_proj4 LICENSE_proj4 README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ Changelog LICENSE_proj4 LICENSE_proj4 README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/gis/pyproj/pyproj.info b/gis/pyproj/pyproj.info
index 37afaec583..6056aa2b01 100644
--- a/gis/pyproj/pyproj.info
+++ b/gis/pyproj/pyproj.info
@@ -1,7 +1,7 @@
PRGNAM="pyproj"
VERSION="1.9.5.1"
HOMEPAGE="https://github.com/jswhit/pyproj"
-DOWNLOAD="https://github.com/jswhit/pyproj/archive/v1.9.5.1rel.tar.gz"
+DOWNLOAD="https://github.com/jswhit/pyproj/archive/v1.9.5.1rel/pyproj-1.9.5.1rel.tar.gz"
MD5SUM="38126f5b25a09ec2b6ee488613c717d8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""