summaryrefslogtreecommitdiffstats
path: root/gis/pyproj
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2014-02-02 06:40:44 +0700
committer Robby Workman <rworkman@slackbuilds.org>2014-02-02 02:09:49 -0600
commit391aa7c2ed513bdcd9768e8afc357d840e29b94c (patch)
treeea280f0bd2be3eb8fea8742d013f4c17bcac22f1 /gis/pyproj
parent521c8a6af538c2a981b1fa259b06366958e8efe2 (diff)
downloadslackbuilds-391aa7c2ed513bdcd9768e8afc357d840e29b94c.tar.gz
slackbuilds-391aa7c2ed513bdcd9768e8afc357d840e29b94c.tar.xz
gis/pyproj: Moved from Academic category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/pyproj')
-rw-r--r--gis/pyproj/README16
-rw-r--r--gis/pyproj/pyproj.SlackBuild85
-rw-r--r--gis/pyproj/pyproj.info10
-rw-r--r--gis/pyproj/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/gis/pyproj/README b/gis/pyproj/README
new file mode 100644
index 0000000000..b86dd367a6
--- /dev/null
+++ b/gis/pyproj/README
@@ -0,0 +1,16 @@
+Performs cartographic transformations and geodetic computations.
+
+The Proj class can convert from geographic (longitude,latitude) to native map
+projection (x,y) coordinates and vice versa, or from one map projection
+coordinate system directly to another.
+
+The Geod class can perform forward and inverse geodetic, or Great Circle,
+computations. The forward computation involves determining latitude, longitude
+and back azimuth of a terminus point given the latitude and longitude of an
+initial point, plus azimuth and distance. The inverse computation involves
+determining the forward and back azimuths and distance given the latitudes and
+longitudes of an initial and terminus point.
+
+Input coordinates can be given as python arrays, lists/tuples, scalars or
+numpy/Numeric/numarray arrays. Optimized for objects that support the Python
+buffer protocol (regular python and numpy array objects).
diff --git a/gis/pyproj/pyproj.SlackBuild b/gis/pyproj/pyproj.SlackBuild
new file mode 100644
index 0000000000..967b615712
--- /dev/null
+++ b/gis/pyproj/pyproj.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for pyproj
+
+# Copyright 2013 Benjamin Trigona-Harany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyproj
+VERSION=${VERSION:-1.9.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changelog LICENSE_geographiclib LICENSE_proj4 PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/pyproj/pyproj.info b/gis/pyproj/pyproj.info
new file mode 100644
index 0000000000..5120f16dab
--- /dev/null
+++ b/gis/pyproj/pyproj.info
@@ -0,0 +1,10 @@
+PRGNAM="pyproj"
+VERSION="1.9.3"
+HOMEPAGE="http://code.google.com/p/pyproj"
+DOWNLOAD="http://pyproj.googlecode.com/files/pyproj-1.9.3.tar.gz"
+MD5SUM="ad0ac0602b6373c4203b4d0774445694"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="proj"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/pyproj/slack-desc b/gis/pyproj/slack-desc
new file mode 100644
index 0000000000..b7fe3654f8
--- /dev/null
+++ b/gis/pyproj/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyproj: pyproj (Python interface to the PROJ.4 library)
+pyproj:
+pyproj: pyproj can convert from geographic (longitude,latitude) to native
+pyproj: map projection (x,y) coordinates and vice versa, or from one map
+pyproj: projection coordinate system directly to another.
+pyproj:
+pyproj: Homepage: http://code.google.com/p/pyproj/
+pyproj:
+pyproj:
+pyproj:
+pyproj: